USER MANUAL...
Wings’ modular® software manual
version 5
Copyright © 2001-2010, Wings Systems Ltd. All rights reserved.

The contents of this manual and the associated software are the property of Wings Systems Ltd. No parts of this publication or the accompanying software may be reproduced, adapted, copied or distributed, transmitted, transcribed, stored in a retrieval system or translated into any human or computer language, in any form or by any means, electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party.

Trademarks: Wings’ modular, Wings’ modular, Wings’ XP and Wings Systems, are trademarks and/or registered trademarks of Wings Systems Ltd. All other trademarks are the property of their respective owners. All rights reserved.

Important:
Your use of modular® software is subject to the Wings Systems Limited Software License Agreement. To view the Software License Agreement, please refer to “Help > About” dialog of the Software.

Notice, Warranties and Disclaimers:
All information is provided "as is" without warranty of any kind, either express or implied, including, but not limited to, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. Wings Systems Ltd. assumes no responsibility for errors or omissions in the information, or software, or other documents, which are referenced by or linked to this manual. References to corporations, their services and products, are provided "as is" without warranty of any kind, either express or implied. In no event shall Wings Systems Ltd. or its officers, employees or affiliates be liable for any special, incidental, indirect or consequential damages of any kind, or any damages whatsoever, including, without limitation, those resulting from loss of use, data or profits, whether or not advised of the possibility of damage, and on any theory of liability, arising out of or in connection with the use or performance of this information. This information is provided for informational purposes only, and while Wings Systems Ltd. is confident in its accuracy, please note that this manual could include technical or other inaccuracies or typographical errors. Changes are periodically added to the information herein; these changes will be incorporated in new editions of this manual. Wings Systems Ltd. may make improvements and/or changes in the product(s) and/or the program(s) described in this manual at any time.

Contact:
Wings Systems Ltd.
info@wingssystems.com
info@wingsmodular.com

www.wingsmodular.com
www.wingssystems.com

Last update, January 2010
# Contents

## CHAPTER 1 - FEATURES OVERVIEW ................................................................. 8

Introduction .................................................................................................. 8

Features overview ...................................................................................... 8

- General features: ................................................................................... 8
- Editing features: ................................................................................... 8
- Viewing features: .................................................................................. 9
- New features .......................................................................................... 10

Online resources ....................................................................................... 11

Wings’ modular® help ............................................................................... 16

## CHAPTER 2 - WORKING WITH FILES .......................................................... 17

Introduction ............................................................................................ 17

Workspace tour ......................................................................................... 17

- Introduction ......................................................................................... 17
- Title bar ............................................................................................... 18
- Main menu bar .................................................................................... 18
- Icon Toolbars ...................................................................................... 18
- Design area .......................................................................................... 20
- Context menus ..................................................................................... 20
- Status bar ............................................................................................. 21

Roll up windows (Tool windows) ............................................................ 21

Customizing Wings’ modular® workspace ............................................. 22

Using tool windows ................................................................................. 23

Moving tool windows ............................................................................. 23

Resize tool windows ............................................................................... 23

Docking Tool Windows ........................................................................... 24

Hiding Tool Windows (Auto hide) .......................................................... 24

Create a New design ................................................................................ 25

Vector and Bitmap graphics ..................................................................... 28

Open a design .......................................................................................... 30

- Icon Browser ....................................................................................... 31

Read diskette ........................................................................................... 33

Recent Files ............................................................................................ 34

Save as your design ................................................................................ 40

Save your design .................................................................................... 40

Auto-backup mechanism ......................................................................... 42

Format Floppy ......................................................................................... 43

Write Floppy ............................................................................................ 44

Supported file formats ............................................................................ 45

Import 8-channel tape ............................................................................. 46

Last tape imported ................................................................................ 47

Export to 8-channel tape ....................................................................... 49

Export to DXF format ............................................................................. 49

Export embroidery image ....................................................................... 49

- Changing image resolution ............................................................... 50
- Include fabric option ......................................................................... 51
- Include backdrop option ................................................................... 51

Serial connection with Embroidery machines ...................................... 51

Send through e-mail ............................................................................... 52

Closing – Exit .......................................................................................... 53

Close ......................................................................................................... 53
Wings’ modular® Embroidery Software manual

Table of contents

Close all.......................................................................................................................... 53
Quit ................................................................................................................................. 53

Window.......................................................................................................................... 54
Tile horizontal .................................................................................................................... 54
Tile vertical ......................................................................................................................... 54
Cascade ............................................................................................................................. 54
All iconic ........................................................................................................................... 54

Printing .......................................................................................................................... 54
Print .................................................................................................................................... 54
Printer Setup .................................................................................................................... 55
Print items ........................................................................................................................ 55
Tiled printout .................................................................................................................... 59

Active designs modifications ....................................................................................... 60

CHAPTER 3 - MAKE SELECTIONS............................................................................... 64

Introduction ..................................................................................................................... 64
Selection with mouse ......................................................................................................... 64
Select all ........................................................................................................................... 65
Select none ....................................................................................................................... 65
Invert selection .................................................................................................................. 65
Select by color .................................................................................................................... 65
Select by special function ............................................................................................... 65
Select by stitch type ......................................................................................................... 67
Select by Preset ................................................................................................................. 67

CHAPTER 4 - VIEW YOUR DESIGNS........................................................................... 69

Introduction ..................................................................................................................... 69
Zoom tools ......................................................................................................................... 69
Zoom In ............................................................................................................................. 69
Zoom Back ........................................................................................................................ 70
Zoom All ............................................................................................................................ 70
Pan ..................................................................................................................................... 70
Mouse Pan ......................................................................................................................... 71
Zoom Out by 25% .............................................................................................................. 71

Change view port ............................................................................................................ 71
Image map .......................................................................................................................... 71
Zoom tools on Modes toolbar ......................................................................................... 72
Using keyboard and mouse shortcuts ............................................................................. 73
Zoom preset ....................................................................................................................... 73

Reviewing your work - Embroidery process simulation .................................................. 73
Moving through Objects/Stitches ..................................................................................... 74
Slow redraw ....................................................................................................................... 74

Preview 3D ...................................................................................................................... 76
Set light source ................................................................................................................. 77
Hide .................................................................................................................................. 78
Show hidden objects ........................................................................................................ 78
Show Stitch Marks ........................................................................................................... 79
Show Up to Cursor .......................................................................................................... 79
Show Filled Outlines ....................................................................................................... 79
Measure tool ..................................................................................................................... 80
Ruler ................................................................................................................................... 81
Guidelines ......................................................................................................................... 81
Horizontal Guidelines .................................................................................................... 82
Vertical Guidelines .......................................................................................................... 83
Diagonal Guidelines ........................................................................................................ 83

Wings systems L.t.d. All rights reserved Copyright © 2001-2010
**Table of contents**

- Circle guidelines .................................................................................................................. 84
- Guidelines options ................................................................................................................ 85
- **Toggle Grid** ...................................................................................................................... 87
- **Crosshair** ........................................................................................................................ 88
- **Design info** ....................................................................................................................... 89
  - General .................................................................................................................................. 89
  - Summary .............................................................................................................................. 90
  - Yarn ...................................................................................................................................... 91
  - Stitches ............................................................................................................................... 92
  - Sequins ............................................................................................................................... 96
- **Color Management** .......................................................................................................... 96
  - Color tables ...................................................................................................................... 97
  - Current palette .................................................................................................................. 98
  - Number of available colors ............................................................................................. 99
  - Preview in Color management ......................................................................................... 99
  - New Color ......................................................................................................................... 100
  - Edit Color ......................................................................................................................... 102
  - Delete color ...................................................................................................................... 102
- **Backdrop** ......................................................................................................................... 102
  - Import Bitmap/Vector backdrop ...................................................................................... 102
  - Backdrop properties ....................................................................................................... 102
  - Straighten Bitmap ........................................................................................................... 104
- **Change fabric** .................................................................................................................. 105
  - Fabric categories ............................................................................................................. 106

**CHAPTER 5 - OPERATIONS** ............................................................................................ 107

- **Introduction** .................................................................................................................... 107
  - Redo .................................................................................................................................. 107
- **Transform** ......................................................................................................................... 107
  - Move ................................................................................................................................... 108
  - Rotate .................................................................................................................................. 108
  - Scale .................................................................................................................................... 109
  - Alignment ........................................................................................................................... 110
- **Transform with mouse** ................................................................................................. 111
  - Move objects .................................................................................................................... 111
  - Scale objects .................................................................................................................... 113
  - Rotate objects ................................................................................................................... 114
  - Slant objects ..................................................................................................................... 115
  - Mirror objects .................................................................................................................. 115
  - Repeat last transform - R ............................................................................................... 116
- **Re-order** ......................................................................................................................... 116
  - Sequence manager .......................................................................................................... 116
  - To back - Home ................................................................................................................ 119
  - To Front - End .................................................................................................................... 120
  - One step backward - PgDn ............................................................................................. 120
  - One step forward - PgUp ................................................................................................ 120
- **Object editor/Transform menu** ...................................................................................... 121
  - Order ................................................................................................................................. 121
  - Group – Ungroup ............................................................................................................. 122
  - Break apart ....................................................................................................................... 122
  - Clear transform ................................................................................................................. 122
- **Group** .............................................................................................................................. 123
- **Ungroup** .......................................................................................................................... 123
Cut ................................................................. 123
Copy ........................................................... 123
Paste ........................................................... 123
2-point copy ................................................. 124
Copy an object from one design to another ........................................... 126
Duplicate design .................................................................................. 126
Split objects ....................................................................................... 126
Density adjustment ............................................................................ 127
  Change Stitch-count .......................................................................... 127
  Auto-density Apply ........................................................................... 127
  Auto-density Reset ........................................................................... 128
Modify Satin width ................................................................................ 128
  Change satin width ........................................................................... 128
  Direction ........................................................................................... 129
Filter ...................................................................................................... 129
  In Stitch data objects ......................................................................... 129
  In Punching data objects ................................................................. 130
Reverse ................................................................................................. 131
  In Stitch data objects ......................................................................... 131
  In Punching data objects ................................................................. 131
Add new objects to end (Ctrl+Shift+E) .................................................. 131
Array/Kaleidoscope ............................................................................... 131
  Rectangular array ............................................................................... 132
  Circular array .................................................................................... 134
Divide ..................................................................................................... 137
Special functions toolbar ....................................................................... 139
  Sequin options .................................................................................. 140
Edit step pattern ................................................................................... 141
Design Start/End point .......................................................................... 143
  Move design start .............................................................................. 143
  Move design end ............................................................................... 143
  Return to design start ........................................................................ 143
  Move design Start & End .................................................................... 144
Presets .................................................................................................... 144
Reset object properties ......................................................................... 145

CHAPTER 6 - STITCH EDITOR ................................................................ 146
Introduction ............................................................................................ 146
View direction of stitches ......................................................................... 146
Selections in stitch editor ......................................................................... 146
  Rectangle selection ............................................................................ 147
  Single click selections ......................................................................... 149
Move stitches ........................................................................................... 150
  Snap movements ................................................................................ 150
  All directions movement .................................................................... 151
Add stitches ............................................................................................. 152
Delete stitches ........................................................................................ 152
Replace stitches ....................................................................................... 152
Remove small .......................................................................................... 153
Move outline ............................................................................................ 154

CHAPTER 7 - NODE EDITOR ................................................................ 156
Introduction ............................................................................................. 156
What is a node ........................................................................................ 156
What is a direction .................................................................................................................. 156
Edit punching nodes .............................................................................................................. 157
    Select Node(s) .................................................................................................................. 157
    Move node(s) .................................................................................................................. 157
    Change the tangents of a node ......................................................................................... 158
    Delete a node .................................................................................................................. 159
    Insert a node ................................................................................................................... 159

Punching nodes editor menu .................................................................................................. 159
    Smooth node .................................................................................................................. 160
    Cusp node ....................................................................................................................... 160
    To lines ............................................................................................................................ 161
    Fit to curve ....................................................................................................................... 161
    Add direction .................................................................................................................... 161

CHAPTER 8 - VENERE CUTTING SYSTEM ................................................................................. 162

Introduction ............................................................................................................................ 162
Venere cutting system ............................................................................................................ 162
    Apply Venere cutting system.......................................................................................... 163
    Venere cutting printout.................................................................................................... 164
    Venere cut Running options .......................................................................................... 165

CHAPTER 9 - OPTIONS ............................................................................................................. 167

Introduction ............................................................................................................................ 167
Tools⇒Options ....................................................................................................................... 167
    Display ............................................................................................................................. 167
    Printing ............................................................................................................................. 169
    General ............................................................................................................................. 171
    3D properties .................................................................................................................. 173
    Key ................................................................................................................................. 174
    Colors (Design tools color scheme) ................................................................................ 176
    Workspace ...................................................................................................................... 184

CHAPTER 10 - EDITING EMBROIDERY DESIGNS .................................................................. 186

Introduction ............................................................................................................................ 186
Create Artistic Designs with transformation tools .................................................................. 186
Artistic Mirroring designs ..................................................................................................... 187

APPENDIX A: GLOSSARY ..................................................................................................... 190

Cancel ...................................................................................................................................... 190
Field types.............................................................................................................................. 190
Mouse Terminology .............................................................................................................. 190
Ok .......................................................................................................................................... 191
Scroll bar .............................................................................................................................. 191
Stitch data Objects .............................................................................................................. 191
Track – bar ......................................................................................................................... 191
Punching data objects ......................................................................................................... 192
What is a section .................................................................................................................. 192
What is a node ...................................................................................................................... 193
What is a direction ............................................................................................................... 193

APPENDIX B: HOT KEYS – QUICK REFERENCE CARD .......................................................... 195

INDEX ..................................................................................................................................... 200
Chapter 1 - Features overview

Introduction

“Wings’ modular” is a full working software split in modules. It includes 14 modules which are activated separately. “Basic-Connect Module” is the first and most important module because contains the basic parts of the software. In the following sections we will analyze the features or “Basic-connect Module” and explain how can be applied in any design.

The “Basic-Connect Module” includes the standard interface, scaling design capabilities, simple design editing, image database management and all supported floppy formats. All will be explained analytically in the following sections.

Also, this module contains all modular’s connection tools. It is important module for those who want to connect their computer directly with their embroidery machine or import/export to an 8-channel tape and memory boxes.

Features overview

Wings’ modular® software includes many features just to help you create the designs you want with the quickest and easiest way. An overview of the features that all Wings’ modular® modules include is listed below.

General features:

- Browsers as a separate window helps the user find, load, print and view the information of the designs from the current folder. 2-size icons are also available in Browser Options.
- Printing Catalogs are also available in Browser Options.
- Full Design Information is available for every design with:
  - General information about the design.
  - Number of stitches per length (Histogram).
  - Calculation of needed production time.
  - Calculation of exact number of stitches per machine type.
  - Printable notes are also available.
  - Precise calculation of the needed yarn and bobbin length. Bobbin detention and fabric thickness can also change the above-mentioned calculations.
- Search function even with Customer-Designer-Keyboard.
- Customer Designer and Keyboard fields are also available in the "Save As" dialogue and can be filled in accordingly.
- Read machine disk parameters are also available in File/Open dialogue.
- MS-Agent gives you information and instructions if and when needed.
- Dockable toolbars.
- Capability to use up to 99 needle colors per design.
- Ability to change colors, or create your own, and even edit existing colors.
- Manual or automatic conversion by proximity of existing color palettes.
- Roll-ups can be made semi-transparent so the users can "see" behind them, without closing them. It's even possible to digitize behind the semi-transparent roll-ups.
- Active (Loaded) Designs Controller
  - Visible 2 size icons for every loaded design or detailed information.
  - Full control of all loaded designs or on the selected ones.
  - Printable designs (one or more designs per page) with full printing layout control.
  - Save in a hard disk as .ngs or machine type format.
  - Write in a machine floppy disk.
  - Intelligent selection of loaded designs for use with more than 1 machine disks. Format command is also available.
- Convenient "Rubber-Banding" information which appears next to the mouse cursor (in a semi-transparent yellow box), instead of the status line.
- Ability to read most common images (vector or bitmap) as backdrops.
- Ability to scan an image and save it as "JPEG" file.
- Wings' modular® creates a link between the design and the backdrop to avoid creating large files. Full access and control on these links.
- In the software, we included an advanced printout engine, able to make customizable printouts of the design. It is possible to generate catalogs, in portrait and landscape form, with user-selectable number of icons.
- The program has hot keys for fast access of the most used functions.

**Editing features:**

- Clean up expert. An easy and fast way to correct small stitches, functions and exit/entry points of the current design. (Removes unnecessary stitches which can cause problems).
- Auto branching.
- Tacking as part of the underlay. (This way, you can create the same design with fewer stitches and no delays in production).
- Erase/Trace outline. You can convert the stitch data objects to punching and vice-versa. The result of this function has the least possible objects/sections.
- Clipart. A powerful tool which allows you to use pre-punched parts of designs or even create and save your own.
- Filter function corrects density and shape errors of stitch data designs.
• Sequence Manager in two levels, makes it easy to re-order and change the sequence of the objects.
• Cut-Copy-Paste. A classic way to move parts of one design to another design or application.
• Roll ups. Semi-transparent, easy to hide/show or resize.
• Object properties. This roll up helps you see and change the parameters of the selected object. Multiple inputs even with mouse wheel.
• Ability to call or create specific effect settings or assign an object to a specific effect.
• Node editor. Easy to edit the outlines of the design by using Bezier curves.
• Transform. You can edit the sections of the designs without recalculating.
• Easy access and change of special functions of objects with a single mouse click.
• "Complex Pattern Editor" is a powerful tool where you can create or edit your own or existing patterns. This can be done by:
  • Predefined Shapes
  • User defined polylines.
  • User defined areas with simple patterns.
  • All of the above mentioned functions can be edited as vector lines before they can transformed into stitches.
  • Manually insert or delete stitches of the patterns.
  • Three dimensional realistic previews of the created/edited patterns.
  • The program allows the user to view the repeats of the created/edited patterns in normal or 3-D realistic preview.
  • Undo/Redo options in pattern editor.
  • The program shows the minimum length of the stitches in order to avoid thread trims.
  • The length of the pattern can automatically be changed by the program.
• Horizontal, Vertical, Diagonal or Circled guidelines. Snapping function is also available on the guidelines.
• Advanced Style Editor with move-insert-delete functions for every node or move and mirror the whole style. It can calculate the smallest possible size that the given style can be generated. The length of the style can automatically be changed by the program.
• Text Input with multi-language support. You can also use IME (Input Methods Editor) or "Text" dialog for East Asian languages.
• Full control of the shape, size, position and path of the inserted text.
• Full control of the kerning and the space between the lines and the words of the input text.
• Full access in any parameter of the stitches of punched objects.

Viewing features:
- Show filled outlines. A powerful tool that shows the area with stitches. This way you can re-order the object of the design or pass the tacking stitches.
- Image map, helps you change the view port or Zoom in/out quickly and easily.
- Full zoom in / zoom out or pan capabilities.
  - Fixed zoom scales
  - Zoom function with right mouse click
  - Scroll bars also available
  - Manual panning for all modes
  - Auto panning during punching
- Auto zoom of a specific area for a more detailed stitch quality control.
- Hide/Show functions are available for easier processing of specific objects.

**New features**

- **New interface and new 3D working space**
  
  Wings' modular embroidery software is now coming with a totally new interface that allows you to digitize in 3D mode. This new technology allows you to create designs faster and load larger designs with millions of stitches and sequins.

- **Add envelope on a shape manually.**
  
  Right click on a shape and select Add > Envelope option. Select the Manual option and create a shape by defining pair of nodes. Each pair of nodes defines a subsection of the object that you can edit inside Node editor, afterwards.

- **In the “New design” dialog you can define the number of colors you want the design to have. Also the same adjustment can be made inside the Color manager.**
  
  You can now create designs that will have from 1 up to 99 thread colors. This is very useful when you want to embroider complex designs that have many colors and you need to change threads more than one times.

- **In the “File > Design info” dialog a new tab is added that stores useful information about sequins**
  
  This is very useful for designs that consist of many different types/colors of sequins. You can have an overview of the sequins that will be inserted in the design and make decisions easier.

- **Customize the color and the thickness of all inserted outlines. This option is available at Tools>Options> Colors tab.**
By customizing the color and the thickness of all inserted outlines, you can utilize the advanced 3D workspace and work more efficiently.

- **Produce more realistic 3D effects on your embroidery designs by changing the light source.**

  This option is available at “View>Set light source” option while you are in 3D mode. Drag on the ball to change the light source. This can help simulate better the actual lightning conditions that you have near your embroidery machines.

- **Export the 3D realistic embroidery preview to embroidery look image and use it for textile printing or for promoting your work.**

  Select “File>Export>To image…”. At the bottom of the dialog you will find the available options. Use .PNG files for transparent background.

- **Now you can change any embroidery object to Venere cutwork object and create beautiful designs that will include cutwork.**

  Right click on any object and select “Change to >Venere” (only for those that have Venere option enabled). The Venere cutwork needles can produce perfect cutwork results and save you money from buying expensive laser cutters.

- **Add directions and Divides (to Satin, Zig-Zag and Piping) any time you want and redesign existing objects easily.**

  Right click on a shape filled with Satin, Zig-Zag or Piping and select “Change to> Edit dirs and Cuts” option (with ‘D’ you can change between directions and cuts). All directions and cuts will be removed of the design and you will be able to add them again in the way you prefer.

- **Support for newer versions of .AI vector file format.**

  The importer of .AI vector files has been improved and now you can load newer versions of illustrator files.

- **Special support for SWF double sequins while opening existing designs and while creating new ones.**

  In the “New design” dialog you can select the “SWFSequins_White.ngs” or “SWFSequins_Black.ngs” template and create a design based on SWF mechanism. Also, in file open dialog there is a new option at the bottom “Read sequins as SWF’s Dual Sequin System” that reads correctly the .dst files that were saved with the SWF macro.

- **Many improvements in performance and usability of the software. You can work with huge designs easier.**
No more difficulties with extra large designs. Wings’ modular can handle them without any problem and gain you time and effort. Those designs are no longer a headache for embroiderers. The responsiveness of the software has no competition in the market.

- **Fully customizable workspace according your preferences. Adjust it once and lose no time while creating embroidery designs.**

  You can reposition the toolbars and dockable rollups by click and dragging them. Also at the end of each toolbar you have some options that allow you to select which tools you want to view.

- **Use the mouse wheel on any tool and make changes quicker and easier.**

  The software recognizes the position of the mouse cursor and uses the roller on the specific tool that you are located.

- **View your designs easier by using the Mouse Pan functionality of the middle mouse click.**

  While you are working in the design area you can use the middle click (click the roller in) and switch to mouse pan mode. By moving the mouse towards the area you want to view, the view port changes smoothly and helps you navigate to your design without having to change zoom level. Left click to end panning.

- **Decide if you want to view stitches while you are inside node editor, and visualize how your changes affect the stitches without having to switch back to object editor.**

  Decide if you want to view stitches while you are inside node editor. Click ‘S’ to switch between the two modes and view immediately how the changes you are making on the outline of the design affect the stitches.

- **Circular Array tool**

  Circular Array tool is a great way to create stylish design arrays easily, without losing the ability to edit the design. Any change you are making on a single object is automatically applied in the entire array.

- **Apply 3D effect**

  With the new envelops that have been added you can create designs with 3D effect applied on them. Create unique design by combining styles with envelops easily with unlimited abilities on reshaping and fine tuning the design.

- **Curved direction of stitches**
By applying an envelope with a curved shape you have the ability to apply the envelope on the direction of stitches and see your stitches to follow a curve. This is a very useful and stylish effect for your designs.

- **Convert images to embroidery**
  Wings’ modular 5 has the ability to convert Vector and Bitmap graphic files to embroidery designs automatically. The only thing that is needed for you is to fine tune the design and send it to the embroidery machine. This feature can increase your productivity and decrease your effort without losing embroidery quality.

- **Trim objects and Remove overlaps**
  With the Trim tool you have the ability to reshape your designs by removing unneeded parts of them. You can create holes and reduce the number of stitches that will be embroidered by removing the overlapping parts.

- **Fill area with sequins**
  Wings’ modular now has the ability to fill an area with sequins. You can now create a style with sequins or use any of the existing ones and apply it on any stitch type that supports styles. You can fill Step, Piping, Satin and Zig-Zag objects with sequins with a simple selection of a style.

  You can also, set the direction of the applied style to produce the fish scale effect.

- **Weld objects**
  With the Weld tool you can weld two or more objects and produce unique shapes easily. It is also very useful when you want to create a large object by welding many smaller ones that cannot produce proper embroidery results.

- **Apply different style per line**
  With the One per line option, you have the ability to apply a different style on each row of the filled object. This is a great tool that can release your creativity.

- **Chenille stitch type**
  A new stitch type has been added that allows you to create design with Chenille easily. Also you have the ability to convert any stitch type to Chenille and give life to your older designs.

- **Slow redraw - Embroidery machine simulation**
With the slow redraw utility you can simulate the way the design will be embroidered without having to do that on the machine. Also you have the ability to simulate your machine speed and the movement of the needle carrier.

- **Adjust Bezier curves during digitizing**
  
  Wings' modular 5 now gives you more power during digitizing. You can adjust the Bezier curve of the node you have inserted and change its position at the same time. It is a very powerful option that will save you time and effort.

- **Copy attributes from one object to the other**
  
  Create designs even faster by copying attributes from one object to the other that will save you time and effort. You can copy attributes such as the "Color", the "Special Functions" applied, the "Object properties" options, the "Stitch type" and the "Transformations" that you have made.

- **Convert images to Photostitch automatically**
  
  The new feature for the available Photostitch stitch type of Wings' modular software is that now you can easily convert any image you have to Photostitch with CMYK (Cyan, Magenta, Yellow and Key(Black)) colors automatically. A step by step wizard can convert you image to photostitch. The results are perfect with chromatic realism of the embroidery result.

- **Convert symbols to perfect embroidery**
  
  Convert any symbol to perfect embroidery easily and quickly. Each symbol can become a complete embroidery design with a click. There are many symbols you can import in Wings’ modular® and convert them to stitches. Symbols are ready made artworks that have various shapes that also vary depending on the Font type you are using.

- **Rectangular Array/Kaleidoscope**
  
  With the advanced Rectangular array you have the ability to rotate and mirror the copies of the array without losing the ability to edit them and create easily unique designs. Also, you have the ability to create clones that will copy any transformation that you are doing on the source design.

- **Continuous design preview**
  
  With the Continuous design option you can view the embroidery design you have created multiplied on the working space vertically and horizontally. The copies of the original image are only viewable and not editable. This option is very useful for designing continuous designs that are creating beautiful patterns.

- **Improved Zig Zag stitch type**
Improvements were made on Zig-Zag stitch type and its underlays for even better embroidery quality. When we have a low density (wide) Zig-Zag, tacking is now generated with Zig-Zag, exactly under the cover stitches, increasing the embroidery quality.

- **New gradient fill presets**
  Select any of the 24 available gradient types and create beautiful embroidery designs. Blend different stitch colors easily by applying different gradient types on overlapping stitch objects.

- **Insert double sequins to your design**
  Create embroidery designs by using the double sequins mechanisms and produce unique artistic results. Fill areas with double sequins or insert double sequins anywhere inside the design with a single click.

### Online resources

More information about Wings’ modular® is available in the official site of Wings’ modular®: [www.wingsmodular.com](http://www.wingsmodular.com)

### Wings’ modular® help

Wings’ modular® help provides comprehensive information about all the features of the software. Wings’ modular® help is displayed in the help viewer provided by your operating system: Microsoft HTML Help. You can access help from "Help" menu by clicking on the "Contents" option. You can find the information you need in any of four ways:

- **The table of contents** enables you to see all of the information organized by subject. Click top-level entries to view subtopics.

- **The index**, like a traditional printed index, allows you to look up specific terms or concepts.

- **Search** allows you to find any character string, anywhere in the text of the help system.

- **Show help on** (Shift+ F1) is another way to access help for a specific tool, area, or function in Wings’ modular® and can be activated from the "Help" menu. When you activate show help on the mouse pointer turns to a pointer with a question mark. Click on any function you want to see help on and the respective subject will be displayed.
Chapter 2 - Working with files

Introduction

In this chapter we will present all the basic file operations. Saving-loading files (from or to any system disk or any removable media Floppy disk-removable drives). In order to able to better understand all tools we will first make a detailed description of workspace tools and customizations. Finally we will present all the available actions while working with already opened embroidery designs.

Finally you can learn how to create a new design and how you can edit it in modular.

Workspace tour

The main application window of Wings' modular® consists of a variety of menus, toolbars and tool windows, that together with the design area, they are called a workspace. A workspace is any combination of the above components. The way that workspace components and windows are placed is fully customizable. When opening the application for the first time all these tools are placed by default in a way to help you focus on your task (creating, editing and viewing embroidery designs). Make any arrangement on workspace components in order to have a workspace that matches your personal preferences. If you are familiar to previous versions of Wings' modular® software you will easily find and enjoy using all the design tools and components.

Introduction

Take some time using all the available workspace components. As you are getting more familiar with the tools and their usage you will improve your productivity. Let’s take a look at the tools and their default placement.

This is the main application window of Wings' modular® (Figure 2.1), with a design loaded on the design area. You can see on top "Title bar", "Main Menu bar", "Standard toolbar", "Special functions toolbar" and "Modes toolbar". You can also see the "Status bar" at the bottom of the window. Next to the design area on both left and right sides you can see tool windows (rollups), "Sequence manager", "Image map palette", "Object properties, Transform". Let’s take a closer look at all these components.
Title bar

This bar is located on the top of the application window. Most windows applications provide file information and window handling controls via this bar. The default location is on the top of any application window. Usually it provides file name and path of the currently used file. It also provides basic window handling controls (Minimize, Maximize, and Close). By double clicking on the title bar the application changes from maximized state to custom window state (Figure 2.2).

Main menu bar

Under the title bar is located the "Main menu" bar. This bar provides access to most of the commands that control the main functionality Wings’ modular. It consists of several menus, click on any of them (for example, File, Layout, Options) to see the included menu commands.
In any windows application there are usually a number of icon toolbars. They have shortcuts to dialog boxes or actions. Click on any icon of the program’s toolbars to see the performed action. You can also pause your mouse over any of the icons and a popup containing information about the action will appear. From "View" menu you can select any of the sub items of "Toolbars" item ("Modes", "Standard", "Special functions"), in order to select which toolbars will appear on workspace and which will not. On figure 2.3 you can see all 3 toolbars enabled and appearing on the workspace.

1. **Standard toolbar:**

   **Standard toolbar** (Figure 2.4) is a collection of buttons that serve as shortcuts for the basic functionality of the application. Most of these icons implement the same functionality in the majority of windows applications. If you are familiar to any windows application, you have used many times, operation tools such as "New file", "Open", "Save", "Cut", and "Paste". Although there are some tools that have similar icons to other tools from other applications but they serve different functionality. Be careful in order to avoid confusing their functionality. For example "Read Floppy", "Write floppy" icons look very much like the save icon that exists in most windows applications but they are a little different. Besides these basic file operations, in Standard toolbar, you can select "Zoom preset", use "selection tools" (Select all, Invert selection, select none). Show- Hide selected objects and finally there is a group of tools to help us simulate the way that the objects will be embroidered.

2. **Special functions toolbar**

   In this toolbar you can find the "color manager". This tool is used to edit the colors of the current design. "Create", "edit", "delete" existing colors, or make an alternative color selection. Next to the color manager you will find the "color palette". It consists of thread colors that also represent the needles of your embroidery machine. All available special functions are also included in this toolbar.

3. **Modes toolbar**

   Using this toolbar you can select working mode. You can switch between "Object editing", "Node editing" and "Stitch editing" mode. Edit the inserted OLE-2 objects. Auto-digitize and use various tools that improve quality of stitch objects.
**Design area**

The heart of Wings’ modular embroidery software is the "design area". All the tools, menus and functions exist to provide functionality useful during designing process. The design area is the rectangular area inside Wings’ modular application window. This area is used for creating and editing designs. Any tool you are using from any toolbar affects the creation inside the design area.

**Context menus**

The term "context menu" (shortcut menu or *pop-up menu*) is commonly used for menus which pop up when right clicking on an item inside the design area, offering a list of options. The available options vary depending on the context of the action and the item selected. For example different options appear
when right clicking on a design object than when clicking on a stitch object.

The available context menus of Wings’ modular are hierarchically organized, allowing navigation through different levels of the menu structure.

The context menu of the previous figure (Figure 2.7) is available only when right clicking on an object in object editing mode. Some of the applications functionality can only be revealed by specific context menus, that are available inside the Wings’ modular® design area. This kind of logic helps separates the available actions for each type of object. Select any object, right click on it and select a function of the appearing menu, just like that you can perform a number of designing tasks.

**Status bar**

The status bar displays information about selected objects (such as Width, Height, and Number of stitches). It also displays information while transforming objects about angle etc, information that assist in more accurate transformations.

While digitizing we can also see useful information about digitizing process.

**Roll up windows (Tool windows)**

There are various windows that contain tools or visual assistance to be used while designing.

1. **Image map**

Another very useful rollup window is "image map palette". If Image map palette window is not visible, select from "View" menu ➔ "Rollups" and then "Image Map" sub item. "Image map" shows the current view port of the design and allows you to change it by using the available viewing tools. "Zoom-in" to a portion of a design. "Zoom All", so you can see the whole design. Proportionally zoom-out the current design, by 25%.

2. **Sequence viewer/manager**
This tool provides a graphical representation of the embroidery sequence, together with the special functions that are applied on each object. It is often needed to change this sequence, in order to improve embroidery quality. Any item you select on sequence manager gets selected on the working area. Sequence manager can be called from the "View" menu "Rollups" item and sub item "Sequence manager". The extra ability of this tool is that you can re-arrange the sewing order for the current design, and select one or more objects. Therefore you can organize the sequence of embroidery production in the way you prefer.

3. Sequence manager rollup
4. Image map palette

**Customizing Wings’ modular® workspace**

We have described the workspace components and the purposes that they serve. Spend some time using them in order to understand how they are working. If you're a new user of Wings’ modular® software, you must be trying to sort out which tools are important to you, in order to have them in first sight. You can rearrange workspace components in order to serve your personal preferences and make a version of the perfect working environment for you.

*Wings’ modular® will remember the place that you last placed any workspace component.*

Take in consideration that the screen space depends on the screen resolution. If you have a large resolution it means more available space. So first of all set the best resolution that fits to your screen. Start Wings’ modular® software, make a few shapes, use some properties, add more shapes, and view the design objects in sequence manager. If the design space is not enough and the tools are crowded you must organize available tools.
To give you complete control over the size and position of the elements in the workspace, Wings’ modular® lets you move, resize, dock and auto hide most of the workspace components and make visible only the elements that you want to view. You can attach or dock tool windows to make more space visible. You can also partially conceal tools as tabbed documents along the edge of the workspace and then switch back. The exact size and shape of the tools and windows depend on how you have configured your designing environment to look like.

**Using tool windows**

Once a tool window is floating it has a title bar like the one in the following figure (figure 2.10). By double clicking on its title bar, it gets docked in the last position that it was docked. You can also close this tool window by pressing the in the upper right corner of the window.

You can always use a double click on the title bar to undock it. You can also close it by pressing the "Close" button in the upper-right corner of the window.

You can set the window in auto hide mode by pressing the "pushpin" . Finally you can press the arrow next to the pushpin and by selecting the respective options from, the appearing menu, select the state that you want this window to have (Figure 2.11). You can always open any closed window again later by selecting the appropriate command on the View menu rollups menu item.

**Moving tool windows**

To move one of the tool windows, simply click the title bar and drag it to a new location.

*Move Sequence Viewer tool window:*

1. If the Sequence Viewer window isn’t visible, select from "View" menu, “Rollups” item, "Sequence Manager" sub-menu item. Sequence Viewer
window will appear. (Basic-Connect modules does not have Sequence manager but instead they have Sequence viewer)

2. Double-click the "Sequence Viewer" tool window title bar to display the window as a floating (undocked) window.

3. Using "Sequence Viewer " window title bar, drag the window to a new location inside the application window, but don’t dock it. See how easily you can affect the position of the available tools.

**Resize tool windows**

If you want to see more of a tool window, simply drag one of its borders to view more content.

**Resize Sequence Viewer tool window**

Resize the "Sequence Viewer" tool window to have a better view of the available parameters. **Point your mouse** to the lower-right corner of the Object Properties window until the pointer changes to a **double-headed arrow** (the resizing pointer). **Drag** the lower-right border of the window down and to the right to enlarge the window. The same way, you can resize any tool window from any of its edges. You can work more quickly and with more clarity of purpose in a bigger window. Feel free to move or resize any tool window when you need to see more of its contents.

**Docking Tool Windows**

Dockable windows are advantageous because they always remain visible. (They don’t become hidden behind other windows.) If a tool window is floating over the design area, you can return it to its original docked position by double-clicking the window’s title bar. (Notice that you can use the same technique to undock a docked window. Double-clicking a title bar works like a **toggle**, a state that switches back and forth between two standard positions). You can also attach or dock a floating tool in a different place.

You can dock windows by using **docking guides**, as shown in the following figure below. Docking guides are icons that appear on the surface of the application window when you move a window or tool from a docked position to a new location. Because the docking guides are associated with shaded, rectangular areas of the application window, you can preview the results of your docking maneuver before you actually make it.
In case that you want to dock into a place where there other tools docked while you point over this control and see how the control will be docked only appear extra docking guides to help you decide how to place the window relative to the other docked window.
Dock on the left side under existing rollups | New docked position

Dock the Image map window

1. Verify that the Image map window (or another tool that you want to dock) is floating over the design area in an undocked position.

2. Drag the title bar of the Image map tool window to the top, bottom, right, or left edge of the design area. While dragging, take care to drag the mouse pointer over one of the docking guides (small arrows) on the edges of the Wings’ modular® window or the collection of four docking guides (called a diamond guide) in the center. As you move the mouse over a docking guide, the Properties window snaps into place, and a blue shaded rectangle indicates how your window will appear when you release the mouse button. There are several valid docking locations for tool windows, so you might want to try two or three different spots until you find the one that looks right to you.

3. Release the mouse button to dock the Image map window. The window snaps into place in its new home.

4. Try docking the Image map window several more times in different places to get the feel of how docking works.

You can always adjust the size of docked windows by simply dragging one of its borders to view more content.

Hiding Tool Windows (Auto hide)

If you want an option somewhere between docking and closing a window, you might try auto hiding a tool window at a side of the application window by clicking the tiny "Auto Hide" pushpin button on the right side of the tool’s title bar. When you auto hide a window, you'll notice that the tool window remains visible as long as you keep the mouse pointer in the area of the window. When you move the mouse to another part of the application window, the rollup slides out of view. To restore a window that you have auto hidden, click the tool tab at the edge of the application window or hold your mouse over the tab (You can recognize a window that is auto hidden because the pushpin in its title bar is pointing sideways.)

The benefit of enabling auto hide, of course, is that the process frees up additional design area while the hidden window is also quickly accessible.
Use the Auto Hide feature (Hide Sequence Viewer tool window)

1. Locate the "Auto Hide" pushpin button on the title bar of the Sequence Viewer tool window. The pushpin is currently in the "down", or "pushed in," position, meaning that the window is "pinned" open (Auto hide is disabled).

2. Click the Auto Hide button, Sequence Viewer tool window slides off the screen and is replaced by a small tab named Sequence Viewer at the edge of the application window. You can also use a right-click on the title bar and select Auto Hide in order to auto hide a tool window.

3. Hold the mouse pointer over this Object Properties tab (You can also click the tab if you like) and the Object Properties tool window immediately slides back into view.

4. Click elsewhere inside the application window and it will disappear again.
5. Finally, bring out the Sequence Viewer window again and then click the pushpin button on the title bar. Sequence Viewer returns to its familiar docked position and you can use it without worrying about it sliding away.

Tool windows that have Auto Hide enabled temporarily slide into view when the window has focus. To hide the window again, select an item outside of the current window. Once the window loses focus, it slides back out of view.

Create a New design

In order to create a new design, you can click on the "New" icon that is located on the standard toolbar or select the option "New" of "File" menu or press "Ctrl + N" shortcut key.

On the following dialog you can specify:

- **Limits of the design**

  You can specify the "Width" and "Height" of the design area by entering the exact values in centimeters. The program will create a rectangle with the specified dimensions, where you can place your design. The rectangle does not restrict you to expand the design outside of its boundaries, but it works like a guideline.

  If you select a backdrop to set behind of the design the "Width" and "Height" fields will change to backdrop’s dimensions.

- **Available colors**

  The limits of the design have adopted the size of the bitmap.
Select the number of the available colors that will be used for the new design. We can also adjust the number of used colors using “color manager”. This option is very useful when we want to use more than 20 colors for an embroidery machine that supports more than 20 colors or when we want to embroider designs that have more than 20 colors.

- **Template**

In this field you can select the template that the new design will be based on. Templates are "NGS" embroidery designs that are saved in a "Templates" directory.

This "Templates" directory is located:

- **Windows XP** *(C:\Documents and Settings\All Users\Modular v5.00)*
- **Windows Vista** *(C:\Users\Public\Modular v5.00)*

In case that you have selected a template, all settings including styles, patterns, effects and stitch data are available in the new design.

If you have created a new design with a template selected, the next time that you will create a new design, the program will have pre-selected the last used template.

In order to create your own template you have to create a new design, make all the adjustments you want and save it as an "NGS" file in the "Templates" directory (in the location mentioned previously) with a name you prefer. The next time that you will create a "New" design you will find your template in the “Template” dropdown menu.

- **Backdrop**

In this part of the "New design" dialog box you can specify the image file you wish to be placed as a backdrop. When you click on the "Select" button a normal "File → Open" window dialog appears. There you can browse in your computer and find the image you want to place as backdrop to the design (modular can read all the known image formats). The image file will be set to the background behind the embroidery design that you will create. You cannot edit the image inside the program but you can move and preview it in 3D mode behind your design (read more in the Backdrops section).

When you finish the backdrop selection, click "Open" to continue.

In some cases you may want to use “Convert” tool in order to convert the selected image file into stitches. You can learn more about the file types and the possible conversions in section “Convert” that follows. The selected backdrop is previewed in the “New Design” dialog in a specific rectangle. In case that you do not want to use the already selected
backdrop image, you can use the "Clear" button to remove it or the "Select" button to select a new one.

When a backdrop is selected, the limits of the design change, following the dimension of the selected backdrop.

Vector and Bitmap graphics

Wings' modular can import Vector and Bitmap graphics. These graphic files can be used as backdrops.

**Vector graphics:** Vector designs are created as collections of lines. Vector designs are images/drawings generated from mathematical descriptions that determine the position length and direction in which lines are drawn. They vector files types that can be recognized and used by Wings' modular® are:

- Corel Graphics (*.CMX)
- Encapsulated Postscript (*.EPS)
- Enhanced windows metafile (*.EMF)
- Scalable vector graphics (*.SVG)
- Adobe Illustrator (*.AI)
- Autocad (*.DXF)
- Windows metafile (*.WMF)

All these types of files can be directly imported into Wings' modular®, which recognizes and visualizes all mathematical descriptions that determine the position, length and direction in which lines-shapes are drawn.

**Bitmap graphics,** which are mainly photographs, are saved in .bmp, .jpeg, .gif, or .jpg files formats. **Bitmap graphics** (Images) are made of patterns of individual dots or pixels. The shapes that they contain cannot be easily resized. The bitmap file formats that Wings' modular® supports are as follows:

- Bitmap files (*.BMP, *.DIB, *.RLE)
- Gif file (*.GIF)
- Tif file (*.TIF, *.TIFF)
- Png file (*.PNG)
- Icon file (*.ICO)
- Photoshop (*.PSD)

Bitmap graphics can be directly converted to "Cross stitch" or "Photostitch" embroidery design, or else they can be **traced.** This process turns the bitmap into a Vector design so it can be embroidered.

Now that you've learned that Vector means clipart and that Bitmap means a photograph or picture, we'll use the graphics terms of Vector and Bitmap as you familiarize yourselves with them.
**Open a design**

With the "Open" dialog you can load an embroidery design which is in a local disk or in a network disk. This dialog is a normal Windows file "Open" dialog.

In order to find the design you are looking for you have to specify its position. This can be done with the "Look in" field. This field shows the folder and the disk that you are looking. The designs of the current folder can be viewed in the File list under the "Look in" field. By default every time you open the "Open" dialog, the program shows the "Embroidery Designs" folder that is located in My Documents folder. In Windows XP the path to this folder is (C:\Documents and Settings\Username\My Documents\Embroidery Designs\), where user name is the user name of the current user. In Windows Vista/7 the path to this folder is (C:\Users\User name\Documents\Embroidery Designs\).

In order to change the "Look in" folder, click on the arrow showing down on the right side of this field.

**Example:**
If you want to load a design which is in "Documents\Embroidery Designs\" directory.
Click on the "Look in" field and click on the Documents folder. The "Look in" field shows "Documents" and the "File list" will show the contents of the folder.

In the file list double click on the folder "Embroidery Designs". The "Look in" field shows "Embroidery Designs" and the file list will show the contents of the "Documents\Embroidery Designs\" folder.

In the file list double click on the folder "Women" (we assume that exists). The "Look in" field shows "Women" and the file list will show the contents of the "Documents\Embroidery Designs\Women" folder.
Double click on the design you want to load. On the right side of the "Look in" field are two more buttons that helps you to change the folder that you are searching.

If you click on any file design in the "file list" the image of the file immediately will be displayed on the “Preview Icon” area which is located at the bottom left corner of the dialog box.

This area is activated whenever you click on any file design. The area automatically previews the design that it is stored in the selected file design. This helps you to select the design you want without remembering the file name of the design.

**Go to last folder visited**

This button brings you to the previous folder that you saw. In the given example, when you are in the "Documents\Embroidery Designs\Women" and you press the back button, in the "File list" you will view the contents of the "Documents\Embroidery Designs\" folder. The second time you will press the back button you will view the contents of the hard disk C: and the third time the contents of your designs directory.

**Up one level**

This button brings you to the folder that contains the current sub-folder. **Example:**
The file open dialog shows the "Documents\Embroidery Designs\" directory and you want to find a design which is in "Documents\Embroidery Designs\men".

Press the "Up one level" button and the "Look in" field will show the "Documents\Embroidery Designs\" directory.

In the file list double click on the men directory.

The "File list" area shows the designs or the sub-folders that the current folder contains. The selections of the designs depend on the way you have set the parameters of your Windows Explorer. From the same settings depends the way that the selected design will be loaded.

**Create new folder**

With this button you can create a new sub-folder in the current folder. After this button pressed a new folder named as "New Folder" can be seen in the "File list" area and you can type its name.

**View menu**

With this button you can specify the way that the sub-folders and the designs will be vied in the "File list". The possible options are:

- Large Icons,
- Small Icons,
- List,
- Details
- Thumbnails.

Every design you are selecting from the "File list" its name is written in the "File name" field and it is previewed in the bottom of the dialog box. Also you can type in this field the name of the design that you want to load and after that press the "Open" button.

In the "Files of types" field you can select the type of embroidery files that will be visible in the "File list" area. In case that you want to see all the files, no matter the file type, you can select the "All Files" option.

On the left bottom side of the "File ➔ Open" dialog you can see the information of the selected design like the "Design dimensions", "number of stitches", "Color changes" and "File size on disk". In case that you would like to see more information for the selected design you can load it and select the "Design Info" option from the File menu.

Additionally you can call the "Icon browser" of the designs and the "Favorites" folders.

**Favorites**

In this dialog you can "Add" or "Open" the most common directories with designs that you are using, in order to access them easily. In the "Current path" area you can view the path of the hard disk that will be "Added" in favorites list or "Opened" in the "Open" dialog box. In case that this folder is not added in your favorites list, you can add it by writing a description of the favorite in the "Name" field and then press the "Add" button. All the Favorite folders are added in the list next to the "Open" button with the name you gave to them. In order to call a favorite, just click on it and then press the "Open" button.

Favorites can save you time of searching inside your hard disk to find your designs.

On the right bottom corner of the "Open" dialog box you can see and change the parameters of machine type files. These parameters are the same like the Import design from a machine disk. Depending on the machine file type design you want to open you have to make changes on the special functions that are applied
With the "Browse" option from the "Open" dialog box or from "File" menu, you can display pictures of designs and visually choose the designs that you want to load.

The "Icon browser" works like the Windows Explorer and it is a separate window inside Wings’ modular® software. This allows you to load the designs you need while the browser stays open and you can manage it as a normal window.

On the left side of the browser, you can see the structure of the folders and the subfolders of your hard disk. If you click on a folder you can see all the subfolders and embroidery designs in these folders on the right hand side of the field. You can also use browser to see any designs contained in a network computer.

If a folder has the symbol "+" on the left, this indicates that this folder has subfolders and you can view them by clicking on the "+" button. By pressing the "-" on the left side of the subfolder, you can compress the contents of the folder again.

Using the browser you can:

- Select the designs.
- Load the selected designs.
- Print the selected designs.
- Change the size of the icons.
- See the information of a design.
- Delete one or more designs.
- Move one or more designs in another folder
- Search the embroidery designs of your hard disk.

The same option can be called from the "File ➔ Open" dialog by pressing the "Browser" button.

**SELECTION IN BROWSER**

If you want to select a design, simply click on the icon of it. If you want to select more than one design, just select the designs while keeping the "Ctrl" key from the keyboard pressed. In order to open them you can select the "Open" function from the right click menu or by pressing "Enter" button from keyboard.

If you want to open a number of designs that are contained sequentially in the same list you can do so by selecting the first design of the list, then press the "shift" key and select the last design on the list. All the designs between the two selection points will be highlighted; you can open them all by pressing the "Enter" key. This selection is possible only in "Details" mode which can be activated from the right click menu.

To select all the designs, which are in the current folder, you have to right click on any design and select the option "Select all" from the menu. The same functionality is activated when you press the "Num +" key from the keyboard or the "Select all" icon from the standard toolbar.

To de-select all the selected designs, you have to right click on any design and click on the option "Select none" of the menu. The same functionality is activated when you press the "Select none" icon from the standard toolbar or if you click on an area without icons.

To invert the selection you have made, you have to right click on any design(s) and click on the option "Invert selection" of the menu. The same functionality is activated when you press the "Num –" key from the keyboard or the "Invert selection" icon from the vertical toolbar.

**LOAD DESIGN IN BROWSER**

You can use the "Browser" to load the selected design(s).

By double-clicking on a selected design, you can load it. Also you can load the selected designs by right-clicking on the selected design and from the menu that appears select the "Open" option.
Alternatively you can load the selected design, by clicking on the icon of the horizontal toolbar.

**PRINT SELECTED DESIGNS**

On the top-left corner of the "Active designs" dialog you can see which printer has been installed and you can specify which one you would like to print on. In case that you want to change the printer, you have to click on "Setup" button. In the following dialog you can change also the parameters of the printer.

**SIZE OF ICONS**

In "Browser" mode you can change the size of the icons by right-clicking on the icon and from the menu that appears selecting the size option you prefer. The options are:

- **Large icons**
  the sizes of these icons are 160 X 120 pixels and it is the default, when you are loading the Browser for the first time.

- **Small icons**
  the sizes of these icons are 80 X 60 pixels. With this size you can preview more icons per page and make quicker selection.

- **Details**
  With this option you cannot view the icons of the designs, but you can view the information about them. The information listed contains the Name, Type, Width, Height, Stitches and Colors. If you click on the header of a field, the designs will be sorted by this field starting from the lowest value to the highest. If you click again on the same header, the designs will be sorted by the opposite way.

Wings' modular® software always keeps the latest configuration of the icon view.

**PROPERTIES**

This option can be accessed from the right-click menu of "Browser" and shows the information of the last selected design. In the window that will appear you can view the Icon of the design, the Name, the Width, the Height, the Stitches count, the Colors, the Notes, the Customer, the Designer and the Keywords.

You cannot change the design information in this window but you can do it by opening the "Design info..." option from the "File" menu that we will analyze later on.
In the "Browser" you have the option to delete the designs that you do not want.

In order to delete the unnecessary file designs, first you have to select them and after that press the "Delete" button from the keyboard.

Another way to delete the design you wish is to select these designs and on the right click menu select the option "Delete".

In the "Browser" you have the option to move designs from one folder to another.

In order to move one or more design from the current folder to another, first you have to select the designs you want and then drag them on the folder you wish on the left part of the Browser.

With this dialog you can search for one or more designs in your hard disk or in a network disk.

The filters you can use are:

- **Design name:**
  In this filter you can write a part of the name or exactly the name of the design you are searching for.

- **Keyword:**
  In this filter you can write one or more keywords that you have added in the "Design info..." or "Save as" dialog.
- **Stitches:**
  In this filter you can specify the number of stitches of the shown designs.

- **Customer:**
  In this filter you can write a part of the name or exactly the name of the customer that you have added in the "Design info..." or "Save as" dialog.

- **Designer**
  In this filter you can write a part of the name or exactly the name of the designer that you have added in the Design info... or Save as dialog.

- **Size:**
  In this filter you can specify the limits of size of the shown designs.

- **File date:**
  In this filter you can specify the type of the date that you are going to use for searching and the time period that you would like this time to be.

- **Start from folder:**
  In this filter you can specify in which directory the program will start searching for designs. In order to change the searching folder you can use the "Browser" button. Also you can enable the following filter "Browse also subfolder" in order to search and the subfolders of the selected folder.

- **Limit search to:**
  In this field you can specify the maximum number of the shown designs after the search.

- **Search:**
  Pressing this button, the software starts searching the selected drives accordingly to the filters you have specified.

- **Search results:**
  In this area can be seen the designs that are fulfill the conditions of the searching dialog.

### Read diskette

You can read a diskette or floppy disk using this option from the "File ➔ Import ➔ Machine Floppy" menu item. Place the diskette inside the drive and then click on this option. The program automatically recognizes the format of the diskette and the designs that it contains. At this point you can see a dialog box asking about parameters for designs that the diskette has. If you change the diskette, the program will recognize the new one. In case you have forgotten to put a diskette in the drive the program the software will prompt you to do so and asks if you want to retry or cancel.
In the following dialog you have to specify:

- The **Designs** that you want to load
- The distance which above two objects will be split.
- The way that the **stops** will be read.
- If the commands **Slow/Fast** will be detected.
- The number of **jump-stitches** which will be interpreted as a cut.
- If the **double stops** command will be detected.
- If the Slow/Fast or the Sequin command for **ZSK** will be detected.

**Designs**

In this area you can see the names of the designs that are contained on the diskette.

To load a design you can click on it and then click the OK button. If you want to load more than one design, you can click and drag from one design to another. By holding the shift button, you can click on one design then another and all the designs in-between will be selected. If you want to load multiple designs that aren't listed sequentially, hold the control key and click on each of the designs that you want to load.

**Split objects above distance**

Using the following scroll bar you can set the distance above which the objects will be split. For information, two parts of a design are treated as separate objects if they have a special function between them. This option is useful when you have a design without thread trims. Specifying a distance just higher than the longest stitch that exists inside the design automatically converts all the long stitches (movements between objects) to split objects.

**Convert all Stop functions to color changes**

If you enable this option, the program will translate the Stop special function into a color change.

**Delete all Slow/Fast commands from design**

If you enable this option, the program will delete any slow or fast commands the design may have.

**Cut is … jumpstitches**

This option relates only to the Tajima machine format. With the following scroll bar, you have to specify how many jumpstitches will be translated as a cut.

**Read double stops**

This option is related only to the Tajima machine format in which there is no color change function. This type of machine uses the stop function as a color change. If you have two or more stops in sequence (for example when
embroidering appliqués) the program will read them as a "Stop" function, not as two color changes.

**ZSK code Version**

The following two commands work as radio buttons. They allow you to select one of the two commands depending on which type of ZSK machine version you are working with:

- **OLD: Slow speed command**
  
  The old version of ZSK code uses Function 20 as a slow speed command; therefore you must specify if your design was made with old or new ZSK code using this option.

- **NEW: Sequin command**
  
  New version of ZSK code uses Function 20 as a Sequin command; therefore you must specify if your design is made with old or new ZSK code using this option.

**Delete Design**

With this button you can delete the selected designs on the Designs list. On the following window you have to confirm if you want to delete the selected design(s) or not. If you press the "Yes" button, the designs will be deleted. If you press the "No" button the function will be cancelled.

**Recent Files**

At the end of the "File" menu there is a list with the 5 last used designs. In order to load one of these designs, just click on the design you want. The design will immediately open in a new internal window without affecting the already open designs.

**Save as your design**

When you open a design in Wings’ modular® you can save it in many different file formats. The standard saving format is ".ngs" which is the default Wings Systems file format. The other file formats are:

- Wings Systems (".ngs")
- SEF xp (".sef")
- Tajima (".dst", ".dsz", ".dsb")
- Tajima TBF (*.tbf)
- SEF xp (*.sef)
- SWF (".sst")
- Pfaff (".ksm", ".pcs", ".pcm")
- Singer (*.xxx)
- Happy (".tap")
- Bernina / Melco expanded (".exp")
- Brother/Baby Lock/Bernina (".pec", ".pes")
- Husqvarna (".hus")
- Husqvarna Viking (".vip")
- Viking Designer 1 (.shv)
- Janome (".jef", ".sew")
- Janome (".jef+")
- Juki (".M3")
- Toyota (".10O")
- QuiltCAD (*.hqf)
- PC Quilter (*.txt)
- Statler Stitcher (*.qli)
- Mitsubishi HD (".1??")
- Barudan FDR (".U??")
- ZSK TC (*.Z??)

With the "Save as" option, from the "File" menu, you can save the current design on your hard disk for the first time or save the current design in a different position or with a different name.

In the "Save as" dialog you can specify the position in which you want the design to be saved by changing the "Save in" field which is the same with the "Look in" field that we analyzed in the "File ➔ Open" dialog. Also are available the "Go to last folder visited" ➔, "Up one level" ➔, "Create new folder" ➔ and "View menu" ➔.

The "File list" area shows the designs that the current folder contains. If you click on a design, its name will be added in the "File name" field and the information about that design will be list on the left bottom side of the "Save as" dialog. If you press the "Save" button the selected design will be deleted and in its position will be written the current design. If you type a different name on the "File name" field the design will be saved with this file name.

On the right bottom side of the "Save as" dialog you can view the "Customer", "Design" and "Keyword" fields. These fields are useful in order to search a design. The same fields exist also in the "Design info..." dialog.

Finally, from the "Save as Type" you can select the file format you want to save the design.

It is good practice always to save your designs in ".NGS" file format because it is a reach embroidery file format that allows you to make any modifications.
you want easily by editing punching data. In addition "NGS" file format keeps information like Keywords, the Designer’s name, the Customer’s name, an image of the design and many more that can help you create your own embroidery design library.

With those saving capabilities you can easily make your designs, save them in a floppy disk, load them from your embroidery machine and embroidered them.

**Save your design**

In order to save an existing design you must follow the steps listed below.

1. Choose "File ➔ Save" or "Save As". The "Save As" dialog box appears. If your design has been saved once already, by clicking on the "Save" option, the "Save As" dialog box will not appear but will save any changes to your previous saved file.

2. In the dialog box define the "File name" and the file type.

3. Select the location you want to store your designs and click "Save".

Following these simple steps you can save your designs in any embroidery machine file format you prefer loaded to your embroidery machine and start the embroidery process.

**Auto-backup mechanism**

Wings' modular® software has two security features that will help you avoid losing important work from systems crashes that might occur. The first is the "Failure Recovery" feature and the second is the "Auto-backup" feature of the embroidery designs.

- **Failure Recovery**: This feature is activated automatically when an illegal operation is made in the software. Immediately the "Failure Recovery" tool is activated in order to baffle the termination of the program.

The "Failure Recovery" dialog box looks like the one above. If you click the "Yes" button the software will continue functioning from the position you were before your last action. On the other hand if you click on the "No"
button the Software will be terminated immediately without asking you to save your design. If the "Failure Recovery" appear in a design is better to save your design, after clicking the" Yes" button, and restart "Wings' modular®". This mechanism secures your work.

- **Auto-backup:** Another feature that Wings’ modular® has to protect your valuable work is the "Auto-backup" feature. Wings' modular® automatically saves your designs after every change you make on them. The "Auto-backup" works even if you have not saved your design at all. If the software hung-up for a reason, your work will not be lost in most of the cases. The next time that you will open the software the designs that were open before the hung-up of the software will be there at the point of your last embroidery transformation. This mechanism will protect you from losing your work.

**Note:** Always keep in mind to save your designs frequently.

---

**Format Floppy**

Using the "Format floppy" option from the "File" menu, you can format a new diskette. Before you call this option you must have a new diskette inserted in the floppy disk drive.

In the "format properties" field of the "Floppy disk format" function you can select the type of the machine disk that you are going to create.

![Format floppy dialog](image)

To start the formatting processing, press the "Start format" button. The program recognizes the current floppy disk format.

If the diskette that you have inserted is already formatted, Wings’ modular® software will show a warning message showing the type of the diskette that you are willing to format and the number of the designs that this diskette has.
Attention:

If you will press the "Yes" button on the warning dialog, all the designs of the diskette will be deleted. In case that you are not sure if you want these files or not, press the cancel button and use another empty diskette.

In case the current floppy disk format is the same as your choice, the Wings’ modular® software gives you the opportunity for a fast format.

Write Floppy

Using "Write floppy" option from the "File" menu, you can write the current design to a diskette. First place the diskette inside the drive and then click on this option. The program automatically recognizes the format of the diskette and asks for the parameters. If you have forgotten to put the diskette in the drive, the program will prompt you and will ask if you want to retry or cancel.

In the following dialog you have to specify:

- The internal file name of the design.
- The templates that you use on your machine.
- The maximum stitch length.
- The number of the jumpstitches which will be interpreted as a cut.

File name

In this area you have to write the internal name of the design. This name will appear on the file when you want to load the designs from the diskette. For some embroidery file formats (eg. Tajima) these names are different than the ones saved to disk. ZSK accepts only numbers as filenames.

Under this field you can see the designs that are already in the diskette.

Templates

In this area you have to select the accepted template that you use in your machine.

Maximum stitch length in design / between objects

In this area you have to select the maximum stitch length that the design will have.

Cut is … jumpstitches

This option has to do with the Tajima format. With the following scroll bar you have to specify how many jumpstitches will be interpreted as a cut.

Additional information is also given in this dialog:

Machine-Code format
In this area the program recognizes the existing format of the diskette and shows which code the design will be written in on the diskette.

**Design stitches**

In this area you can see the estimated number of stitches that the design has.

**Free stitches.**

In this position you can see the free space of the current diskette counted in stitches.

---

**Supported file formats**

**a. Embroidery formats (MS-DOS compatible)**

Wings’ modular® software supports the following DOS file formats:

<table>
<thead>
<tr>
<th>Format</th>
<th>Extension</th>
<th>File Open</th>
<th>File Save</th>
<th>Read Disk</th>
<th>Write Disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tajima DSB</td>
<td>.DSB</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Tajima DSZ</td>
<td>.DSZ</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Tajima DST</td>
<td>.DST</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>APS DOS</td>
<td>.STC</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>APS DOS</td>
<td>.PCH</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Happy</td>
<td>.TAP</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>KSM/PFAFF</td>
<td>.KSM</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>PFAFF</td>
<td>.PCS</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>PFAFF</td>
<td>.PSM</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Melco Expanded</td>
<td>.EXP</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Melco Condensed</td>
<td>.CND</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Singer</td>
<td>.XXX</td>
<td>✔</td>
<td>✔</td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Milestone</td>
<td>.MLS</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Wings’ modular</td>
<td>.NGS</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>CadCam APS</td>
<td>.STC</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>CadCam APS</td>
<td>.PCH</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>SWF</td>
<td>.SST</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Mitsubishi</td>
<td>.1</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Toyota</td>
<td>.10O</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Barudan FDR</td>
<td>.U</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Artista</td>
<td>.art</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Juki</td>
<td>.M3</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td>Brother/ Baby Lock/ Bernina</td>
<td>.pes</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Brother/ Baby Lock/ Bernina</td>
<td>.pec</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Janome</td>
<td>.Jef</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Janome</td>
<td>.Jef+</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Janome</td>
<td>.sew</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Viking Designer1</td>
<td>.shv</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Husqvarna Viking</td>
<td>.Vip</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
<tr>
<td>Husqvarna</td>
<td>.Hus</td>
<td>✔</td>
<td></td>
<td></td>
<td>✔</td>
</tr>
</tbody>
</table>

**b. Non MS-DOS compatible floppy disk formats**

Wings’ modular® software, in addition to the above-listed MS-DOS compatible formats, supports the following special disk formats:

<table>
<thead>
<tr>
<th>Disk type</th>
<th>Size</th>
<th>Embroidery formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barudan FMC</td>
<td>640K</td>
<td>Barudan</td>
</tr>
</tbody>
</table>
Import 8-channel tape

With this option you can read a tape from a reader. On the following dialog you have to specify if the reader is ready or not.

Check if the reader is switched on and if the reader mode is on. If the reader is ready, click on the "Yes" button.

The program reads the tape and recognizes automatically its format. On the following dialog you can specify:

- The correct format of the tape
- The distance which above two objects will be split.
- The way that the stops will be read.
- If the commands Slow/Fast will be detected.
- The number of jumpstitches which will be interpreted as a cut.
- If the double stops command will be detected.
- If the Slow/Fast or the Sequin command for ZSK will be detected.

Format

On this area can be seen the available tape formats. The software has marked the format that was recognized during reading the 8-channel tape. In case that you want to change the tape format click on the format you wish.

Split objects above distance

Using the following scroll bar you can set the distance above which the objects will be split. For information, two parts of a design are treated as separate objects if they have a special function between them. This option is useful when you have a design without thread trims. Specifying a distance just higher than the longest stitch that exists inside the design automatically converts all the long stitches (movements between objects) to split objects.

Convert all Stop functions to color changes

If you enable this option, the program will translate the Stop special function into a color change.

Delete all Slow/Fast commands from design

If you enable this option, the program will delete any slow or fast commands the design may have.

Cut is … jumpstitches
This option relates only to the Tajima machine format. With the following scroll bar, you have to specify how many jumpstitches will be translated as a cut.

**Read double stops**

This option, also, is related only to the Tajima machine format in which there is no color change function. This type of machine uses the stop function as a color change. If you have two or more stops in sequence (for example when embroidering appliqués) the program will read them as a "Stop" function, not as two color changes.

**ZSK code Version**

The following two commands work as radio buttons. They allow you to select one of the two commands depending on which type of ZSK machine version you are working with:

- **OLD**: Slow speed command
  
  The old version of ZSK code uses Function 20 as a slow speed command; therefore you must specify if your design was made with old or new ZSK code using this option.

- **NEW**: Sequin command
  
  New versions of ZSK code use Function 20 as a Sequin command; therefore you must specify if your design is made with old or new ZSK code using this option.

**Note:** The Reader can be specified during the installation. For more information see the Getting started, in modify section.

### Last tape imported

With this option you can read again the last tape (without needed to be put on the reader) in order to change the import parameters.

The parameters you can change are:

- the correct format of the tape
- the distance which above two objects will be split.
- the way that the stops will be read.
- if the commands Slow/Fast will be detected.
- the number of jumpstitches which will be interpreted as a cut.
- if the double stops command will be detected.
- if the Slow/Fast or the Sequin command for ZSK will be detected.

**Format**

On this area you can view the available tape formats. The software has
marked the format that was recognized during reading the 8-channel tape. In case that you want to change the tape format click on the format you wish.

**Split objects above distance**

Using the following scroll bar you can set the distance above that the objects will be split. For information, two parts of a design are treated as separate objects if they have a special function between them. This option is useful when you have a design without thread trims. Specifying a distance just higher than the longest stitch that exists inside the design automatically converts all the long stitches (movements between objects) to split objects.

**Convert all Stop functions to color changes**

If you enable this option, the program will translate the "Stop" special function into a color change.

**Delete all Slow/Fast commands from design**

If you enable this option, the program will delete any slow or fast commands the design may have.

**Cut is … jumpstitches**

This option is related only to the Tajima embroidery machine file format. With the following scroll bar, you have to specify how many jumpstitches will be translated as a cut.

**Read double stops**

This option is, also, related only to the Tajima embroidery machine file format in which there is no **color change function**. This type of machines uses the "stop" function as a color change. If you have two or more stops in sequence (for example when embroidering appliques) the program will read them as a "Stop" function, not as two color changes.

**ZSK code Version**

The following two commands work as radio buttons. They allow you to select one of the two commands depending on which type of ZSK machine version you are working with:

- **OLD: Slow speed command**
  
  the old version of ZSK code uses Function 20 as a slow speed command; therefore you must specify if your design was made with old or new ZSK code using this option

- **NEW: Sequin command**
new versions of ZSK code use Function 20 as a Sequin command; therefore you must specify if your design is made with old or new ZSK code using this option.

**Export to 8-channel tape**

With this option you can punch (write) an 8-channel tape.

On the following dialog you have to specify the code and the Macro of the tape that you are going to punch.

More over you can specify:

- the **maximum stitch length**.
- the number of the **jumpstitches** which will be interpreted as a cut.

**Maximum stitch length in design / between objects**

In this area you have to select the maximum stitch length that the design will have.

**Cut is … jumpstitches**

This option has to do with the Tajima format. With the following scroll bar you have to specify how many jumpstitches will be interpreted as a cut.

**Export to DXF format**

With this tool you can export your design to DXF (AutoCAD) format. This is a vector format that can be used for presentations or used in Laser cutters.

To export a design to (DXF) file format you have to follow the steps listed below:

Select the object(s) that will be exported to "DXF" file format.

From "File" menu select the "Export ➔ Output to DXF".

A standard "File ➔ Save" dialog box appears.

Select the location where the file will be saved, enter a name in the "File name" filed and click the "Save" button to finish saving in "DXF" format.

**Export embroidery image**

At this point we will analyze the way that you can export an image of a design you have created. We have the ability to export the embroidery design to a bitmap file with embroidery look. The 3D preview of Wings’ modular is going to be saved. Only anything that is visible in 3D preview. We can export the design to four different image file formats (Tiff (*.tif), PNG (*.Png), Jpeg (*.jpg, *.jpeg) and Bitmap (*.Bmp)). The embroidery images that will be produced can be used for graphics designing, envelop decoration, creation of birthday
cards, brochure creation and generally advertising material that are based on embroidery or not.

In order to export the embroidery design to bitmap file you have to follow the steps below:

1. From File > Export select To image… option or press Ctrl and Shift and G shortcut keys (Ctrl+Shift+G) together from the keyboard.
2. The dialog that will appear is a standard Save as windows dialog from which you can browse and find the location you want to save the design,
3. Find the location you want the file with the embroidery effect to be saved,
4. Type the name you want the exported file to have in the File name field
5. Select the file you want to save the design from Save as type drop down menu. The options you have are Tiff (*.tif), PNG (*.Png), Jpeg (*.jpg, *.jpeg) and Bitmap (*.Bmp).
6. Click Save button and you are ready.

There are some more adjustments that you can do on the dialog window before exporting the design that we will analyze later on. After making the adjustments you want (DPI, Fabric option and Include Backdrop option), you can click the save button that will export the file in the location you have specified with the name you wanted.

**Changing image resolution**

You can adjust the resolution of the produced image by changing the DPI (Dot Per Inch) value.

The resolution of an image is measured by the number of dots per Inch that it consists of when it is printed. The DPI value that you will choose affects the image quality. The DPI value that you can enter in the DPI field can vary from 60 to 600. Generally images that are created only to be displayed on computer monitors are 72 or 96 dpi and images that are created for the internet are 72 dpi. In addition images created for printing on desktop printers are between 150 to 300 dpi, while images for professional printers are usually 300 dpi or higher.

You can produce images with embroidery effect with the dpi resolution you prefer by simply adding the DPI value in the field. We propose for better embroidery effect results to set the dpi value more than 150 dpi. With resolution near to 160 dpi you will be close to the real dimensions of the design and you will get a proper representation of the embroidery effect by
avoiding re-sampling the original image. For textile printing it is better to use the highest possible resolution of 600 dpi for more realistic results.

**Include fabric option**

With the **Include fabric** option you can decide whether you want the exported image from Wings’ modular to have fabric background or not. With a fabric background you could have a realistic preview of the design on a fabric that will make it look like it is actually embroidered.

If **Include fabric** option is selected, the currently used fabric will be added as a background in the exported image. The color and type of the fabric is the same with the one that was set in the embroidery design. If **Include fabric** option is not selected, the embroidery effect image will not have a fabric background. For **Bitmap**, **Jpeg** and **Tiff** files the background will be a solid white color and for **PNG** files will be transparent.

**Include backdrop option**

In some cases that we are digitizing based on a backdrop it would be very useful to export the design with the used backdrop. This way we can review the design in comparison to the design source in order to improve any aspect of the design we like.

If this option is selected the Backdrop that is included in the design will be exported to the image as seen on screen. In order to be able to export the backdrop, the desired backdrop must be visible in 3D preview. In any design we may have one or backdrops if we want to export the design to image we any of them we must first enable "Use in 3D preview" option of Backdrop properties dialog.

**Serial connection with Embroidery machines**

With this tool you can connect your embroidery machine directly with the computer. There are several plug-ins that can be used to connect your Wings’ modular® with your embroidery machine or a Memory-Box storage device. You import or export designs from the connected devise.

In order to export a design directly to your embroidery machine you have to activate the "Plug-ins" function from the "File ➔ Export" menu. The "Export design" dialog box appears (Figure 2.24).
Export design

In the "Export design" dialog box you can make the following adjustments:

**Select Driver:** In this list box you can select the device in which you will export the design. You can select to export between a storage device or directly to an embroidery machine.

**Add driver:** By clicking on this button you can add a driver to the "Export design" dialog box and use it to connect Wings’ modular® directly with a storage devise or an embroidery machine.

In the dialog box that appears you have to specify the location where the driver of the devise is located.

**Remove driver:** With this button you can remove the selected driver from the "Select Driver" list.

**Configure:** with this button you can configure each plug-in that exists in the "Select Driver" list.

**About:** with this button you can view information about the selected driver of the "Select Driver" list.

When you finish with the adjustments, click the "Ok" button to continue. In the dialog box that will appear you can make extra machine type adjustments that will be the final before you embroider the design. Click the "Ok" button to send the design to the design you have selected.

**Send through e-mail**

With this option you can send the current design by e-mail. When the "Send" option is selected from the "File" menu, Wings’ modular® finds the default program that you use for e-mails and opens a new e-mail window. The current design is saved in a temporary location and then it is attached to a new mail that has been created using your mail client.
Type in the e-mail address of the person you want to send the design, add any text you wish in the e-mail and send it through internet.

**Closing – Exit**

In this section you can learn the possible ways to close the loaded designs or to exit from the program.

**Close**

By clicking on this option in the "File" menu, you can close the current design. If the design has changes that are not saved, you will see a message box asking if you want to save the current changes.

**Important:** If you click the "Yes" button the new design will be saved over the old one without any further warning. If you want to keep the old design as it is, you must click the "Cancel" button and then use the "Save as" command of the "File" menu. In case that the current design has not saved, the program automatically call the "Save as" option.

If you choose the "No" button, the changes of the design will not be saved. If you choose the "Cancel" button, the design will not be closed and you can continue working on it.

The same option can be called with "Ctrl+F4" from the keyboard.

**Close all**

By clicking on this option from the "Window" menu, you can close all the designs which have been loaded. If one or more designs have changed but not saved then you will see a message box asking if you want to save the current changes.

**Attention:** If you click the "Yes" button the new design will be saved over the old one without any further warning. If you want to keep the old design as it is, you must click the "Cancel" button and use the "Save as" command from the "File" menu. In case the current design has not been saved, the program automatically bring up the "Save as" option.

If you choose the "No" button, the changes of the design will not be saved. If you choose the "Cancel" button, the design will not be closed and you can continue working on it.

The same option can be called by pressing the "Ctrl + F4" keys.

**Quit**

You can exit the program using this option from the "File" menu. If any of the designs you have been working on have changed but are not yet saved then
the software will prompt you with a dialog box asking if you want to save the current changes.

**Attention:** If you click the Yes button, the new design will overwrite the old one without any further warnings. If you want to keep the old design as it is, you have to click the Cancel button and then use the Save as command of the file menu. If you click the No button, the changes to the design will not be saved.

### Window

Wings’ modular® loads all the embroidery file designs in multiple internal windows. For this reason Wings’ modular® includes functions for Windows managing. These functions can help you to manage the active designs better, helping you reduce the production time of the design. All the “windows” managing functions are the following:

#### Tile horizontal

Using this option from the "Windows" menu you can display multiple designs underneath one another. This allows you to see all the designs on the screen simultaneously - please note that the screen may become crowded if you open many designs at the same time.

#### Tile vertical

Using this option from the "Windows" menu, you can display multiple designs next to one another. This allows you to see all the designs on the screen simultaneously. Please note that the screen may become crowded if you opened many designs at the same time.

#### Cascade

Using this option in the "Windows" menu allows you to see the designs displayed as cards. The design that you select will move to the front.

#### All iconic

By choosing this option from the "Windows" menu you can minimize (shrink) the designs to the bottom left corner of the screen.

### Printing

Printing the designs that will be embroidered it is important procedure in the embroidery process. Wings’ modular® in the printouts includes all the information that you would possible need for the embroidery design.
This option can be activated by pressing the icon above or from the option "File > Print" menu - it enables you to print the current design.

On the following dialog you can see a preview of the printout of the current design.

To the right side of this dialog you can specify:

- **Printer setup**
- **Print items**
- **Tiled printout**

The design will be printed when you click on the "Print" button. In case that you do not want to print the current design, press the "Close" button but any changes you have made in the "Print preview" structure will be saved.

In case the printout dialog was brought up from the "Browse" option, the last field "page" will be enabled. With this field you can specify which page of the printout you would like to see.

### Printer Setup

With the Setup button of the printing dialog you can see the properties of the printer. The dialog of the printer setup depends on the printer driver that you are using.

### Print items
In this part of the printing dialog you can specify which information will be visible on the printout.

The option that you have are:

- **Header**
- **Color changes**
- **Sequence icons**
- **Information**
- **Orientation**
- **Company name**
- **Binder space**
- **Stitch count**
- **Start point**
- **3D-Preview**
- **Fabric**
- **Design date**

Every item of the printout can be enabled or disabled with a click on the square on the left of its description. If the item is enabled the changes can be viewed on the preview area.

**Header**

The header of the printout is at the top of the page and shows the size, color changes, number of stitches of the design, the needed yarn for the current design, the colors that the current design is using and in which position they should be.

**Color changes**

The color changes are at the top right side of the printout and show the sequence of the color changes. This information is really useful in case the current design will be saved in machine file format which uses Stop instead of color change command.
Sequence icons

The sequence icons are located at the bottom of the page. They show parts of the design split with a special function like color change, appliqué or stop. Also in the bottom of its icon can be viewed the name of the color that should be used, the needle carrier and the position of each object in the embroidering sequence.

Information

The information is the notes that were written on the "Design info..." dialog. This information is placed at the bottom of the page.

Orientation

The orientation is the icon shown with the "R" character on the top right corner of the printout and it shows how the printed page should be put on the embroidery machine in order to define the starting point of the design.

Company name

The company name can be viewed on the top of the printout. What is written on the company name field can be changed from the "Printing" tab of the "Tools → Options" dialog.
Binder space
This option makes the necessary margin (on the left side of the page) in case you want to put the printout in a folder.

Stitch count
With this option you can arrange if the number of stitches of the current design will be printed or not. The number of stitches of the design can be viewed on the header of the printout.

Start point
This option shows or hides the starting point of the design, marked with the above icon.
3D-Preview

This option shows the embroidery design in 3D preview.

Fabric

If this option is disabled, the preview will not preview the fabric behind the design. Therefore if you want to have the fabric as a background you have to check the checkbox next to "Fabric" option.

Design date

This option shows the creation date of the design. The Date is located at the header.

Tiled printout

The "Portrait" option specifies how the design is positioned on the page. If it is enabled then the design is printed vertically; if disabled (Landscape) then the design is printed horizontally.
The scale field shows if the design will be depicted smaller than its actual size and the percentage of the shrink. The first time that the printing dialog will be called, the program finds the best way to show the design in actual size with the least number of pages required.

To automatically restore the parameters indicated at the beginning of this process you could use the "AutoFit" button. If your design is previewed in more than one page, you can print them, cut the border of the page, which is already marked, and bind them to have your design complete.

**Active designs modifications**

This is a supportive tool, located under Window menu, where you can view all the designs that are currently open in the program and some extra functionality:

- **Print** the selected designs one by one or like catalogue.
- **Save** the selected design(s) in the hard disk by changing their location or their format.
- **Write** the selected designs in machine disk.
- **Format** command is available in case it is needed.
- **Close all** the selected designs at once.
- **Right click menu**
  
  Print the selected designs one by one or like catalogue.
In the "Active designs" dialog box you can print the designs one by one or like a catalogue. Therefore you can select the designs you want to print using also the Ctrl or Shift Key for your selections and click the "Print" button to make a print list of designs.

The "Print" dialog box is like the standard dialog box that Wings’ modular® has. Instead of viewing the whole design you can view thumbnails of all the selected designs (Figure 2.39).

The way that the designs will be printed can change by adjusting the printing parameters. The parameters that you can adjust are the following.

**Setup:** with the "Setup" button you can change the parameters of the installed printer. The dialog box that will appear changes from printer to printer. For adjusting the printer setup please refer to printer’s manual.

**Save to JPG:** with this button you can save the print preview in jpg file format (image file format).

**Print area:** in the "print area" you can select which information will be added in the print preview. You can add or remove general "Information" about the design, your "Company’s name", the "Binder space" and the "Stitch-count".

**Save defaults:** If you made some adjustments and you want to be set it as the default settings, you can click on the "Save defaults" button to do so.

**Number of icons:** In the "Number of icons" area you can specify the way that the designs will be placed on the print preview area. In the "X" and "Y" fields you can specify the number of columns and rows of the table where the
designs will be placed in the print preview area. Also you can specify if want the designs to be printed in Portrait or Landscape paper.

**Page:** by increasing or decreasing the "Page" field you can view the other pages that will be print. Only the pages that contain designs are printed when the "Ok" button is been clicked.

When you finish with the adjustments you can click the "Ok" button to print the designs. If you click the "Cancel" button the printing process will be canceled and you will return to the "Active designs" dialog box.

**Save the selected design in the hard disk by changing their location or their format.**

In the "Active designs" dialog box with the "Save as" button you can save as the selected designs in a new location in the file format that you prefer. With this function we have the ability of multi design saving.

In order to apply this function you have to select one or more designs and click on the "Save as" button. The standard "Save as" dialog box will appear where you have to specify the location and the file type you want the designs to be saved. If you click the "Save" button all the selected files will be saved instantly in the location you have specified.

**Format floppy**

With the "Format floppy" button you can format a floppy disk and make it readable from the respective embroidery machine.

In the dialog box that appears you can choose one of the following embroidery machine’s floppy formats: TAJIMA, TAJIMA HD, HAPPY, PFAFF, ZSK, MARCO, BARUDAN FDR, BARUDAN FMC, MELCO DOS, MELCO HD, MELCO SD, SAURER HD, MITSUBISHI HD, TOYOTA, JUKI, SWF, SWF HD.

Place a floppy disk in the floppy drive and click on the "Start format" button. The progress of the format can be viewed in the "Format progress" area.

**Write to floppy**

Using this option you can write the current design to a diskette. First place the diskette inside the drive and then click on this option. The program automatically recognizes the format of the diskette and asks for the parameters. If you have forgotten to put the diskette in the drive, the program will prompt you if you want to "Retry" or "Cancel".

In the following dialog you have to specify:

- **File name:** In this area you have to write the internal name of the design. This name will be seen when you want to load the designs from the diskette. For some formats (eg. Tajima) these names are different than the
ones saved to disk. ZSK accepts only numbers as filenames. Under this field you can see the designs that are already in the diskette.

- **Templates**: In this area you have to select the accepted template that you use in your machine.

- **Maximum stitch length in design / between objects**: In this area you have to select the maximum stitch length that the design will have.

- **Cut is … jumpstitches**: This option has to do with the Tajima format. With the following scroll bar you have to specify how many jumpstitches will be interpreted as a cut.

- Additional information is also given in this dialog:
  - **Machine-Code format**: In this area the program recognizes the existing format of the diskette and shows which code the design will be written in on the diskette.
  - **Design stitches**: In this area you can see the estimated number of stitches that the design has.
  - **Free stitches**: In this position you can see the free space of the current diskette counted in stitches.

**Close designs**

By clicking this button at the bottom right of the "Active designs" dialog you can close all the active designs at once.

**Right click menu**

From the right click menu you have the ability to "Print" your design, change the icon view of the designs, make selections and view the "Properties" of the selected design.

In the "properties" of each design you can view the file name of the design, the path where it is located, the dimension, the number of colors used, the number of stitches, and the notes that the designer have added.
Chapter 3 - Make selections

Introduction

In this chapter we will analyze how we can make object selections from our designs. There are many ways you can select an object from a design or the whole design. You can use the tools from the standard toolbar, the mouse (click) and the functions in the edit menu.

Selection with mouse

If you want to select an object of a design, you have to click on it while you are in object editing mode.

You can also select one or more objects by clicking and dragging the mouse on the design area to draw a **rectangle** or a **lasso** around the object(s) you wish to select. All the objects that are completely within this selection (rectangle or lasso) will be selected. By holding the "Alt" while creating a selection (rectangle or lasso), all objects that part of them is covered by the selection will become selected. With this method you do not need to view the entire object in order to selected but need only a part of it.

When selecting items, if you hold the "Shift" or "Ctrl" key you can add or remove items from the selection by simply clicking on them.

To enable the "Lasso" selection tool you have to click on the 'L' key form the keyboard while you are on "Transform" mode. The cursor will change and a small lasso will appear on it, informing you that the tool is ready for use. To use the lasso tool you have to click and drag with the mouse on the screen to draw a freehand selection line around the objects of the design. This selection tool is very useful for more accurate selections.

A selection can be also made using "Sequence manager" by clicking on the icon of any object. Automated selection presets such as "Select all", "Select none" or "Invert selection" are available on the horizontal icon toolbar and on "Edit" menu from main menu bar.

If you are editing a complex design, you can use the "Hide" selected object(s) tool to hide an object(s) and have a better view of the one you want to work with. From sequence manager tool window you can also select the object(s) you want.

In order to be able to recognize more easily the currently selected objects the software shows them inside a highlighted rectangle like the one on following figure.
Select all

Using this option from the "Edit" menu, you can select all the objects in the design. The same selection can be done by using "Ctrl + A" shortcut key combination on your keyboard or by pressing "Select all" button of the horizontal icon toolbar.

Select none

Using this option in the "Edit" menu, you can de-select all selected objects. The same can be done using Deselect all button of the vertical toolbar or by clicking on an empty area inside the design area. You can also use the keyboard shortcut key "Ctrl+Shift+A" in order to deselect all.

Invert selection

Using this option from the "Edit" menu, you can reverse the objects selected. Anything on the design that is not currently selected gets selected, while the selected items get deselected. This option is useful when you want to select all objects except a small group. You select the small group and then choose invert selection. The same action can be applied by using the "Ctrl+Shift+I" keyboard combination or by pressing "Invert selection" button on the horizontal icon toolbar.

Select by color

Wings' modular® gives you the ability to select a set of objects from a design by their color. This function is very easy to use and is applied as follows.

Right click with the mouse on a color, the color that is used for the objects you want to select, of the "Special functions" toolbar and from the pop-up menu that will appear select the "Select by color" function. All the objects that are using this color will get selected. By selecting multiple objects of the same color gives you the ability to change the color for all of them at once without having to apply the color change to each one separately.

Select by special function
A very special ability if Wings' modular is that we can select a set of objects (or stitches inside one or more objects) inside a design according to the usage of a special function. For example you can select all objects that have a "Thread trim" applied on them.

This function is very useful because you can easily apply another special function on all objects, without having to apply on any of them separately.

The "special functions" toolbar is the second horizontal icon toolbar that is located on the top area of Wings' modular main application window, when the software is loaded. A “Special function” is a special command that will instruct the embroidery machine to perform a special action. The available special functions can be applied in one or more object(s)-stitches.

Any applied special function is performed before the actual embroidery of the specified object, otherwise you can apply it using “Stitch editing” mode in one or more stitches of any object.

You can also see the objects that have a special function applied from the icons that appear on the right part of sequence manager, revealing that a special function has been applied.

The usage of this special functionality is very simple. You can just right click on any of the available special functions on special functions toolbar, in order to have access to this special selection tool. Once you right click on an object a popup menu appears stating "Select by" followed by name of the special function.

The selection options for “Stop” special function appear in the above figure.

Once you select the first option of this popup menu, all objects that have this special function are immediately selected.

The other 2 options are only enabled when in stitch editing mode. This happens because any special function can be applied only once on an object, while it can be applied many times on more than one stitches of the object.

At this time we need to mention that when using the "Select by special function options in stitch editor the selection is done among all the stitches of the object. In case we want to select all the special functions starting from the currently selected stitch we need to hold "Shift" while using the select by special function option. The same applies to the above described capabilities.

1. **Add to selection by special function**

   This option allows selecting a number of stitches, and by pressing this option all the stitches that have the selected special function to be added in the initial
selection. This way we can make a selection of stitches that have a special command and some that don't have any special command in order to move them or apply another special function.

2. Remove from selection by special function

We use this option if we need to remove the stitches that have a special function applied from a selection of stitches.

**Select by stitch type**

In many cases it is very useful to be able to select all objects from a design according to their stitch type. Sometimes we want to apply a specific option on all the objects of the same stitch type. For example we want to select a style or pattern for all Step objects in a design, we don't have to make the adjustment for each one of the Step objects separately. You can also change all objects of a stitch type into another stitch type.

To select all the objects of a stitch type, you have to first define a stitch type on the top area of "Object properties" rollup. For example define "Step" stitch type. Once the stitch type is defined by right clicking on any part of Object properties rollup a context menu appears. Press on "Select by type" action on this menu and all objects of the selected stitch type will get selected.

![Select by type](image.png)

All **Step** objects of the design will be automatically selected. By selecting the objects with the same stitch type you can make modifications that will affect all of them.

**Select by Preset**

...
Object properties toolbar allows you to save "Presets" that you can use whenever you want.

You can also use different presets to different objects that sometimes is confusing to distinguish. To be easier to find which preset has been applied to which object, Wings’ modular® gives you the ability to select all the objects that have a specific preset applied on them.

To do that you have to select the "Stitch type" of the objects from "Object properties" rollup and then right click on the area where the options of the stitch type are listed. From the right click menu choose "Select by preset" option and the "Current Preset" dialog will appear. From there select the preset you want and click "OK". All objects that this preset was applied will be selected. By having those objects selected you can make any change you want that will be applied to all objects.
Chapter 4 - View your designs

Introduction

In this chapter we will analyze the ways that you can view your file designs. You will learn how to Zoom in/out your designs, measure them or move them around the design area. Also you will learn how to change view modes in your designs. The default view mode is digitizing mode. You can change this mode and view the embroidery design in 3D preview. All the functions in this section can be accessed from "View" menu and standard toolbar. In addition will be analyzed the way that you can insert guidelines, activate grid on the working area, how to use color manager and how to add information to your designs.

Zoom tools

Wings’ modular provides 5 tools that you can use to easily adjust your current view port. We will provide a description of their usage and you will learn more about the available ways to access them in the following sections. You can access their usability through various workspace components. They can be accessed through:

- Image map palette icon toolbar
- Modes toolbar selected Zoom tool
- Various keyboard shortcuts

But let's take a look at their usage for now.

Zoom In

Using this tool you can **Zoom-in** your view to a portion of a design.

1. Select **Zoom in** tool.
2. The mouse cursor becomes a magnifying glass.
3. Click on a point and drag the mouse (Holding the left button).
4. The area that you mark will be the new view port.

You can also access Zoom in tool just by right clicking in a white space on the design area.(Mouse cursor must not be over any selected object). Another quick way to access Zoom tool is by clicking on its icon that is located on modes toolbar, that is located on the left side of the design area.
**Zoom Back**

Using this option you can "Zoom-back" to the previous view port of the current design. The new view port will be the same as it was before the last zoom-in.

If you right click on the design area you also activate the zoom-back function (The mouse cursor must not be over any selected object).

Another quick way to access Zoom Back tool is by clicking on its icon that is located on modes toolbar, which is located on the left side of the design area.

---

**Zoom All**

By pressing "Zoom all" tool you can see the whole design. Wings’ modular® makes the best fit of the design in the design area according to the size of the window.

The same functionality can be also accessed by pressing "A" shortcut key on your keyboard.

By Double clicking the right mouse button on the design area the same number of times you have zoomed-in, also activates the zoom all function.

---

**Pan**

The "Pan" tool lets you move a design around your screen like you would move a paper around on a desk with your hand. Once you select the pan tool the cursor will change into a hand like the one on the icon and you can use it by clicking and dragging on the design area. To move the working area you have to move the mouse slowly to the direction you want. The view port will move, showing you the design to the direction that you are moving the mouse. In order to release the Pan tool right click inside the design area or select some other tool.

You can activate the "Hand tool (Pan)" function by pressing its icon on the horizontal icon toolbar of "Image Map" rollup, or in modes toolbar that is located on the left side of the design area. Another way to access Pan tool is by using "Ctrl+ Right click" shortcut key.
Mouse Pan

Another way to Pan in your design is by using the middle mouse or by clicking the mouse wheel. The mouse pan tool will appear that allows you to navigate yourself on the design by simply moving the mouse towards the direction you want to view. The mouse cursor changes to an arrow showing you the direction that you are moving. To end the Mouse pan you have to left click once on the working area. The Pan will end immediately. You can activate it again by clicking on the middle mouse button (wheel) once more.

Zoom Out by 25%

By pressing “Zoom out” tool, you can zoom-out the current design, by 25%.

Change view port

This section covers the various ways to access the Zoom tools described in the previous section and some examples of the way to work with them.

Image map

The Image map roll up gives you the opportunity to see and change the view port of the main window of the program. This roll up has three parts:

The first part is the horizontal icon toolbar that is located on the top area of the roll up. This toolbar includes all the Zoom tools mentioned in previous section. By pressing any of the icons the respective tool is enabled.

The second part of image map palette is a thumbnail-representation of the design that is currently loaded. Inside this map of the design there is rectangle area that highlights which part of the design is currently viewable in the design area. In figure 4.3.1 that the design is in "Zoom All" the highlight area is around the whole design. In the next figure 4.3.2 that we have Zoomed in on a specific part of the design you can see the highlight area in image map revealing the currently viewable part of the design.
Click and drag this highlight area inside image map palette, the design area will preview the part of the design that is indicated by this highlight area. The current zoom will remain unchanged.

The highlight area of image map is around the whole design

The highlight area is around the part of design that we have zoomed in

The last part of the image map palette, is the Zoom track bar. You can change the Zoom of the view port, using this track bar. The scale of the zoom can be viewed on the right side of the track bar.

In case you have closed the Image map palette you can re-call it using from menu View→Rollups→Image map palette. More information about handling workspace components can be located in Workspace tour section.

### Zoom tools on Modes toolbar

The available "Zoom tools" that were described previously on "Zoom tools" section can be also available on modes toolbar. On modes toolbar you can select one of the Zoom tools to be active on the toolbar. The one that is active can be used easily by a single click. In order to select some other Zoom tool to be default visible on the toolbar you have to press the small arrow that is located on the lower left corner. If you keep it pressed the available tools appear, while holding the left button pressed you can move your mouse over any of the available icons, release the mouse and the tool gets selected and its icon becomes the default on modes toolbar. Now you have quick access to The Zoom tool you desire. By default the zoom in tool is the default.

Press the small arrow on the left lower corner of Zoom tools

Keeping the left mouse button press, move to the tool you wish to select

Once you release the mouse the tool is enabled and its icon is set default in order to be able to easily access it.
Using keyboard and mouse shortcuts

In order to access the available Zoom there are various keyboard and mouse combinations. We have mentioned most of them previously but we will make a brief description in order to recall them.

**Zoom in**, you can use 'Z' key on your keyboard and the mouse cursor becomes a magnifying glass prompting you to select an area with your mouse by click and drag in order to turn this selection into the current view port.

**Zoom back**, use "Shift+Z" keyboard combination on your keyboard in order to go back to the last used view port.

**Zoom All**, press "A" key on your keyboard in order to view the design in best fit according to the size of the window.

**Pan**, press "Ctrl" key on your keyboard and then **right click** with your mouse. The cursor becomes a hand and you can easily move the design area in order to see better each part of it you like.

**Zoom out by 25%**, has no keyboard shortcut you can only access the functionality by pressing on its icon (Image map palette, modes toolbar).

**Zoom preset**

With click on this button of the horizontal toolbar, you can see the current design in actual size.

Moreover by clicking on the arrow on the right of this icon, you can select one of the zoom presets.

Reviewing your work - Embroidery process simulation

In embroidery process the most valuable step before turning on your embroidery machine to embroider any of your designs for first time, is a simulation like of the embroidery process. You can use tape buttons to **move** through object/stitches, located on standard toolbar to move to any stitch/object you have created. See the exact placement of stitches placed and correct any detail of your design. Also, for the same purpose you can use the arrow keys from the keyboard. The "Right" and "Left"
arrow keys are simulating the design stitch by stitch and the "Up" and "Down" keys object by object. Another more automated way to simulate the process is by using "Slow redraw" tool. By pressing the "Slow redraw" icon on standard toolbar the slow redraw roll up appears. You can only use this tool while you are in stitch editing mode.

### Moving through Objects/Stitches

These tape buttons of the horizontal toolbar helps you to select the **object** or the **stitch** you want from the current design. 

Click one by one the following icons in order to see its functionality.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
</table>
| ![First Object](image) | First Object  
The first object of the design gets selected when you are in object or node editing mode. If you are in stitch editing mode, the cursor goes to the first stitch of the design. |
| ![Previous object](image) | Previous object  
The previous object gets selected when you are in Object/Node editing mode. If you are in stitch editing mode the tool moves you to the first stitch of the current object. |
| ![Previous stitch](image) | Previous stitch  
Using this tool you can move the cursor to the previous stitch. If you keep pressing this button the cursor will start to move faster. This tool works only in stitch editing mode. |
| ![Next Stitch](image) | Next Stitch  
Using this tool you can move the cursor to the next stitch. If you keep pressing this button the cursor will start to move faster. This tool works only in stitch editing mode. |
| ![Next object](image) | Next object  
The Next object tool moves the cursor to the start of the next object when you are in stitch editing mode or to the next object when you are in object/node editing mode. |
| ![Last Object](image) | Last Object  
By using this tool you can see and select the last object of the design (Object/node editing mode). If you are in stitch editing mode, the cursor goes to the last stitch of the design. |
| ![Slow redraw](image) | Slow redraw  
|
Slow redraw rollup is a nice tool that provides an automated way to watch a visual representation of the way the design will be embroidered. Slow redraw window can only be visible in stitch editing mode.

Once you enter **Stitch editing** mode you can use "Slow redraw" button that is located on standard toolbar on the upper part of the window. Once Slow redraw tool is it is enabled it appears on top of the design area. By pressing "Start" button you can watch a visual simulation of the way your design will be embroidered. In case that no object-stitch is selected, the simulation will start from the start of the design. In case you have selected any object, the simulation will start from the selected object-stitch. You can stop the simulation by pressing "Stop" button. You can also stop the simulation by pressing "Esc" key on your keyboard. After Stopping the simulation, you can always start over and continue from the stitch you left the simulation or from the currently selected **stitch/object**. You can always use tape buttons together with **slow redraw** tool in order to navigate through object/stitches. Use the track-bar on the upper part of the roll up to adjust simulation speed. While using the track-bar you can see the selected speed on top of the track bar. Finally the button at the bottom of “Slow redraw" roll up can be use to switch between "Move head" or "Move frame" mode. By default it is set in "Move head" mode. When move head is pressed you can see the head of the embroidery machine moving along the design simulating the embroidery process. In case you select "Move frame", the head stays at the same place and the design (Frame/hoop) moves in such a way in order to pass under the head to be embroidered.

You can also use "Slow" redraw simulation tool together with Show up to cursor function. Select a stitch by pressing show up to cursor all stitches until the selected stitch will be inserted, the by using slow redraw function you can watch the rest of the stitches.

A brief description about how these controls work:

<table>
<thead>
<tr>
<th><strong>9900</strong></th>
<th>The machine <strong>speed</strong> that you select on the track bar, shown in numeric format.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulation speed track bar, <strong>Simulation speed</strong> track bar, Select the speed of the simulation. It looks like you are selecting your embroidery machines speed. Simulation speed cab between 100 and 9900 RPM</td>
<td></td>
</tr>
</tbody>
</table>
**Preview 3D**

With this option from the "View" menu, you can view the design in a more realistic preview that is closer to how it will be embroidered. You can also activate this function at any time by simply pressing the 'P' key - to revert to previous view press 'P' key once more. Please note that the thread is viewed much thicker than in the normal view.
The option displays the design at the same zoom level you were using prior to its activation - by doing so you can check that the density of the stitches and if the overall appearance of the design is correct. Please remember that if you are working at very high levels of zoom then the stitches and gaps between them that are shown may seem large on the screen but in reality the gaps are too fine to see.

The fabric of the preview can be changed from the "Change Fabric" option of "Layout" menu. The color of the fabric depends on the background color that you are using. You can change the background color by using Color manager tool.

### Set light source

You can activate "Set light source" from "View" menu. The "Adjust light" dialog will appear from where you can change the light source of the embroidery's 3D preview. The option of Set light source becomes available only if you are working in "3D preview" mode (View ➔ Preview 3D). It is a 3D tool that gives you the ability to illuminate your design from different angles.

If you activate the "Set light source", the "Adjust light" dialog will appear with a 3D ball in it. The light source changes by moving the crossed lines to the position you want the light to come from or by click and dragging on the ball to the position you want the light to be. The yellow crossed lines show where the new light source will be and the blue their initial position.

Another option that you can adjust in the dialog is the "Intensity" of the light that illuminates the threads. By click and dragging the "Intensity" bar to the left the light decreases and to the right the light increases. Select the amount of light you want to illuminate your embroidery designs and click "OK" button to apply the changes you have made to the dialog.

The best way to make the adjustment accurately, is by having an embroidery design loaded prior activating the "Set light source" option. Any change you
are making inside the “Adjust light” dialog it is immediately previewed on the design allowing you to make accurate adjustments.

We can also use “Save as default” option in order to save current light source as the default for every design. Once a default value is selected and saved as default it will be used for every new design. You can also use Reset to default in order to reset the light source to the default value.

Hide

This tool hides the selected object(s). You can also hide selected object(s) by pressing “H” shortcut key on your keyboard.

Important: when one or more objects are hidden they are not displayed and cannot be edited but is still included as part of the design.

The hidden objects can become visible with the "Show hidden objects" button of the horizontal toolbar or by pressing "Ctrl+H" keyboard shortcut.

This tool is very helpful when you are digitizing an imported backdrop image and you have overlapping areas.

There is also another capability to hide object of a selected color. This option is used in case that we want to hide all the objects with a specific color so that we don't have to select them all one by one. In order to do that we must right click on the desired color and from appearing menu select the option "hide by color" all the objects that use this color will be hidden. Their outline will remain in order to reveal their position but you can't see their stitches or select them. These hidden objects can become visible with the "Show hidden objects" button of the horizontal toolbar or by pressing "Ctrl+H" keyboard shortcut.

Show hidden objects
This button on the horizontal toolbar shows all the hidden objects of the current design. This option alters the "Hide" option. You can also show hidden objects by using "Ctrl+H" keyboard shortcut.

**Show Stitch Marks**

Using this tool you can see the stitch marks (needle penetrations) applied to the design. This is useful when you want to see the pattern of an area of step or tatami stitching.

**Show Up to Cursor**

Using this tool you can see the stitches of the design up to the stitch that the cursor has reached. This option can only be used if you are in "stitch mode".

When you are in "object mode", the program automatically turns to "stitch mode". To move through the stitches you can see the tape buttons:

![Tape buttons](image)

or by using slow redraw

**Show Filled Outlines**
Using this option you can view the areas that will be covered with stitches in a light color. This helps to view better the stitches that are placed on the outline of the design.

**Show filled outline**  **Show normal outline**

### Measure tool

With this tool you can measure anything in the design area. We can also measure the horizontal and vertical movement as well as the angle of the movement. It is a very useful tool whenever you need to know the exact dimensions of a specific object or design. You can activate this tool by holding down the "Shift" key and right clicking once with the mouse. The "Measure" tool is activated and the cursor changes into measure \( \text{mm} \). In order to measure a distance between two points, you have to move the cursor to the first point left click to that point and drag it till the next point. Next to the measure tool, while dragging, appears the measure text dialog where you can view the distance from the starting point to the current point and the angle movement. You can also see as seen on the figure bellow the length of the horizontal-vertical movement.
When you finish measuring just release the left mouse click and the "Measure" tool will stop functioning. With some practice you will get used to it.

**Ruler**

The "Ruler" appears at the left and top sides of the working area. It is transparent and becomes solid only if you place the mouse on it. The ruler shows the values of virtual 'X' and 'Y' axes based on centimeter or on inch values. The 0 on 'X' axis and the 0 on 'Y' axis in the starting point of the axes. The values on the ruler are changing based on the zoom you are using to view the design.

The ruler can help you draw size and align the objects precisely and create the design you want.

In case you select "US" measurement system, from "Tool → Options → General tab" the ruler will show information in "US"(inches) and not "Metric".

**Guidelines**

When you are creating a design inside Wings’ modular® it is sometimes useful to add guidelines to help you in aligning the objects or creating new ones. Guidelines appear in the working space like dotted lines with light blue color. If you want you can change their color from "Tools → Options → Colors tab" easily, by selecting a different color from the list or creating a new custom color.

There are four different types of guidelines:

- The **Horizontal** guidelines
- The **Vertical** guidelines
- The **Diagonal** guidelines
- The **Circle** guidelines
Horizontal Guidelines

To add a "Horizontal Guideline", left click on the Horizontal ruler and drag a dotted line down to the position you want in your working area. You can also get a "Horizontal" guideline with a right click on the Ruler (Horizontal-Vertical) and from the appearing menu select "Add new guideline ➔ Horizontal".

In case you right click on the vertical ruler the new guideline will be inserted exactly at the place you right clicked. In case you right click on horizontal ruler it will be placed under the horizontal ruler.

You can reposition the inserted "Horizontal Guideline" by clicking and dragging it to the position you want it.

1. Place your mouse over the guideline until it gets highlighted.
2. Left click and keep pressed on the highlighted guideline.
3. A move handle appears revealing the directions in which you can move the guideline (Up or Down).
4. Drag your mouse (Keep left click pressed) towards the direction you like.
5. Once you release the mouse it is placed to the place you have defined.

You can also lock a guideline to the position that is located, to avoid accidentally moving it during editing the design. To do that you have to right click on the guideline and from the pop-up menu that will appear select "Lock Guideline" option. Once the guideline is locked its color will change to the color that is selected for locked guidelines and you will not be able to move it. To unlock the guideline you have to right click on the guideline and from the right click menu select "Unlock Guideline" option.
Finally, you can delete any guideline by right clicking on it and selecting the "Delete Guideline" option. Another way to delete a guideline is to drag it over the ruler until a "small garbage-can" appears. By releasing the mouse click while the "small garbage-can" is still visible, the guideline will be deleted.

**Vertical Guidelines**

To add a "Vertical Guideline", left click on the Vertical ruler and drag a dotted line down to the position you want in your working area. You can also get a Vertical guideline with a right click on the Ruler (Horizontal or Vertical) and from appearing menu select "Add new guideline ➔ Vertical Guideline".

In case you right click on the horizontal ruler the new guideline will be inserted exactly at the place you right clicked. In case you right click on vertical ruler it will be placed next to the vertical ruler.

You can reposition the inserted "Vertical Guideline" by clicking and dragging it to the position you want it.

1. Place your mouse over the guideline until it gets highlighted.
2. Left click and keep pressed on the highlighted guideline.
3. A move handle appears revealing the directions in which you can move the guideline (Left or Right).
4. Drag your mouse (Keep left click pressed) towards the direction you like.
5. Once you release the mouse it is placed to the place you have defined.

You can lock a guideline to the position that is located, to avoid accidentally moving it during editing the design. To do that you have to right click on the guideline and from the pop-up menu that will appear select "Lock Guideline" option. Once the guideline is locked its color will change to the color that is selected for locked guidelines and you will not be able to move it. To unlock the guideline you have to right click on the guideline and from the right click menu select "Unlock Guideline" option.

Finally, you can delete any guideline by right clicking on it and selecting the "Delete Guideline" option. Another way to delete a guideline is to drag it over the ruler until a "small garbage-can" appears. By releasing the mouse click while the "small garbage-can" is still visible, the guideline will be deleted.

**Diagonal Guidelines**

To add a "Diagonal Guideline", right click on the Ruler and when the pop-up "Add new Guideline" appears, select "Diagonal" option. The "Diagonal Guideline" will be inserted exactly in the position where you right clicked on the Ruler. Also, you can insert a "Diagonal Guideline" by click and dragging from the top left corner where the rulers are crossing into the working space.
You can reposition the inserted Diagonal guideline by clicking and dragging it from its center to the position you want. If you position the mouse over the diagonal guideline far from its center, the cursor will change to rotation icon allowing you to rotate the diagonal guideline by clicking and dragging it. The guideline will rotate by displaying the current angle next to the cursor.

If you hold the "Ctrl" key pressed while rotating the guideline, it will snap on every 22.5° to make precise rotation of the guideline.

There is also a way to insert two crossed diagonal guidelines at once in the position you want. In order to insert them, keep pressed the "Shift" Key of the keyboard and right click with the mouse. The cursor will become as a ruler with a cross on the top. Click and drag on the position you want and during dragging right click once. The program will insert two crossed diagonal guidelines. The first guideline follows the line you drew when you dragged the mouse and the second will be vertical to it.

Also, you can lock a guideline to the position that is located, to avoid accidentally moving it during editing the design. To do that you have to right click on the guideline and from the pop-up menu that will appear select "Lock Guideline" option. Once the guideline is locked its color will change to red and you will not be able to move it. To unlock the guideline you have to right click on the guideline and from the right click menu select "Unlock Guideline" option.

Finally, you can delete any guideline by right clicking on it and selecting the "Delete Guideline" option. Another way to delete a guideline is to drag it over the ruler until a "small garbage-can" appears. By releasing the mouse click while the "small garbage-can" is still visible, the guideline will be deleted.

### Circle guidelines

To add a "Circle Guideline", right click on the Ruler and when the pop-up "Add new Guide" appears, select "Circle" option. The cursor will turn to a pencil allowing you to draw a circle by click and dragging on the working space. If you keep pressed the "Shift" key from the keyboard during dragging, the point that you will click will be the center of the circle guideline.

Another way to insert a circle guideline is by calling the "Guidelines" option of "View" menu and press the "Add circular" button. The cursor again will become a pencil and by click and dragging you can draw the circle guideline.

If you want to reposition the circle guideline, you have to click and drag the cross that appears at the center of the circle guideline to its new position.
Also, you can change the radius of the circle by click and dragging on its circumference. The cursor will change to a two sided arrow allowing you to decide from which direction you want to move the circumference.

Also, you can lock a guideline to the position that is located, to avoid accidentally moving it during editing the design. To do that you have to right click on the guideline and from the pop-up menu that will appear select "Lock Guideline" option. Once the guideline is locked its color will change to the color that is selected for locked guidelines and you will not be able to move it. To unlock the guideline you have to right click on the guideline and from the right click menu select "Unlock Guideline" option.

Finally, you can delete any guideline by right clicking on it and selecting the "Delete Guideline" option. Another way to delete a guideline is to drag it over the ruler until a "small garbage-can" appears. By releasing the mouse click while the "small garbage-can" is still visible, the guideline will be deleted.

**Guidelines options**

Inside "Guidelines options" you can adjust the properties of each guideline. You can activate "Guideline options" by either selecting Guidelines option from “View” menu or by selecting "Guidelines options" from the popup menu that will appear after right clicking on the rulers. All guidelines appearing as blue dotted lines on the workspace helping you to create easily and accurately your embroidery designs. During digitizing or object editing the cursor snaps on the guidelines helping you to draw exactly what you want.

All guidelines can be repositioned by click and dragging them to a new position. In addition you can move a guideline by changing its properties from the "Guidelines" dialog.
You can delete a guideline by right clicking on it and selecting the "Delete Guideline" option. Another way to delete a guideline is to drag it over the ruler until a "small garbage-can" appears. By releasing the mouse click while the "small garbage-can" is still visible, the guideline will be deleted. Also, a guideline can be deleted if you select it from the "Guidelines" dialog (Figure 4.16) list and then press the "Delete" button. In the same dialog you have the ability to "Delete all" guidelines by clicking on the respective button. Another way to delete all guidelines is by right clicking on the "Ruler" and from the right click menu select "Delete all guides".

The horizontal guidelines can be viewed in the "Guidelines" list with the character "H" in front and the vertical has the character "V" (Figure 4.17). In both cases the only parameter that you can change is the "Position" counted from the center of the design and if you want to be "Locked" or not.

The diagonal Guidelines can be viewed in the Guidelines list with the character "D" in front (Figure 4.17). The parameters that you can change is
the "Horizontal"(X) position, the "Vertical"(Y) position, the rotation "Angle" of the guideline and if you want to be "Locked" or not.

The circular Guideline can be viewed in the Guidelines list with the character "C" in front. The parameters that you can change is the "Horizontal"(X) position of the circle center, the "Vertical"(Y) position of the circle center, the Radius "R" of the circular guideline and if you want to be "Locked" or not. Also, inside the "Guidelines" dialog you have the ability to add more circular guidelines by simply clicking on the "Add circular" button. The cursor will automatically change to a small pencil that allows you to draw the circular guideline by click and dragging on the working space. At the moment that you will insert a circular guideline the dialog will close.

After finishing the adjustments you want to make inside the "Guidelines" dialog, you can apply them by clicking on the "OK" button or on the "Cancel" them if you want to close the dialog and discard all changes.

You can change the colors that will be used for guidelines using from "Tools" menu "Options" and then in tab Colors adjust the colors that refer to guidelines (Locked and Unlocked)

**Toggle Grid**

With this option from the "View" menu or the "G" key from the keyboard, you can display grid lines on the screen to allow accurate positioning of the design.

If you activate the Grid options from the "View" menu a dialog box (Figure 4.19) appears that asks you to specify the distance between grid lines for the 'X' and 'Y' axis and if you want the grid lines to be displayed.
The origin of the grid is always the "Start-point" of the design. Please note that if you alter the design start point later on, then the position relative to the grid will also be changed:

- **X unit**
  
  In this area you can enter the distance between grid lines for the 'X' axis. The distance must be entered in millimeters.

- **Y unit**

  In this area you can enter the distance between grid lines for the 'Y' axis. The distance must be entered in millimeters.

- **Show grid**

  The grid lines will be displayed while you are working on the design if this option is enabled.

You can change the colors that will be used for grid lines using from Tools menu, Options and then in tab Colors adjust the colors that refer to grid lines.

---

**Crosshair**

Using this option in "View" menu, a cross follows the mouse when it is on the design and helps you align and position design items. You can also initiate the crosshair display by pressing the letter "C" from the keyboard while you are working with the design.

You can change the color that will be used for Crosshair lines using from Tools menu, Options and then in tab Colors adjust the colors that refer to Crosshair lines.
Design info

Using this option of "File" menu you can view and add information relating to the current design. The same option can be called for the horizontal toolbar by pressing on the respective icon.

The "design information" dialog has four sections:

- General
- Summary
- Yarn
- Stitches
- Sequins

To add the information in the data of the design you have to press the "OK" button. If you want to discard the changes you have made, press the "Cancel" button.

General

On the top of the "general" section of the Design Information dialog you can see the path and the file name of the current design. For example, c:\users\public\documents\Wings' modular\wingsXp.ings. This field cannot be changed from the design information dialog but only from the "Save as" option of "File" menu.

The following fields listed are:

- Size
- Number of stitches
- Number of color changes
- Number of thread trims

You have the option to add information on: Date, Fabric, Yarn and Density if you wish.

Also you can see if the current design has "Borer" or "Sequins" but this information cannot be changed because it depends on the design itself.

**Summary**

You can enter information in the "Customer" and "Designer" fields to allow you to make notes on the design which can help your record keeping. These fields can be used also as filters in search option of "Browser".

In the "Keywords" field you can add words that describe the current design. These keywords can be used as a filter in search option of Browser: if you are dealing with hundreds of designs it can be a vital function for quickly searching your database. Many people find it easiest to write down a fixed list of options or keywords to allow multiple users to enter data in the same style into a common design database.
In the "Note" field you can add any other information relating to the design: for example instructions relating to production. This field in one of the "Print items" of the "Print" option.

**Yarn**

The "Yarn" section of the "Design Info..." dialog contains all the information regarding the yarns you need to complete your current design.

Yarn Length per color in meters. The table shows:

- the needle number for each color you have chosen
- the length of yarn and the number of stitches for that needle.

Under this table are listed the total number of colors, length of the yarn and length of the bobbin that you need in order to produce the current design.

The length of the top yarn and bobbin thread depends on two factors:

- the Bobbin tension
- the Fabric thickness

Both factors can be changed using the track bars located at the bottom of the dialog box which will alter the yarn required automatically. This information can be copied to the clipboard and pasted into any standard spreadsheet or word processing package.
Stitches

This function shows an analysis of the stitch make-up in your design:

Stitches per maximum stitch length:

This shows the number of stitches in your design up to a fixed length of stitches.

Stitches per length (in mm):

This shows the number of stitches in your design by category of stitch length.

Histogram:

Pressing this function displays a graph of the numbers of stitches by stitch length; this gives you a visual impression of the information above.

Exact stitches:

Pressing this function opens another dialog box, this allows you to calculate the exact number of stitches depending on the type of machine you intend to use. You can use the default data contained or enter the specific settings of the particular machine you intend to use. The settings of any machine can be recorded separately in the "Machine time" dialog box (see below).

Machine time:
This function opens another dialog box to allow you to record the settings of particular machines individually to keep for future reference; by pressing the “machine time” button you can then calculate the exact time your design will take to run on the selected machine.

**Please note:** all stitches less than 0.4mm can be safely eliminated without affecting the design quality in any way and will increase productivity by reducing production time. Stitch lengths more than 4mm may invoke the "Slow-speed" function on your embroidery machine [depending on the setting of your machine] - you may wish to alter the machine settings or re-digitize the design to ensure that all stitches are under this maximum stitch length.

### COUNT EXACT NUMBER OF STITCHES

Using this option in the "Design info" dialog "Stitches" tab, you can calculate the exact stitches that will be embroidered.

The number of stitches depends on the type of the machine that you are using. These parameters are:

**Code**

In this field with a single click you can specify the code of the machine that you are going to use.

**Macro**

In this field with a single click you can specify the Macro of the current Code.

Maximum stitch length in design / between objects

In this area you have to select the maximum stitch length that the design will have.
Cut is … jumpstitches

This option relates only to the Tajima machine format. With the following scroll bar, you have to specify how many jump-stitches will be translated as a cut.

By pressing the "Calculate" button you can see the exact number of stitches.

### COUNT TIME NEEDED TO EMBROIDER

Using this option in the "Design info" dialog "Stitches" tab, you can calculate the needed time in order to embroider the current design. This calculation will be made without counting thread breaks or time to change frames.

The needed embroidery time depends on the type of the machine that you are using. These parameters in order to specify the type of the machine are:

**Machine type**

In this area with a single click you can select the type of the machine that you are going to embroider the current design. Also you can create your own type of machine by pressing the "New machine type" button.

**Maximum stitch length**

In this area you have to select the maximum stitch length that the design will have.

By pressing the "Calculate" button you can view the time that the current design needs to be embroidered.

### MACHINE TYPE

In order to create a new machine type you have to specify the following parameters:
- **Type**  
  In this area you can name the new machine type that you have created.

- **High speed**  
  In this area you enter the highest speed of your embroidery machine.

- **Low speed**  
  In this area you enter the lowest speed of your embroidery machine.

- **Length Hi -> Lo**  
  In this area you can enter the longest stitch the machine can embroider without slowing down.

- **Stitches Lo -> Hi**  
  In this area you can enter the number of stitches that your embroidery machine needs to accelerate.

- **Color change**  
  In this area you can enter the number of seconds that your embroidery machine needs to change color.

- **Thread trim**  
  In this area you can enter the number of seconds that your embroidery machine needs to perform a trim.

By pressing the "OK" button the new machine type will be added in the machine type list of the "Count time needed to embroider" dialog. With the "Cancel" button you can discard the settings you have input.

**HISTOGRAM**

This function displays a graph of the numbers of stitches by stitch length. While moving the mouse on the graphic area, you can view the stitch length, the number of stitches and their percentage according to the total number of stitches of the current position of the cursor.
With click and drag you can view the same information regarding the selected area.

**Sequins**

In this tab we can see a summary of the types of sequins that are used for the design. For each type of sequins we can see various information about it, more specific in what needle it has been assigned. The size of the sequin and if it is a single or Double sequin.

**Color Management**

This dialog gives you the opportunity to change the colors of the current design or **create**, **edit** and **delete** your own selection of colors or choose from one of the available color references.
On the left side of this dialog you can see the default "color table" of the program.

On the right top side, you can see the colors that have been chosen for the "current" design.

On the right bottom side you can see how the "design" will look after the color changes have been made.

By pressing the "Ok" button, the changes you have made will be applied on the current design. With "Cancel" button the changes will be discarded.

**Color tables**

On the left side of the "Color Management" dialog you can see a drop down menu that lists all the thread manufacturer's color tables that are included in the software. The color table that is currently used is selected on the drop down menu and all colors are listed inside the list below it.

The color table labeled "Colors" is the default color table of the Wings' modular® software. In this color table you can "create" your own colors, "delete" the colors that you do not need or "edit" a particular color.

To select a color from a specific color table, you have to click on the drop down menu, select the color table you want and from the thread color list that will appear below the color table select the thread color you want. In case that the color is not visible, you can use the scroll bar on the right or the mouse wheel to scroll down and view more colors.

To specify a color from the current palette to a particular needle position, just select it and click and drag it to the needle position desired. Another way of
doing this is to highlight the needle number you wish to change, choose the color you want from the desired palette and press the "Set Color >> " button.

If you would like to "convert all" the colors in the current design to the closest colors of any selected thread manufacturer color palette, you can press the "Convert All" button and each needle position will be allocated the closest colors in that range automatically.

This color table list can be arranged in 2 ways, according to the name of the color or according to the color tone.

**Current palette**

Palette in general is a set of colors you have defined when you created the design or you have set in the “Number of available colors” option, plus one for the background.

The current palette is the palette that Wings’ modular® is using to show the colors of the current design.

![Current palette](image)

In case that the loaded embroidery file (design) has no color information, the design will use the default palette, otherwise Wings’ modular® will show the colors of the design.

The colors of the current palette can be changed as we described in "Color tables".

On the current palette you can see the colors and their names that the design is currently using, the sequins of the colors and whether they are used or not.

In case that you want to change the sequence of the colors of the current palette, you should click on the color you want and drag it to a new position.
If you want the currently used colors to be the first colors in the current palette, you can use the "Auto arrange" button to rearrange them. The first color of the current palette is always the background color and its position cannot be changed.

By right clicking on the current palette you can:

- **Load a palette**
  With this option you can load an existing palette. The following dialog is a normal file open dialog and shows the files with .PAL extension.

- **Save a palette**
  With this option you can save the current palette so to be possible to load it again if you wish. The following dialog is a normal "File>Save as" dialog. We suggest that the palette file which has .PAL extension, to be saved in "Palettes" sub-folder of "Wings modular" folder.

- **Set as default**
  With this option you can set the current palette as the default palette. The default palette is the set of colors that the Wings' modular® will use in case that the design will be loaded has no color information. With this way you can select 1-99 colors coming from the Sulky color tables and one for the background and make your own default palette.

- **Reset to default**
  In case that you are not satisfied with the changes you have made in the current palette or you do not like the colors of the current design, with this option you can switch the current palette to the default.

### Number of available colors

When creating a new design we can select the number of available colors for the design. This number should be the number of colors that our embroidery machine supports or the number of colors you want the design to have. In some cases we may need to change a design and work with more colors in order to use it in another embroidery machine. In cases like this we can change the number of available colors using this control.

### Preview in Color management

In this area you can see how the design will look against a fabric background when you apply the changes you have made.
New Color...

With this option you can create your own color. This color can be added only in the Default color table and you can view it with the name “Color”.

There are three methods to create a color.

Red - Green - Blue method

A combination of red, green, and blue levels can be used to define any color.

- **Red** - this specifies the amount of red in the selected color.
- **Green** - this specifies the amount of green in the selected color.
- **Blue** - this specifies the amount of blue in the selected color.

You can see the effect of changing the values above in the color matrix. If you change any R-G-B value, the values for the H-L-S method outlined below will be changed automatically to match. The easiest way to experiment with different colors is to click and hold the left mouse button and move the cursor around the color matrix to the left.

Hue- Luminance - Saturation method

A combination of hue, saturation, and luminosity can be used to define any color.

- **Hue** - this specifies color in the spectrum for the selected color. Hue is a numerical value where 0 is red, 60 is yellow, 120 is green, 180 is cyan, 300 is magenta, and 240 is blue.
- **Luminance** - this specifies the luminance or amount of light or dark for the selected color. Luminance is a numerical value where 0 is white and 60 is black.
- **Saturation** - this specifies the saturation for the selected color.

If you change any of the H-L-S values on by this method then the values for the R-G-B method will be changed automatically. The easiest way to experiment with different colors is to click and hold the left mouse button and move the cursor around the color matrix to the left.
Color map method

This method displays a color matrix. To define a custom color, click anywhere in the circle matrix and then use the triangle at the middle to arrange the saturation and the luminance, as you can see in the illustration below.

If you define a color using the Hue-Sat-Lum or Red-Green-Blue scales, you can look at this matrix to make sure the color is correct. The color you created is also displayed in the "New Color" area.

![Color map diagram](image)

To complete the creation of the new color, you have to name it. This should be typed in the "Name" field.

The new color will be created by pressing the "OK" button. If you want to discard the changes you have made, just click on the "Cancel" button.

Warning: please note that computer screens have physical limitations on the number of colors they can display; some colors you create cannot be displayed accurately. Also note that there is a difference between colors displayed electronically using artificially emitted light and colors as seen by the naked eye using the reflected light from available light sources such as sunlight; the same color values will appear to be different; the methods outlined above are only meant as a guide; please ensure you obtain the assistance of professionally qualified personnel to advise on your final choice of color before transmitting this information or making important decisions on color choice.
Edit Color

With this option you can edit the selected color of the default color table. This can be done by changing the Red - Green - Blue, Hue- Luminance - Saturation parameters and the points of the color map as you can see in the "New color" dialog. You can also change the name of the current color.

Please note that the colors of thread manufacturers color tables cannot be changed.

Delete color

With this button you can delete the selected color of the "default color table". In order to delete a color, you must first select it and then press the "Delete Color..." button - then you have to confirm the deletion of the color in a dialog box, by pressing the "Yes" button. In case you want to cancel this function, you should press the "No" button.

Please note that the colors of thread manufacturers color tables cannot be deleted.

Backdrops

In this section you can learn how you can add, delete or change the properties of a backdrop.

Import Bitmap/Vector backdrop

Using “Import Bitmap/Vector backdrop” option of File ➔ Import menu you can add a backdrop in an existing design or in a design that you have just created. Once you select the import option a typical File ➔ Open dialog appears. Use the dialog to select the file you wish to import. Any file you select using the dialog shows up a preview on the lower part of the dialog as seen on the figure below. Use the preview to find the design you like. The selected file will be imported as backdrop after clicking the “Open” button.

Backdrop properties

With this option of "View" menu, you can change the parameters of the backdrop that you are using.

The backdrop can be any of the known bitmap or vector images and can be added on the design when you are creating it or later with the “Bitmap/Vector backdrop” option of "File import menu".

In case that the current design has more than one backdrops you can see them in the "Backdrops" list. The backdrop with the name limits (e.g. limits 10.00 x 10.00 cm) is the default backdrop that the program adds in case that you have not used any backdrop during the creation of the design.
The parameters you can change on this dialog are:

**Brightness-Gamma-Contrast**

At the bottom of the dialog you can change the Brightness, the Gamma and the Contrast of the selected backdrop. These parameters can be changed with the following track bars and are available in case of a bitmap backdrop.

**Backdrops**

In the Backdrops section you can view all the backdrops you have imported in the design. Each backdrop has specific options that you can enable or disable by checking the respective checkbox. Any change you are making is automatically previewed in the working area. The options you have for each backdrop are the following:

- **Auto-snap**
  When this option is enabled the cursor snaps on the vectors or the colors changes of the backdrop. In order to temporary disable this function, press the **Alt** key from the keyboard when punching the outlines.

- **Selectable**
  When this option is enabled, the backdrop can be selected as a normal object of the design and you can resize, rotate, slant or move it as you wish. This option allows you adjust the backdrop you have inserted easily and make proper to work with it.

- **Use in 3D**
  When this option is enabled, the backdrop is visible in **3D-Preview** option of the design. This option is useful in case that the selected backdrop is the fabric that you willing to embroider the current design.

- **Visible**
  When this option is enabled, the backdrop is visible in the current design. In order to temporary disable this function, press the Alt+1. Also, there are more useful option for the backdrops which are activated with the following shortcuts:
Wings’ modular ® Embroidery Software manual

Chapter 4 - View your designs

- **Hide (Alt + 1)**
  By clicking on Hide – or press "Alt + 1" shortcut key – you can hide the imported backdrop. The Hide option can help you view the embroidery design you have created without confusing it with the backdrop image at the back.

- **Below embroidery (Alt +2)**
  With this option checked you can make the backdrop visible and position it below the design you are creating. Whenever you import a Bitmap image as backdrop, ® automatically positions the image under the embroidery design. Also, another way to enable this option is by pressing the "Alt + 2" shortcut keys from the keyboard.

- **Washed-out (Alt +3)**
  With this option checked you can make the backdrop colors appear Washed-out. This means that the colors of the backdrop will have lighter tones. This is very helpful when you are trying to draw a shape that will have the same color with the backdrop image. Also, another way to enable this option is by pressing the "Alt +3" shortcut keys from the keyboard.

- **Above embroidery (Alt + 4)**
  With this option checked you can position the backdrop image to appear above the design you have created. This is very helpful. You’ll be able to view the backdrop image and be able to design the objects that will be on top of larger objects you have already designed. Also, another way to enable this option is by pressing the "Alt + 4" shortcut keys from the keyboard.

- **Use interpolation**
  This option improves the quality of the backdrop image and helps you digitize the design easier. When it is enabled, it smoothes out the entire backdrop image and removes the pixelization that some time makes the digitizing process more difficult. When it is disabled the smoothness is removed and in high zoom situations the pixels are distinctive. Generally, enable “Use interpolation” when you are importing high resolution images and disable it when you are importing low resolution/size images.

Also in this dialog with:

- **Delete**
  You can delete the selected backdrop. In this case the backdrop will not be deleted from your hard disk but there will be no link between the current design and the backdrop.

---

**Straighten Bitmap**

With this function you can straighten your backdrop bitmap. First you have to load a backdrop bitmap and activate the function. The cursor of your mouse will become a cross. In order to straighten (rotate) your backdrop bitmap you
have to click twice on your bitmap creating a straight line with gradient at the
direction you want your bitmap to be rotated. This is very useful in cases you
want to make slight rotations to scanned images that was placed as
backdrops.

If you did not straighten the bitmap correctly from the first attempt you can use
this option (Straighten Bitmap) as many times as you want. Another way that
you can rotate the imported backdrop is by checking the "Enable Selection"
option from "View→Backdrop" properties dialog, apply this change and then
select and rotate it from the corner handles or using Transform rollup handles.

### Change fabric

While creating a design it is very useful to be able to preview it on a fabric like
the one that you intend to embroider it on. While "3D preview" from "View"
menu is activated you can have a realistic preview of the design that also
presents the selected fabric. When creating a new design the application has
a default selected Fabric. You can also select a **default fabric** for all new
designs using the respective control of "General" tab from "Tool→Options"
window. If you select a template from "New design" dialog, the new design will
have the Fabric that is included in the template. Although while designing it is
possible to change the fabric by activating the "Change fabric" option from the
"View" menu. The "Fabric" window will appear, where you can select one of
the available fabrics. On the right side of the window you can find 6 categories
of fabrics. By pressing the '+' sign that is located next to any of these
categories you can see the available fabrics. Right click on any of them to and
a preview will appear on the left side of Fabric window. The color that the
fabric is previewed is the color that is selected as a background color. When a
new design is created the default color is black, unless you have selected a
template that uses a different background color or if you have selected
another background color using Color manager. When you finish with your
fabric selection and click the "OK" button to apply. In case that a fabric is
already selected and the "Fabric" dialog is called once more you can see the
already selected fabric when dialog window appears.
Fabric categories

There are six categories of fabrics, each one of them is separated from the others for the kind of embroidery that will be placed on the fabric. In case that you don’t want to preview on any fabric you can select NONE option that is on top of fabric categories.

- Embroidery smooth,
- Embroidery Ultra Light,
- Embroidery Light,
- Embroidery Normal Light,
- Embroidery Normal
- Embroidery Heavy
Chapter 5 - Operations

Introduction

In this section you can learn most of the tools that Wings’ modular® has to edit the embroidery designs. We will analyze how you can transform the designs, re-order them and merge or split them. In addition many of the stitch editing tools are explained thoroughly and the way that you can use them. We will start with two useful tools undo and redo.

Undo

Using this option in the "Edit" menu, you can cancel the latest changes that you have made. With this option you can cancel the last seven changes in your design. You can also undo a change by pressing the "Ctrl + Z" keys from the keyboard or by pressing the icon on the horizontal toolbar.

You can recall the cancelled functions by using the redo option. Also you can adjust how many undo you want Wings’ modular® to keep by adjusting the "Undo levels" value from the "General" tab of the "Tools→Options" dialog.

Redo

Using this option from the "Edit" menu, you can cancel the latest undo that you have performed. With this option you can restore the last seven "undo" you have done. You can also redo a change by pressing the "Ctrl+Shift+Z" keys from the keyboard or by pressing the icon on the horizontal toolbar.

Transform

Transform rollup allows you to make precise object(s) transformations by numeric values. This tool window is by default placed on right side of the design area but you can also place it anywhere you like. More information about workspace customization can be found on Workspace tour section of chapter working with files. The transformations are applied on the selected object(s). If Transform tool window is not visible you can activate from "View→Rollups→Transform" option of main menu bar.

The type of changes that you can do can be easily seen from the four icons on the top of them. These are:

- Move
- Rotate
- Scale
• **Alignment**

To call any transform, you have to click on the additional icon and change the parameters, which are relative to the transform that you have called.

At the end of every transform type there are two buttons:

With the "Apply" button, the changes will be done on the selected object(s).

With the "Apply to duplicate" button, the changes will be done on a copy of the selected object(s).

### Move

The "Move" tab of Transform rollup, changes the position of the selected object(s).

![Figure 5.1 Transform Move tab](image)

The following two fields specify the distance between the new and the old position of the selected object(s). This distance should be input in millimeters.

Also, the sign of the input number arranges the direction of the movement. In case the number entered in the X distance field is negative, the selected object(s) will be moved to the left, otherwise they will be moved to the right. The same way for the Y distance. In case the number entered in the Y distance field is negative, the selected object(s) will be moved down, otherwise will be moved up.

The drawing, following these fields, shows clearly the direction of the movement in any case.

### Rotate

The tool "Rotate" of "Modes toolbar", which is located at the left side of Wings’ modular® window, has been replaced with the "Rotate" function of "Object Properties", Transform tab.
The tool "Rotate" of "Object Properties", Transform tab, rotates the selected object(s). In the field "Angle (deg)" specifies the rotation.

The direction of rotation by default is non-clockwise, as the Figure 5.2 shows.

![Figure 5.2 Transform ➔ Rotate tab](image)

The direction of rotation can be changed by enabling the "Clockwise" option. Also the "Angle (deg)" field accepts negative numbers. In this case the direction of the rotation will be clockwise.

### Scale

The "Scale" tool of Transform rollup, changes the size of the selected object(s) or all the current design, in case that nothing is been selected.

In the first part of this dialog ("Horizontal scale" and "Vertical scale") you can scale the selected object(s) as a percentage of the current size. During changing the percentage of the scale, the "Width" and "Height" fields are also changing.

In case that the percentage is more than 100% the selected object(s) will be enlarged, otherwise they will be shrunk.
On the second part of this dialog you can see the size of the selected object(s). Also you can change these fields. During changing the size of the selected object(s) the fields of "Horizontal scale" and "Vertical scale" are also changing.

The "Proportional scaling" option gives you the opportunity to change the size of the selected object(s) by keeping the same analogy between the horizontal and the vertical size of them. That is why, when the "Proportional scaling" parameter is on, and one of the dimensions of the selected objects is changed, automatically the other dimension will be changed with the same percentage. In case that this parameter is switched off, the width and the height of the selected object(s) can be changed separately.

The following buttons, "Mirror X" and "Mirror Y", are mirroring the selected object(s) horizontal and vertical.

**Alignment**

The "Alignment" tool of Transform rollup, specifies the position and distance between the selected object(s).
The alignment can be made horizontal or vertical. The buttons show the way of the alignment.

- Their left side will align the selected object(s).
- Their horizontal center will align the selected object(s).
- Their right side will align the selected object(s).
- Their topside will align the selected object(s).
- Their vertical center will align the selected object(s).
- Their bottom side will align the selected object(s).

The described buttons (for each alignment) are radio buttons. That means, only one of them can be pressed for each alignment. The selected alignment can be cancelled by clicking on the pressed button.

In order to apply the changes you have to click on the "Apply" button or on the "Apply to duplicate" that will create a copy of the selected object with the changes in alignment applied.

Finally you can align manually the objects of the current design by using the "Guidelines", "Grid" and "Crosshair" options of "View" menu.

**Transform with mouse**

In this section you can learn the way to edit the selected objects by using the mouse. You can make the same transformations and even easier.

**Move objects**

Moving objects is easily implemented by click and drag. As in normal windows operation you can press and hold a left click on any file, while holding the left click you can move the object wherever you like.

In Wings' modular, select any object you like by a single left click. Hold left mouse key pressed. While holding left key pressed you can drag the object to any position you want.
1. "Left click" to select an object.
2. Hold you "left mouse click pressed" and the cursor is turning into a four arrow shape that reveals the directions that you can move the object.

3. By holding your left click pressed "drag" the object to any direction you like. While dragging a Shadow like the object you are dragging appears, previewing of how the moved object will look like.

4. Release the mouse and the object is placed into the new position you defined.

If you "right click" while dragging the selected object, an exact copy of the initial object will be created that you can place anywhere you like on the working area after releasing the left mouse click. The new object will be added after the original or to the end of the design in the embroidery sequence. The way that these placements take place depends on whether "Add new objects at the end" option of "Layout menu" is enabled or not.

When you want to move to a position that you can't see on the screen, the program changes the view port automatically during dragging, following the
movement of the mouse (Automatic panning). The Image map always shows where you are.

If you want to copy an object from one design to another (drag-drop), you have to hold the shift key during dragging, to temporarily de-activate the auto-panning so that you can drag the object out of the window. The Object(s) remains selected on the new design and you can move it on the position that you want. To use this feature, you must have both designs open and use the "Tile Horizontal" or "Tile Vertical" option of Window Menu.

If you keep the "Control" (Ctrl) key pressed during dragging, the objects move only horizontally or vertically.

**For moving objects see also:** "Transform" section that we discussed previously in this chapter

---

**Scale objects**

In order to make any scale transformations using your mouse you have to first select the object(s) that you like to transform. Once you select an object(s) you see a highlight rectangle appearing around the select object(s). This rectangle implements some handles on the corners and in the middle of the sides. These handles are indicated as highlighted dots. When you place your mouse over any of these control handles you can see various signs appearing.

When you place your mouse over the highlight controls that are located in the middles of the sides, a double arrow handle appears. Keep right mouse button pressed and drag, a shadow preview of the transformed object appears. Once you release the mouse the transformation is applied.

If you want to Enlarge-Shrink an object proportionally you must use the scale handles that appear on the corners. When you place your mouse over a corner, slightly to the inside of the corner, the "Scale" handle appears. This double arrow handle shows the directions that you can scale the object. Click and drag to the direction you like (Shrink-Enlarge), while dragging you can see a preview of the transformed object. Once you are satisfied by the result release the mouse click and the transformation is applied. You can make as many transformations you like. In any case if you don't finally like the result, you can use "Undo" function or select "Clear transform" option by right clicking on the object. All the transformations that have been applied on this object will be reverted.
If you hold the "Control" key from the keyboard while dragging the mouse, the scale will be made in increments of 25 percent. If you want to make a copy of this object, you have to click the right mouse button once while dragging. Also with the "Shift" key during dragging, you can scale the selected object(s), by keeping the same center.

**For scaling see also:** Transform rollup and Scale sections

**Rotate objects**

In order to rotate an object you must first select it. A highlight rectangle appears around it. When you place your mouse over any of the Corners of the highlight rectangle and slightly to the outside of the corner, a rotate handle appears. By clicking and dragging using this handle you can rotate the object to any direction you like. While rotating, at the bottom of the screen you can see the rotation amount applied to the object in degrees.

Another important thing is the rotation center of the object. It is a small Plus sign that is usually at the center of the object. This is the center of the rotation. You can change/reposition this rotation center in order to rotate the object based to another point.

If you hold the "Control" (Ctrl) key while dragging the mouse, the center point can be moved only horizontally or vertically. If you hold the "Control" (Ctrl) key
while you are rotating an object, the rotation will be performed in multiples of 15 degrees. If you want to make a copy of the selected object, you have to click the right mouse button while dragging.

**For rotation see also:** Transform rollup and Rotate sections

### Slant objects

If you want to slant an object, first you must select it a highlight rectangle appears around it providing some control handles. These handles appear as we have already mentioned when we place the mouse over any of the highlight bullets. When we place the mouse over any of the bullets that exist on the middle of the sides, slightly to the outside, a slant handle appears. Press left mouse button and drag in order to Slant the object.

Another important thing is the center of the object around which slanting operation will take place. Somewhere inside the selected object you will see the symbol  

It is usually in the center of the rectangle. You can click and drag this character to the point you desire and this will be the center of the rotation.

If you hold the "Control" (Ctrl) key while dragging the mouse, the center point can be moved only horizontally or vertically.

By clicking and dragging these points you can slant the design around the center. If you want to make a copy of this object, you have to click the right mouse button once while dragging.

### Mirror objects

If you want to mirror an object first you have to select it. On the corners and sides of the highlight rectangle, which surrounds the object, you can see the highlighted points (handles).
Place your mouse over any of these handles and you will see the available control handles. Press left mouse button and drag any of these handles as you have described in previous sections. Start shrinking the selected object, then continue dragging in the same direction until the design starts enlarging. While enlarging, next to cursor a text dialog appears that shows the Shrink / Enlarge percentage of the object. Also, if you hold the "Ctrl" key down while dragging, the Shrink / Enlarge movement, snaps on specific percentages, helping you to make accurate mirror changes.

If you want to make a mirror copy of this object, you have to click the right mouse button during dragging. This procedure will keep the object in the position that it was and creates a mirror copy of the same object in the position you have dragged it.

**For mirroring objects see also:** Transform rollup, Scale and Apply to duplicate sections.

### Repeat last transform - R

With this option of "Edit" menu you can repeat the last change you have made in the current design. You can also use 'R' keyboard shortcut.

This option works in Object editor/Transform mode.

For example if you have move an object 10 mm to the right and after this you press 'R' shortcut key from the keyboard this transformation will be repeated as many times you have pressed the 'R' key.

### Re-order

In this section you can learn the way to change the sequence of the objects of the current design and how to arrange the objects on the working area.

**Sequence manager**
Sequence manager provides a graphical representation of the embroidery sequence, together with the special functions that are applied on each object.

It is a rollup window that is by default visible on the right side of the working area. In case you have closed it you can activate it again by selecting "Sequence manager" item from "Rollups" sub item of "View" menu. More information about Closing, Hiding, Docking rollups can be found in "Workspace tour" section.

The extra ability of this tool is that you can re-arrange the sewing order for the current design, and select one or more objects. You can do that by selecting the object(s) you want on the "Sequence manager" and dragging them lower or upper in the sequence. Therefore you can organize the sequence of embroidery production in the way you prefer.

The Sequence manager shows the objects in two levels. On the first level you can see the parts of the current design separated by the special functions, like color changes, thread trims etc. (Figure 5.10.1). On the second level you can see the objects of every part in the first level. This can be done by clicking on the "+" which is on the left side of the icon of the sequence manager. If there is no "+" sign, means that this part is an object and it cannot be split (Figure 5.10.2). If you want to go from the second level back to the first one, you have to click on the "-" sign on the left side of the icon of the sequence manager. With the scroll bar of the right side of the Sequence Manager (Figure 5.10.2), you can view (if it is needed) the objects which are hidden.
Also, the "Sequence Manager" can be changed in two modes, "Split by function/Color" or "Split by Color". In "Split by function/Color" mode, the objects will be split by the special functions, like thread trim, Stop, Color change etc. as you can see in Figure 5.10.1-2. In "Split by Color" mode, the objects will be split only by color change special functions as you can see in Figure 5.10.3.

If you want to select a single object, you simply click on it. If you want to select all objects located between two objects, you can click on the first one and then hold the Shift key and click on the last object.

If you want to select specific objects, hold the "Control" (Ctrl) key on the keyboard and click on each object that you want to select.

If you want to add comments on a specific object, you have to right click on it and select the "Comment" option from the pop-up menu. The "Comment editor" dialog will appear where you can write the comments you want for the specific object. Type the comment you want in the "Comment" field and select 'OK' to insert it. A paper clip will appear on the object informing that the object contains a comment. You can, also, add comments to multiple objects by making a multiple-object selection and from the right click menu selecting "Comment". The "Comment editor" dialog will appear with the number of
objects on a list. You can add comment to each object you have to select the its number and type the comment you want in the "Comment" field. When you are ready click 'OK' button to apply changes. To remove a comment you have to open "Comment editor", select the comment you want to remove from the list and delete the text that appear in "Comment" field. Comments are useful when you want to keep notes on specific objects.

In addition with the "Show shadows" option, of the right click menu, you can view the outlines on the other objects of the design in the "Sequence manager" and the current object painted in the thread color you have selected. This option helps you locate the object you are viewing on the sequence manager, inside the design. If you do not want to view the other objects of the design you can disable this option and view only the current object.

There are two more useful options in the sequence manager, "Reverse selection" and "Move here". The "Reverse selection" option from the right click menu can reverse the order of the selected objects in the sequence manager. In order to apply "Reverse selection" option you have to select the objects you want to reverse their order by using the Shift or Ctrl keys and then right click on them and apply the "Reverse selection" option. The selected objects will be reversed immediately without affecting the rest.

The "Move here" option from the right click menu allows you to move the selected objects before or after the objects you want. In order to apply it you have to select the objects you want to move from the sequence manager by using the "Ctrl" or "Shift" keys and then right click on the position you want to move them and apply the "Move here" option. The selected objects will be moved in the position you have defined, re-sequencing the entire design automatically. The same can be done by click and dragging the selected object to their new position.

Finally, in case you have closed the sequence manager roll up you can re-call it from menu "View ➔ Rollups ➔ Sequence manger".

**To back - Home**

This option of "Layout" menu is useful if you want to re-arrange the current design. First select an object and then click on this option. The selected object will be the first embroidered part of the design.
Initial position

To back

See also: To front, One forward, One backward options of "Layout" menu.

**To Front - End**

This option of "Layout" menu is useful if you want to re-arrange the current design. First select an object and then click on this option. The selected object will be the last embroidered part of the design.

Initial position

To Front

See also: To back, One forward, One backward options of "Layout" menu.

**One step backward - PgDn**

This option of "Layout" menu is useful if you want to re-arrange the current design. First select an object and then click on this option. The selected object will be embroidered before its previous object.

Initial position

One step backward

See also: To front, To back, One forward options of "Layout" menu.

**One step forward - PgUp**
This option of "Layout" menu is useful if you want to re-arrange the current design. First select an object and then click on this option. The selected object will be embroidered after its next object.

![Initial position](image1.png) ![One step forward](image2.png)

You can also use the "Sequence manager" to re-arrange the design.

**See also:** To front, To back, One backward options of "Layout" menu.

### Object editor/Transform menu

The object editor/Transform menu is the menu that appears when you right click on the selected object(s). This menu appears only in case you have selected one or more objects. Some of its items appear only when one object is selected, some others when more than one is selected and finally there are some that appear only on certain conditions. Always have in mind that the options that aren’t revealed on object editor context menu need some prerequisite in order to appear. The available options also depend on the selected objects stitch type.

The available options of this context menu are:

- **Order** (To front ,To back ,One step forward, One Step backward)
- **Group**
- **Break apart**
- **Clear transform**

### Order

These options are very useful if you want to re-arrange the current design.

**To back - Home**

Select an object, right click on it and from the appearing context menu select "Order ➔ To back" option. The selected object will now be the first embroidered part of the design.

**To Front - End**

Select an object, right click on it and from the appearing context menu select "Order ➔ To front" option. The selected object will now be the last embroidered part of the design.
One step backward - PgDn
Select an object, right click on it and from the appearing context menu select "Order ➔ One step backward" option. The selected object after the re-arrangement will be embroidered before its previous object in current embroidery sequence.

One step forward - PgUp
Select an object, right click on it and from the appearing context menu select "Order ➔ One step forward" option. The selected object after the re-arrangement will be embroidered after its next object in the current embroidery sequence.

Group – Ungroup
The "Group" option is available appears only if you have selected more than one objects. Once it is applied you can consolidate a group of objects into one. Select the objects you wish to group together and then click on "Group option. Now if you click on any of the object of the group the whole group is selected.

The "Ungroup" option is only available when you select a grouped object. Using this option you can separate the grouped object into its subsidiary objects.

Break apart
Using this option while an object is selected you can split the selected object to its sections. In this case the sections of the object will become separate objects that can be selected and edited separately.

In case that you have selected more than one object you can use only the "Break apart" option of "Edit" menu.

Clear transform
Clear transform option of object editor context menu provides the ability to "Cancel" all the transformation that have been done to an object in object editing mode. This content menu appears when right clicking on any object that has been repositioned, resized, slanted, rotated or when any other transformation has been applied to it while you are in Transform mode. The reverted transformations can be more than one. The object is reverted to its initial state and position that it was designed. When applying "Clear transform" you are asked whether you like to keep distorted shape or not. This way you
can make the present state of an object have no transformations. This is used when you like the current state of an object and you want to be able to recover this state in case you apply any transformations.

**Group**

With this option from the "Edit" menu you can consolidate a group of objects into one. To use this option, first select the objects you wish to group together and then click on this option. After using this function, clicking on this object will select all the sub-object and you can hide, copy, cut etc. all components as one object. The program will keep the groups of the design together even if you save and load it later. See also the "Ungroup" command which breaks groups apart.

**Ungroup**

With this option from the "Edit" menu you can highlight a group of objects that you have made with the "Group" option and isolate them into their separate components. To use this option, select the group you wish to separate and then click on this option. After that you can edit the objects separately.

**Cut**

With this option of "Edit" menu you can remove a part of the design (or the whole design) and paste it in another design or in another application (like Microsoft Word) as a .WMF or .BMP file.

**Copy**

With this option from the "Edit" menu you can make a copy of a part of the design (or the whole design) and paste it in another design or another application (like Microsoft Word) as a .WMF or .BMP file.

**Paste**

With this option from the "Edit" menu, you can transfer a part of another design into the current one. Also, you can paste external graphics directly.
inside Wings’ modular® and convert them to embroidery manually or automatically.

### 2-point copy

This tool is useful when you want to copy an object-design and at the same time place it on another position in the design area rotated, enlarged or shrunk. Select an object and then activate the function "2-point Copy" from "Layout" menu or by pressing "K" shortcut key on your keyboard, the cursor will turn to cross prompting you to select 2 points. Select two points inside or outside of the selected object(s) by creating a straighten line. Then in the same way specify 2 points at the position you want to place the copy of the initial object, rotated, enlarged as you like assisted by the visual assistance the tool provides. When you have inserted the first point and by moving your mouse pointer, you can actually see the exact size and direction of the new copy. While moving the mouse in order to specify the second point for copied object you can use some shortcut keys to perform some transformations on the pasted object.

- If you right click once the object is placed staring from the point you have specified without any scale or any transformation.
- If you hold "Shift" key while moving the scale of the copied object snaps only predefined sizes 50%, 100%, 200%, increasing by 25% each time.
- If you press "V" key the copied object is mirrored vertically according to the initial object
- If you press "Z" key the copied object is mirrored horizontally according to the initial object

You can also use any combination of these shortcut keys, for example press "V" to mirror vertically and then right click once to keep the same dimensions for the copied object.

After inserting one copy the cursor remains a cross prompting you to insert another copy. Insert any other copy if you like or right click on the design area once in order to release the tool.
1. Select an object
2. Activate 2 point copy from Layout menu
3. The cursor becomes a cross prompting you to specify 2 points
4. Specify first point
5. The cursor becomes a cross again,
6. specify the second point
7. The cursor becomes a cross again, specify 2 points to define the place of the copy
8. Right click for the first point
9. Then by moving your mouse you see a preview of the copy according to where you have placed your pointer.
10. When you are satisfied by the preview specify the second point.
11. The copy has been placed, the cursor becomes a cross again. Enter another copy or left click to release the tool.
Copy an object from one design to another

In Wings' modular® there is another copying ability that allows you to copy objects from one design to another using drag and drop technique. If you want to copy an object from one design to another (drag-drop), you have to hold the "Shift" key during dragging, to temporarily de-activate the auto-panning so that you can drag the object out of the window. The Object(s) remains selected on the new design and you can move it on the position that you want. To use this feature, you must have both designs open and use the "Tile Horizontal" or "Tile Vertical" option of "Window" menu.

Duplicate design

You can activate this function from the "Edit" menu or from the shortcut key Ctrl + D of the keyboard.

This function creates a new window with your design duplicated. Your current design remains unchanged. It is useful for creating multiple designs and creating many variations of a design that will help you choose the one you like more.

Split objects

By clicking on a point and then to another, the split objects, splits all the stitches that are passing under the blue line specified by the two points. By clicking additional points, you can specify a polyline, which splits the objects of the design. By clicking the right mouse button, you stop adding points and start a new polyline. Pressing right button again ends the operation. If you want to reverse this operation, you can use the "Join" option from the "Edit" menu.

![Split object]

**Figure 5.16 Split object**
Important: This tool does not convert the stitches to thread trims or color changes, but only splits objects. If you want to add these functions, you must select the object you wish to place trims and click on the thread trim button of the horizontal toolbar. Also it is important to know that this function can be used only on stitch data objects.

Density adjustment

In this section you can learn the possible ways to change the density of the objects of the designs.

Change Stitch-count

With the "Modify density" tool you can change the number of stitches contained in the selected object(s). If you haven't selected anything, then the changes will be applied to the whole design.

In the "Change stitch count" dialog box that appears, using the Track bar, you can specify the percentage of the stitches that will be added or reduced.

Also the stitch count of a punching object can be changed from the density or length parameters of the "Options" tab of "Object Properties" roll up that is available in the "object properties" toolbar.

See also: "Auto-density Apply" option of "Stitches" menu.

Auto-density Apply

Using this option on the "Stitches" menu, you can adjust the density of the selected objects or the entire design (if you haven't selected any object). You
can use this function to match the densities to those that were present before the objects were scaled.

This tool is very important in case you changed the size of certain objects without keeping the same percentage of stitches. In this case, the program changes the stitch count of every object, trying to keep the same density that the object had before the scale operation.

These functions can be applied only on stitch data object. In order to change the density of a punching object you can use the density or length parameters of the "Options" tab of "Object Properties" roll up.

**Auto-density Reset**

Using this option on the "Stitches" menu, you can reset the counter, which keeps the density that every object should have after scaling.

Example: An object has 40 stitches and you expand it 150%. After this you call the "Auto-density Reset" and "Auto-density apply" the object will have 40 stitches. If you will expand it again 150% and then call "Auto- density apply" the object will have 60 stitches.

*Attention:* You must be aware that if you have enlarged a stitch data object, the density is automatically decreased because the program keeps the same stitch count. If you call this option you can't automatically adjust the density later.

*Note:* Auto density function does not work in punching objects. In this case the density depends on the density or length parameters of the "Options" tab of "Object Properties" roll up.

**Modify Satin width**

Using this tool you can change the width of the satin stitches within the object(s) that you have selected. If nothing is selected, then the change will be applied to the whole design.

In the following dialog box you have to specify:

**Change satin width**
With this track bar you can specify the change of the satin stitch width in millimeters.

![Initial state + 2mm satin width - 2mm satin width](image)

**Direction**

With this track bar you can specify the direction of the growth or shrinking of the satin bar.

![Initial state and grow out + 2mm satin width and grow in - 2mm satin width](image)

You must always take in consideration that only the satin cover stitches are changing. The underlay’s remain in the same position.

**Note:** This option can be active only in "Stitch data objects".

In "Satin-ZigZag" objects with "punching data" you can use the "Compensation" option that is available in the "object properties" toolbar.

In Satin serial objects with "punching data" you can use the "Width" option that is available in the "object properties" toolbar.

**Filter**

With this tool you can make automatic corrections on the selected objects or the whole design.

This tool is working differently in "Stitch data objects" and in "Punching data objects".

**In Stitch data objects**

The "Filter" tool can correct designs or part of them, where the stitches are not following correctly the outline (Stitched outside of shapes) or stitches that are...
not keeping the same density. With this way you can increase the quality of your designs.

**Notice:** This tool should not be used more than two times in the same design and we would suggest after you have edited the current design.

### In Punching data objects

The Filter tool erases nodes that are not needed. The way that the filter will be applied on the selected objects dependents on the value of the "Tolerance" of the following dialog.

With the "Track bar" of this parameter you can arrange the maximum movement of the outline after the "Filter" has applied on it.

If the "Track bar" is near to the "Accurate curve" side the nodes will be reduced but the shape of the object will not change. On the other hand, if the "Track bar" is near to the "Less nodes" side, the nodes will be set to minimum needed and the shape of the object will change.
**Reverse**

With this tool you can reverse the way that the selected parts of design will be embroidered.

This tool works differently in "Stitch data objects" than the "Punching data objects".

**In Stitch data objects**

This tool will reverse the sequence of the stitches. This is the reason why before you will use this tool you should separate the underlay stitches from the cover stitches. This can be done by using the "Knife" tool or the "Insert special function" option.

**In Punching data objects**

This tool will change the "Exit" point to "Entry" and vice versa.

**Add new objects to end (Ctrl+Shift+E)**

Using this option in "Layout" menu, all new objects added to the design will be placed at the end of it. Otherwise new objects will be added after the selected object. You can also use the keyboard combination "Ctrl+Shift+E", in order to enable or disable this functionality.

This occurs when you are copying objects from the current design or when you are punching a new object.

Objects copied from other designs are always placed at the end of the current design.

With this way you can easily arrange the sequence of the objects that you are copying or creating in the current design.

Of course in order to rearrange the objects of a design, you can use the Sequence manager roll up or the options: "To front", "To back", "One forward", "One backward" options of "Layout" menu.

**Array/Kaleidoscope**

Another transformation tool which is not in the "object-properties" toolbar, is the "Array" tool that can be activated from the menu "Layout Array". The "Array" tool is useful when you want to make copies of your entire design or of a selected portion. You can either create "Rectangular" or "Circular" arrays allowing you to multiply the objects of the design and create unique formations. You also have the ability to reshape an object of the array you have created.
and the changes that you will make will be automatically applied on all copies of the specific object.

**Rectangular array**

The "Rectangular" array works with the same way that you can create a table in any text editor. Select the object you want to multiply and from "Layout" menu select the "Array" option. The "Array/Kaleidoscope" dialog will appear. If the "Rectangular array" tab is not selected, click on it and you will be able to view all its options.

In the "Rectangular array" tab that appears you can specify:

- the "Number of horizontal Copies".
- the "Number of vertical Copies".
- the "Spacing between horizontal copies"
- the "Spacing between vertical copies"
- the "Orientation of copies"
- If you want to "Keep colors together"
- If you want to "Clone objects if possible".

Make your adjustments and click "Ok" button to apply it on the selected object (Figure 5.24)

**Number of horizontal Copies**
In this field you can specify the number of copies, of the selected design/s, you want to be created in the horizontal axis.

**Number of vertical Copies**

In this field you can specify the number of copies, of the selected designs, you want to be created in the vertical axis.

**Spacing between horizontal copies**

In this field you can specify the distance of the horizontal copies that will be created.

**Spacing between vertical copies**

In this field you can specify the distance of the vertical copies that will be created.

**Orientation of copies**

With this option you can change the orientation of the cloned objects/designs. You can change the orientation of the clones with 90° degrees step as you can see in the image below.

You can do that easily by simply clicking on the ‘P’ you want to rotate once for every 90° degrees step and you will see the ‘P’ rotating. Each ‘P’ represents the copies that will be created vertically or horizontally. Also, by changing the upper left ‘P’ you can change the orientation of the initial/selected object.

This is a very useful option that allows you to create artistic embroidery designs easily by multiplying objects. By clicking "Ok" button on the dialog you will see the orientation you have selected applied on the copies of the objects/designs.

With this option also you can apply the Kaleidoscope effect on the array of objects/designs. You can simply hold Shift key pressed and then click on any ‘P’ to mirror it.

**Keep colors together**

If you want the thread colors of the selected design to be together when they will be sewed, you have to check the checkbox. Otherwise keep it unchecked. This option when it is checked groups the duplicated objects with the same colors together in the sequence manager, to preserve that will be embroidered sequentially. Not all objects with the same color in the design but the same objects with the same colors of all duplicated designs/objects.

**Clone objects if possible**

With this option selected you can create clones of the selected object/design that can be reshaped all together by simply reshaping one of them. This option saves you time and it is a creative tool that can produce unique
embroidery designs. Any shape transformation that you will make on any of the cloned objects/designs will be applied to all of them immediately. To change the shape of all objects you have to select any from the cloned objects, click on "Edit nodes" tool from "Modes" toolbar, to switch to node editing mode and reshape the object by click and dragging the node segments to the direction you want. To view the changes you made applied on all objects, you have to click back to "Edit objects" option of "Modes" toolbar.

**Circular array**

The "Circular" array works with the same way that you can place objects on a circle or on an arc. Select the object you want to multiply on an arc/circle and move its rotation center (is located at the center of the object) in the position where the circular array will be based on to make the repeats. Then from "Layout" menu select the "Array" option. The "Array/Kaleidoscope" dialog will appear. If the "Circular array" tab is not selected, click on it and you will be able to view all its options.

- In the "Circular array" tab that appears you can specify:
  - the "Select start/end angle".
  - the "Step angle".
  - the "Step count"
- If the copies will be applied "Clockwise"
- the "Orientation of copies"
- If you want to "Keep colors together"
- If you want to "Clone objects if possible"

Make your adjustments and click "Ok" button to apply it on the selected object.
Select start/end angle

With this option you can specify where the copies of the selected objects/designs will be placed on the arc/circle.

On the image below with the two arrows, you can see the start and the end point of the arc.

You can click and drag these points on the position you want. If you hold the "Ctrl" key from the keyboard pressed, during dragging the two edges of the arc, you can increase or decrease the arc size with 15° step. Also, if you hold the Shift key pressed from the keyboard during dragging, you can increase or decrease the arc size symmetrically. Any time you want at the middle of the circle you can view the exact position of the "Start" and the "End" arc points.

The setup of start/end angle it is important because the circle array of objects will be applied on it. Once you have created the circle array you do not have the ability to go back and edit the start/end angle but only if you reproduce the entire circle array.

By changing the "start/end angle" the "Step count" options is also changing accordingly based on the size of the arc.

Step angle

In this field you can specify the angle step (degrees) that each copy of the circular array will be placed on. For example if you type 15° degrees, every copy of the circular array will be placed on the arc with 15° degrees between them, until the end of the specified "start/end angle". The "Step angle" that you will specify affects also the number of object/design copies that will be added on the "Circular array". The "Step angle" and the "Step count" options are connected and the value specified in the first options affect the value of the second and the opposite.
The valid values of Step angle option are from 0° to 359°.

**Step count**

In this field you can specify the number of object/design copies you want to be placed in the circular array, between the specified "start/end angle". For example if you set "Step count" to 5 copies, it will place 5 copies of the selected object/design on the specified "start/end angle" by adjusting the "Step angle" accordingly. The "step count" that you will specify affects also the angle step (degrees) that each copy of the circular array will be placed on. The "Step angle" and the "Step count" options are connected and the value specified in the first options affect the value of the second and the opposite. Also the value of "Step count" from the size of "start/end angle" that you have specified.

**Clockwise**

With this checkbox you can specify if you want the circular array to be created clockwise or anticlockwise. If the "Clockwise" option is checked, (this is the default option) then the objects/designs will be placed on the circular array with clockwise order and the opposite if it is not.

**Orientation of copies**

With this option you can change the orientation of the cloned objects/designs. You can change the orientation of the clones with 90° degrees step as you can see in the image below.

You can do that easily by simply clicking on the 'P' you want to rotate once for every 90° degrees step and you will see the 'P' rotating. Each 'P' represents the copies that will be created vertically or horizontally. Also, by changing the upper left 'P' you can change the orientation of the initial/selected object. The changes that you are making on the orientation will be applied on pairs of copied objects including the initial/selected object/design. Therefore if for example rotate the left 'P' 90° degrees (click on the left 'P' once) and the right 'P' 180° degrees (click the right 'P' twice), on each pair of circular object/design copies the respective rotations will be applied starting from the initial/selected object/design.

This is a very useful option that allows you to create artistic embroidery designs easily by multiplying objects on an arc or circle. By clicking "Ok" button on the dialog you will see the orientation you have selected applied on the copies of the objects/designs.
With this option also you can apply the Kaleidoscope effect on the array of objects/designs. You can simply hold Shift key pressed and then click on any ‘P’ to mirror it.

**Keep colors together**

If you want the thread colors of the selected design to be together when will be sewed you have to check the checkbox. Otherwise keep it unchecked. This option when it is checked groups the duplicated objects with the same colors together in the sequence manager, to preserve that will be embroidered sequentially. Not all objects with the same color in the design but the same objects with the same colors of all duplicated designs/objects.

**Clone objects if possible**

With this option selected you can create clones of the selected object/design that can be reshaped all together by simply reshaping one of them. This option saves you time and it is a creative tool that can produce unique embroidery designs. Any shape transformation that you will make on any of the cloned objects/designs will be applied to all of them immediately. To change the shape of all objects you have to select any from the cloned objects, click on "Edit nodes" tool from "Modes" toolbar, to switch to node editing mode and reshape the object by click and dragging the node segments to the direction you want. To view the changes you made applied on all objects, you have to click back to "Edit objects" option of "Modes" toolbar.

**Divide**

With this option of "Stitches" menu you can split the stitches that are bigger than a specific length.

This option is enabled in "Object editor" mode and it works in "Stitch" data object. In case that you wish to split the stitches of one or more punching objects, you have to do it by applying styles or patterns on it.

In order to use the "Divide" option, first you have to select the object(s) you want and then click on the "Divide" option.

On the following dialog with the scroll bar you can specify the maximum length of the stitches.
All the stitches that are bigger than the length that you specify with this scroll bar will be split in more than one stitch.

With the following field you can specify the way that the stitches will be split. If the "equal pieces" field is enabled, every stitch of the selected object will be split in the needed pieces with equal length.

**Example 1:** In case that an object has a 5mm stitch, the "From length" field was set as 3.0 mm and the "Equal pieces" parameter is enabled, the stitch will be split in two pieces and their length will be 2.5mm.

That does not mean that all the stitches of the object, after the divide option is applied, will have the same length. This depends on the original length of the stitches.

**Example 2:** On the above mentioned example, if the next stitch is 5.2mm, this stitch will be split in two pieces and their length will be 2.6mm. As you can understand, in case of a satin bar, the length of the stitches that will be created after the divide option is applied, depends on the width of the satin bar.

If the "equal pieces" field is disabled, every stitch of the selected object will be split in the needed pieces but their length will not be equal. In this case the program will create so many stitches that their length will be equal to the maximum length and one stitch at the end that its length will be less than the value of the "From length" field.

**Example 3:** On the first given example, if the "Equal pieces" parameter is disabled, the stitch will be split again in two pieces but the length of the first stitch will be 3.0mm and the length of the second stitch will be 2.0mm.
Press the "OK" button to apply the changes you have made. If you want to discard the changes, press the "Cancel" button.

**Special functions toolbar**

The "special functions" toolbar is the second horizontal icon toolbar that is located on the top area of Wings’ modular main application window, when the software is loaded.

A "Special function" is a special command that will instruct the embroidery machine to perform a special action. On the top area of Wings’ modular application window, where all icons toolbars are, there is also the "Special Functions" toolbar. It consists of 2 parts, the first part contains the "Color manager icon" and all current thread colors and the second part contains all special commands as shown in the following figures.

The first part consists of:

<table>
<thead>
<tr>
<th><img src="image" alt="Color manager tool" /></th>
<th>Color manager tool, which can be used to manage all currently, used colors, to create new colors, or to select a Thread manufacturer palette.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><img src="image" alt="Color palette" /></th>
<th>The color palette shows the number of colors you have selected when you created a new design or through the color manager. By pressing on any color it is applied on any selected object(s) or is set as the current color for any newly created color. You can increase the number of visible colors on the toolbar, by adjusting the &quot;Maximum visible palette buttons “ value that you will find at Tools-&gt;Options&gt; Display tab. While digitizing you can also select and change the current color by pressing 1..9,0 in order to select the colors that exist in the first 10 needle carriers, or by pressing Shift+1..9,0 in order to select the colors that are on the needle carriers from 11 to 20.</th>
</tr>
</thead>
</table>

You can find more information about using the "Color manager" tool in section "Color management" of "Viewing your designs" chapter.

The second part consists of:

<table>
<thead>
<tr>
<th><img src="image" alt="Thread trim" /></th>
<th>Add a &quot;Thread trim&quot; special function, this function instructs the embroidery machine to make a pause, cut the thread and then start embroidering again.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th><img src="image" alt="Stop" /></th>
<th>Add a &quot;Stop&quot; special function, this function instructs the embroidery machine to Stop, there are things that can’t be done automatically by the embroidery machine, the machine makes a stop and waits</th>
</tr>
</thead>
</table>
until you press start.

<table>
<thead>
<tr>
<th>Special Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Needle up</td>
<td>Add a &quot;Needle up&quot; special function, this special command rises the needle carrier up. Usually this command is followed by another special function as a “Stop” or a “Frame out”.</td>
</tr>
<tr>
<td>Frame out</td>
<td>Add a &quot;Frame out&quot; special function, the frame comes a little out in order to have better access</td>
</tr>
<tr>
<td>Borer</td>
<td>Add a &quot;Borer&quot; special function, instructs the machine to use its borer</td>
</tr>
<tr>
<td>Sequin</td>
<td>Add a &quot;Sequin&quot; special function, for sequin mechanisms in order to place a sequin.</td>
</tr>
<tr>
<td>Appliqué</td>
<td>Add an &quot;Appliqué&quot; special function, this special function informs the embroidery machine that the embroidery process will pause and an appliqué will be manually placed on the fabric in order to add an appliqué</td>
</tr>
<tr>
<td>Low speed</td>
<td>Add a &quot;Low speed&quot; special function, this function instructs</td>
</tr>
<tr>
<td>Insert object split</td>
<td>Change borer depth, using the little arrow on left part of the control you can select the depth of the borer. The borer depth must be adjusted according to the fabric we are going to use and the types of borer that the embroidery machine supports.</td>
</tr>
<tr>
<td></td>
<td>Add an &quot;Insert object split&quot; special function, this special command break an object into 2 or more. It can only be applied on stitch data.</td>
</tr>
</tbody>
</table>

To apply any special function on an object (or on any stitch), follow the steps below:

1. Select one or more objects of the current design or stitches of the current object.
2. Click on the special function, which will be applied on the selected object(s) or on the selected stitches.

Any applied special function is performed at the beginning of the specified object, otherwise you can apply it using "Stitch editing" mode in one or more stitches of any object.

For most of the special functions when they are applied, you can see an icon on the left part of sequence manager, revealing that a special function has been applied.

**Sequin options**

In Wings’ modular® you have the ability to select the size, the shape and the color of sequins. In order to do that you have to right click with the mouse on the sequins thread color of the "special functions" toolbar and click on the "Sequin shape/size" function from the pop-up menu. The following dialog box appears:
In the dialog box you can select the shape and size you want the sequins to have, by clicking on the shape you want from the list. You can view the size of sequins in the "Sequin size (mm)" field or on the name of the selected sequin.

If you want to change the color of the sequins you can click on the "Set color..." button, select the color you want and click the "Ok" button to apply the changes.

You can select different color, size and shape for each Reel for machines that support double sequin chain head. The first reel includes all sequins that you can add in a single sequin mechanisms and the second reel includes the sequins that can be added as second sequins to double sequin mechanisms.

When you finish with the adjustments click "Ok" to apply the changes in the design.

**Edit step pattern**

Using this option on the "Stitches" menu, you can change a step pattern or convert a satin object to step. This option changes the step or the satin of the selected objects, or the entire design if no objects are selected.

This option can be active only in "Stitch data objects".
The parameters you have to specify in this option are:

- The **type of the step** that you want to use.
- The **length** of the step.
- Which part will be **calculated**.

**Preset steps**
By clicking on one of these buttons, you can select one of the existing step patterns.

![Preset Step Patterns](image)

"/3" step pattern  "Fish" step pattern  "Weave" step pattern

The pattern of step is visible on the preview window. The scroll bar above of the pre-made steps shows the way that the pattern was made. Moving the scroll bars you can change the stitches of the step.

The diamond on the right side of every scroll bar shows until, which scroll bar you want to use for the current pattern. By clicking on one of these diamonds the program will use the selected scroll bar and all of its previous. As you can see, these points are useful if you want to make your own step pattern or you want to edit an already existing step and add or remove lines.

**Preview**
In this area you can see the type of step that you have selected. Also in this area, you can see the changes that you may have made to the step by changing the scroll bars.

**Length**
By using the "Length" scroll bar you can choose the length where the effect (the pattern of the step you selected) will be repeated.

**Regenerate satin**
If you enable this option, the program will convert all the satin areas inside the selected objects to the step pattern that you have selected.

**Regenerate old step**
If you enable this option, the program will re-calculate the existing step areas inside the selected objects to the step pattern you have selected.
**Constant - width satin**

If you have a satin with all stitches having the same direction, you should not mark this option.

Otherwise, if the satin is changing directions and has more or less the same width, then you have to enable this option so that the shape you are creating follows the shape of the satin. In case of a **punching step object** (more info in Appendix A) you can use the "Complex pattern" option of "Tools" menu and the "Convert step to satin" of "Stitches" menu.

### Design Start/End point

With this option from the "Edit" menu you can change the start and end point of the current design.

The Start point is the crossing point of the two dot lines and the End point it is marked with the icon.

In the sub-menu you can choose one of the following options:

- **Move design start**
- **Move design end**
- **Return to design start**
- **Move design Start & End**

#### Move design start

Using this option you can set the start of the design.

When this option is selected the program shows the current design in a rectangle made by red dotted lines and the cursor becomes as a cross. Also there are one vertical and one horizontal dot lines showing the center of the design.

To set the start point to the position you want, just click on this position.

#### Move design end

Using this option you can set the end of the design.

When this option is selected the program shows the current design in a rectangle made by red dot lines and the cursor becomes as a cross. Also there are one vertical and one horizontal dot lines showing the center of the design.

To set the end point to the position you want, just click on this position.

#### Return to design start
Using this option a new object will be added at the end of the design that will make the needle carrier return to the starting position of the design. To this object the "Needle up" special function will be also applied, which will park the needle in order to be safe during the movement of the needle carrier.

**Move design Start & End**

Using this function of menu "Edit" ➔ "Design Start/End" you can replace the design "Start" and "End" together at the same time. You can also access this function by pressing X button on your keyboard.

The cursor becomes a cross prompting you to specify first the "Start" point. As soon as you specify this point the center of the horizontal and vertical axis is moved to the specified point. After that the cursor remains a cross prompting you to specify the "End" of the design.

---

**Presets**

Each stitch type has many parameters that can take many different values. Setting and remembering the optimal values of each stitch type is difficult for everyday usage. For this reason Wings’ modular® has the ability to create presets for each stitch type that can be loaded instantly saving you time adjusting the parameters from the start. You can do that by adjusting the parameters of a stitch type and then right clicking on the "Object Properties" toolbar in the "Options" tab and from the popup menu selecting the "Add Preset" option. In the dialog box that will appear, just name the preset and click "Ok".

Now you can use the preset by right clicking on the Object Properties rollup and from the popup menu select "Presets" or by clicking the preset name, shown at the end of the popup menu.
Moreover in **Punching mode**, you can select the preset you want by pressing 'E' key or the asterisk ‘*’ key (from the numeric keyboard) and in the following dialog select the preset with single click or by typing the number of the preset you wish to use. You can also use a double click on the desired preset to automatically apply the preset and close the dialog.

Remember that each stitch type has its own presets. You can make as many presets as you wish. The presets are saved in the design you are currently working. If you want the presets you have created to be available in any design, you have to create a Template that will contain all the presets in. Therefore every time you are creating a new design using this template, all the presets will be available to the new design.

Also the presets can be merged in any design from the menu "File>Merge…"

### Reset object properties

While digitizing you may change the properties of a stitch type. The next object that you will create will be created based on the changed object properties. In case that you like an object to have the default stitch properties you can use "Alt+R" keyboard shortcut.

This can happen in 2 ways

- Select an already created object and by pressing "Alt+R" the object properties of the selected object are reseted to default.
- Before you digitize an object press "Alt+R" any changes properties on the selected stitch type will be reset and when you start digitizing the created object will have the default properties.
Chapter 6 - Stitch editor

Introduction

In the "stitch editor" mode you can see the stitches of the current design. You can make as many adjustments as you want on the stitches and create the embroidery design that will be embroidered exactly in the way you want. In addition you will learn how to select, move, add, remove or divide stitches and any combination exists that can make your life easier.

View direction of stitches

In the "Stitch editor" mode that you can activate by clicking on the "Edit stitches" tool at the modes toolbar, you have the ability to view the direction of stitches of you embroidery design. In order to do that you have to "Zoom in" a lot (depends on the design) until the stitches become clearer.

![Figure 6.1 Direction of stitches](image)

You can see the direction of stitches relative to the active stitch. Once you have selected a stitch Wings' modular reveals the direction of stitches by these small arrows that appear next to the stitches. These arrows appear only on the stitches that are next to the one that is selected. A few stitches before and a few after are showing the direction of the stitches.

In case you have enabled the "Show stitch marks" option you can also see the small circles that show the needle penetration points.

This option can be really useful when you want to make specific adjustments on specific stitches in the design and you need to know the stitch direction.

Selections in stitch editor

There are many ways to make selections in the stitch editor. You can make multiple selections or single stitch selections by creating a rectangle selection...
or by single clicking on the specific stitch you want to move. The selection abilities you have are listed here:

**Rectangle selection**

If you want to select more than one stitches you can do it by drawing a rectangle that will contain all the stitches you want to select. In order to do that you have to click on the "Edit stitches" tool at the "modes" toolbar, click and drag on the working area to draw a rectangle over the stitches you want to select and release the mouse click to confirm your selection. After making the selections you can move them by clicking and dragging on any of the selected stitches or make any other transformation you want.

There are, also, special rectangle selections that you can do by using "Ctrl", "Shift" or "Alt" keys.

If you have already made a rectangle selection you can hold the "Shift" key and add more stitches to the current selection by creating a new rectangle selection that will contain the stitches you want to add.
By holding down the "Ctrl" key you can invert the current status of the selected stitches.

For example if you have made a rectangle selection and you want to invert the status (from selected to unselected and vice versa) of some of the selected, you can create a rectangle selection over the stitches you want to change, by clicking and dragging, and immediately you will see that the stitches are inverted. This ability can help you create specific and multiple selections from different parts of the design, therefore more stitch editing power.

Finally, if you have already made a rectangle selection you can hold the "Alt" key and remove stitches from the current selection by creating a new rectangle selection that will contain the stitches you want to remove.
All the stitches inside the rectangle selection will be immediately deselected leaving the remaining as it was.

**Single click selections**

If you want to make specific stitch selections you can simply click on the stitch you want to select and will become selected. The selected point is the same with the needle penetration point that the embroidery machine will make on the fabric.

There are also special "single click selections" that you can do by using the "Ctrl", "Shift" or "Alt" keys.

If you select a stitch point and then by holding down the "Shift" key, select another one, all the stitches between those two points will be selected. In this case the "Shift" key works like a stitch point addition tool.

The other special selection tool is activated by holding down the "Ctrl" key. The "Ctrl" key works like an inversion tool of the current status of the selected point. For example, if you hold the "Ctrl" key down and make stitch point selections you will end up with multiple stitch selections of single stitch points. If you continue holding the "Ctrl" key, by clicking on an already selected stitch point, you can instantly remove it from your current selection. Therefore by using the "Ctrl" key you can add or remove stitch points to your current selection by changing each time the status of a stitch point.
Finally, if you want you can remove specific stitch points from a current selection by using the "Alt" key. You can do that by holding down the "Alt" key and clicking on any stitch point you want to remove.

All the previously selected stitch points will be instantly become unselected.

**Move stitches**

If you want to move one stitch or multiple stitches, first you have to click on the "Edit stitches" tool from the modes toolbar to activate the stitch editor. Then, you have to click and drag the selected stitches and move them to a new position. By using the selection techniques we described above you can make complicated stitch movements that give you powerful stitch editing abilities.

Also you can go to the exact stitch you want, by using the arrows of the keyboard or with the tape buttons of the horizontal toolbar. When you find the stitch you want to move you can click and drag it to its new position.

There are also special stitch movements that we will describe below.

**Snap movements**
A really useful stitch movement that you can make is the snap movement. This movement of stitches can be activated by holding down the "Ctrl" key and click and dragging the selected stitch points.

This line snaps on specific angles and help you to make accurate movements along the direction of the angle you want. The angles that the red line snaps are: 0°, 45°, 90°, 135°, 180°, 225°, 270° and 315°.

**All directions movement**

Another useful way to move stitches is by moving the selected stitch points to all directions proportionally based on the virtual center of the selection. In order to do that you have to select the stitch points you want and by holding down the "Alt" key click and drag to the direction you want all the selected stitches to be moved.
If you try to move the stitch points you will see that they have a flexible movement in all directions that can help you easily reposition the stitch points on the design.

**Add stitches**

Using this tool you can add stitches to the current design. This function can be used only when you are in "stitch mode".

First click on the stitch where you want to add stitches and press the "Insert" key from the keyboard or the "Insert" option of the right click menu. Each subsequent click adds a stitch after your initial location and before the stitch you have selected.

After finishing with the insertion of stitches you can simply right click with the mouse and the function will end.

If you want to add stitches at the end of the current object, you can press the "Num +" key of the keyboard or select the "Insert at end" function from the right click menu, following the same procedure we described previously.

**Delete stitches**

In order to delete stitches, first you have to select the stitches that you want to delete, by using the selection options we described, and then press the "Delete" key from the keyboard or select the "Delete" option from the right click menu. This action will remove the selected stitches from the design and will recalculate the rest to fit in the changes.

**Replace stitches**

Follow the steps below in order to replace a number of existing stitches with new ones.

You have the ability to replace a single stitch point or multiple selection of stitch points. If you want to replace a single stitch point you have to select it, select the "Replace" option of "Stitches" menu or the "Replace" option from the right click menu and position the stitch point to a new position.
Select Stitches
Left click to replace the first one
Right click and replace all the rest

On the other hand if you want to replace a multiple selection of stitch points you have to again select the "Replace" option of "Stitches" menu or the "Replace" option from the right click menu and start replacing the stitches to each new positions. In addition, if you replace the first stitch of a multiple stitch’s selection and then you right click with the mouse; all the remaining stitches will be moved respectively to a new position according the movement of the first stitch.

Now, if you want to apply "Replace" stitches function like the previous versions of Wings’ modular®, you have to select the stitches you want to replace and then apply the "Replace" stitches function.

If you want to replace stitches without affecting the underlay you have to select the first stitch of the outline and then "Shift" select the last stitch of the outline you want to replace and then apply the "Replace" function. The "Shift" key allows you to select all the stitches between two selected stitch points in the stitch flow, without affecting the underlay. Therefore, by using "shift" selection procedure and the "Replace" function of "Stitches" menu you can simulate the multiple replacement of stitches of previous versions.

**Remove small**

With this option from the "Stitches" menu, you can remove the small stitches which can cause thread breaks from the current design.

Please note that "Borer" objects will not be removed by using this function.

The parameters you have to set for this option are:

- **Lower range** at which you think that the stitches are too small.
- **Upper range** at which you think that the stitches are too small.
- If you want to **remove all** the small stitches.

### Small stitches from (mm)
Using the track bar below, you can specify the lower range at which you think that the stitch is too small (in millimeters). Most of the time this option will be 0.0 millimeters.

### To (mm)
Using the track bar below, you can specify the upper range at which you think the stitch is too small. Most of the time this option will be 0.8 millimeters.

### All small stitches
If this option is enabled, the program will remove all small stitches.

**Attention:** You must be aware when using this option that if that you have small stitches in a row multiple (three for example), the design may be distorted.

The small stitches of the current design can be viewed also on the "Histogram" of "Design Info..." dialog.

---

### Move outline

Follow the steps below in order to move a number of stitches to another position following user mouse input:

1. Select the outline stitch points you want to move by holding the "Ctrl" key.
2. Click on "Move outline" option from "Stitches" menu or the same option from the right click menu.
3. In the following dialog you have to specify the type of the object that the selected stitches belong (running, satin, step) and click "Ok".
4. Each subsequent click moves one stitch after the other from the initial location to a new location.
5. Clicking the Right mouse button ends the function by moving the rest of the selected stitches according the latest moved stitch.

Another way to move the selected stitches of the outline is by clicking and dragging them in their new position.

**Note:** In case that you have selected running stitch type, you can move all stitches between the initial and the end location.
Chapter 7 - Node editor

Introduction

In this chapter we will analyze all the node editing abilities that Wings’ modular® has. You will learn how to select, move, add, delete and split the nodes of an embroidery design. In addition, you will learn all the terminology that will help you to understand node editing better and how to use the functions of the node editor’s right click menu.

What is a node

There are two kinds of nodes. The smooth nodes which are indicated with ○ characters and the cusp nodes which are shown with the □ characters. During punching all nodes that you are adding are smooth nodes. If you want to add a cusp you should hold the "Shift" key from the keyboard while clicking on the point that you want. If you have placed a smooth node, you can convert it to a cusp node using the node editor, which can be viewed by clicking the right mouse button over the node you wish to convert.

A node is the point indicated with the arrow in the drawing on the left.

A curve can be controlled by the tangent, which is indicated with the arrows in the drawing on the left.

What is a direction

The direction always indicates the way that the stitches will be sewn. The most important information is that you don’t have to add nodes on satin or Zig-Zag to show the direction. The direction indicator is separate from the nodes.
This allows one part of a design to have directions in one orientation and another part with a different direction.

### Edit punching nodes

During punching you can edit the nodes that you have punched. First you have to click on the "Node Edit" icon, which is on the vertical toolbar (modes) and that will enter you in node editing mode. The current design changes to outlines and you can see the punching nodes of the selected object.

At this point we must mention that during node editing we can hide stitches in order view only outline data. This way we can see clearly the shape that we are editing. In order to do that, we must press S key. It is like a toggle key if we press it once more stitches appear again.

The changes that you can make are:

- **Select node(s)**
- **Move node(s)**
- **Change the tangents of a node**
- **Delete node(s)**
- **Insert a node**

Additional functions are available by selecting one or more nodes and clicking the right mouse button. This calls the menu of the node editor.

If you click on a curve, the circle point appears on it. By clicking the right mouse button on this point you can call the curve editor menu.

### Select Node(s)

If you want to select one of the punching nodes, place your mouse over the node and it becomes bigger indicating that it has focus. Left click on the node and it gets selected and the color of the node gets darker while it is selected.

### Move node(s)

If you have punched a curve and you want to move a node, you should click on it and drag the mouse to the point that creates the desired shape.
Also if you want to move a node 1/10 of millimeter towards a specific direction, you have to press the arrow showing this direction.

For movements of 1 millimeter to a specific direction you can hold down the "Ctrl" key from the keyboard and then click the arrow to the direction you want the nodes to be moved.

**Change the tangents of a node**

If you want to change a curve you can move, insert or delete one or more nodes. You can also edit a curve using the tangents of a node. This can be done by clicking on the control point of the tangent, and dragging it in the direction that you want. By changing the direction and the length of the tangent, the curve will change also. For example:

Normal Curve

By changing the length of the tangent.

By changing the direction of the tangent.

Also the tangents of a curve can be changed by clicking on this curve and drug it on another point, as you can see in the following draw.

The arrow shows the movement of the temporary node.
The red line shows the curve prior to the movement and the magenta line indicates its shape after the changes.

**Delete a node**

If you don’t need a node you can delete it. First select the node that you want to delete and then click the "Delete" key on your keyboard. You can also click the right mouse button over one of the selected node(s) and choose the "Delete node" option of the node editing menu. Finally you can delete a node by double clicking on it.

**Attention:** If you delete a node of a curve, the shape of the object it may change.

**Insert a node**

As you can see with the smooth node tangents, curves become very flexible. Many times you will need to insert an additional node inside a curve. To create a new node, click on the point where you wish to insert it. The \( \circ \) character will appear on the curve. If this is not the exact point that you wanted to insert it, you can click on another point of the curve. By pressing the "Insert" key on the keyboard a new node is inserted in the position you have defined. The new inserted node can be edited as an existing node.

You may also insert a node by selecting a node point and using the "Insert node" option of the node editing right click menu. The new node will be added between the selected node and the one next to it.

You can also call this same option from the curve editor menu. The same can be done by selecting more than one nodes. Select as many nodes as you like, use Insert node option (or Insert key), a node will be added into the curve following each selected node. The inserted nodes are placed always in the middle of the curve.

**Punching nodes editor menu**

This menu is shown when you have selected nodes and then clicked the right mouse button. The options that appear are the following:

- **Smooth node**
- **Cusp node**
- **To lines**
- **Insert Nodes**
- **Delete nodes**
- **Fit to curve**
- Add direction

**Smooth node**

During punching all nodes that you are adding are smooth nodes 🔄. That means that the curve that you are creating is smooth. While changing the tangents of a smooth node, the curve changes from both sides of the node, as you can see in the following figure 6.3.

With the red line you can see how the curve was before to be changed and with the pink line, how the curve will be after the changes.

If you don’t want this movement, you can use a cusp node or change the current node to a cusp node by using the nodes editor right click menu.

**Cusp node**

These nodes can be used if you want to create a corner in an outline 🛋. To create a cusp node during punching, you hold the "Shift" key on the keyboard while adding the nodes of the curve. The difference with the smooth node is that you can change the tangents of one side of the curve without the other part being changed.

The nodes indicated with the arrows are cusp nodes.

We changed the tangent of the node indicated by the arrow. The right side of the curve of the node changed but not the left.

In the drawing with the black color, you can see the curve as it was. The blue color version shows the result after the operation.
If you want to change the current node to a "smooth node" you can use the nodes editor menu.

**To lines**

If you have a curve and you want two nodes to be connected with a straight line, you can use the option "To lines" of the node editing menu. First you have to select the node, which will start the line. This is the node that you can see in the following drawing indicated with the arrow. Clicking the right mouse button presents the node editor menu and you can choose the option "To line". This can also be done if you have selected more than one node.

The black line shows the curve as it was before.
The blue line shows the result of the "To Lines" conversion.
The arrow points to the node at which you should call the node editor menu and the "To line" option.

This option changes the type of the selected node and their next node to cusp. This change cannot be cancelled by the "Fit curve" option. In this case you should use the "Curve" option.

**Fit to curve**

This function allows many changes on a curve without adding unnecessary nodes. There will be many times that the results will not be what you expected and you can't restore the curve. In this case you need to use the "Fit curve" option which restores the selected smooth nodes to its original shape without affecting the entire shape.

**Attention:** If you have transformed nodes using the "Curve", "Cusp" or "To lines" option, the conversions are not cancelled. If this is the case you should reset all of the nodes to their original positions.

**Add direction**

This option is enabled only if the object that you are creating is a satin or Zig-Zag object. With this function you can add (insert) a new direction for the object without needing to punch it again or add nodes.
First you click on this option and the cursor becomes a cross. After that you have to add pairs of nodes which show the directions that you want to add.

If you want to stop adding directions, you have to press the right mouse button.

## Chapter 8 - Venere cutting system

### Introduction

Using venere cutting system you can make Venere cuts in the fabric. You can design the area you want to be cut with “Venere cutting” like creating an outline with Running stitch. Your embroidery machine will process the information and will cut the area you have design accordingly.

The Venere tool increases embroidery quality by creating accurate cuts in the fabric with the best possible way. Using this tool you can create unique designs combining embroidery with fabric cuts.

In the following sections we will analyze the features or “Venere” module and explain how can be applied in any design. All the features from “Basic” module will be omitted in order to be clearer the extra features of “Venere” module.

### Venere cutting system

The cutting needle VENERE is a new revolutionary system in the embroidery industry, which allows every cut, namely every incision to be made directly on the embroidery machine.

The installation of four needles on a machine, as show in the picture, permits every kind of cut. The system consists of 4 cutting needles, which replace the regular embroidery needles. They are installed at an angle of 45° to each other (0° - 45° - 90° - 135°). Simple forms such as rectangles, rhombi, squares, etc. requires only two needles for cutting. However, with all four
needles, every kind of complex forms can be archived. The use of these does not require any change in the machine. The only need is to switch off the "thread break" sensor.

To achieve this function, a running stitch which runs parallel to the embroidery must be inserted in the existing design. Its stitch length should not exceed 1mm. The cutting needle has width of 1,2mm. The cutting can be programmed independently, either before or after the embroidery. This novelty enables the embroidery companies to create special artwork in different branches with a higher quality, shorter production time and lower costs.

**Apply Venere cutting system**

In order to create Venere cuts you have to create the shapes that you want to be cut in the design area. Especially for this reason we have created a tool that can be used to create Venere cuts. It works like the digitizing tool but instead of placing stitches, specifies the area where the Venere needles will cut the fabric.

You can activate the "Digitize Venere cutting" tool from the "Tools" menu. When this option is active the cursor becomes as a crosshair and you can start punching the outline you wish to cut.

In order to create an outline you have to specify its nodes. The way of adding nodes is similar to Running stitch type punching way. By left clicking with the mouse you are inserting nodes that will create the outline of the area you want to cut. If you hold the "Shift" key while left clicking the nodes will become curve brakes. If you have made a mistake while entering nodes you can delete the last inserted node by clicking the "Backspace". After that you can continue entering nodes normally. In addition you can insert a shape that will specify the area where Venere cut will be made. In order to insert a shape you have to activate the "Digitize Venere cutting" tool and before start digitizing click the 'S' letter from the keyboard. The "Insert shape" dialog box will appear.
from which you can select the shape you want to enter in the design. The area that the shape will cover will be cut with Venere.

The punched outline or the shape is the first object that you are creating. In order to continue creating a new Venere cut outline you have to right click once. The cursor remains as a cross waiting from you to enter the next outline (auto-branching). When you finish entering Venere cut outlines or shapes right click once more.

The program asks for the exit point of the object that you have just punched. With click on the position you wish you can place the exit point on this specific position. In case that you would like the exit point to be placed on the best possible position, just press the right button of the mouse again. Even if you have created open shapes, the Venere tool automatically closes them by cutting also the straight line between the first and the last inserted node.

Venere cutting tool automatically recognizes the created outlines that needed to be cut and decides the best possible way that have to be cut by using the correct combination of the four cutting needles.

We can also convert any created shape into venere by using the available option of right click menu, Change to ->Venere. This option converts the the outline of any created object into a venere object. Venere cutting tool will automatically recognize the outline of the object and instead of stitches it will apply cuts using the functionality of venere cutting tool.

**Venere cutting printout**

The printout of a Venere cut design is important to the embroidery process. In the printout, except of the standard information, you can find also, information about, which "Venere Knife" must be placed in which needle currier in order "Venere cutting" function to work properly. Depending on when you want the cuts to be made (before or after the embroidery) you can change the cutting order by changing the sequence of embroidery process.

For avoiding mistakes while placing the "Venere Knifes" follow the guidelines.
- Knife — = Place 0° knife in the specified needle currier
- Knife / = Place 45° knife in the specified needle currier
- Knife | = Place 90° knife in the specified needle currier
- Knife \ = Place 135° knife in the specified needle currier

**Venere cut Running options**

In the “Apply Venere cutting system” section we have mentioned that Venere is applied on the design like the Running stitch type without entering any running stitches in the design.

Venere cut also keeps the parameters of Running stitch type. Therefore you have the ability to adjust specific parameters in the “Running” “Option” of the “Object properties” toolbar that will be instantly applied to the Venere cut object.

The parameters that you can change in Venere cut shapes are:

- The **length** of the stitches.
- If there would be **fix and lock** stitches at the start/end of the objects.
- The **offset** of stitches according to the punching curve.

**Length**

With this numeric field you can specify the length of the stitches for the punching object that you are adding. Venere needle constructors propose to be near to 1 mm.

**Fix & Lock stitches**

With this parameter you can specify whether the program will lock the stitches at the start or end of the selected objects. The lock stitches are small stitches that keep the thread from unraveling off the fabric which is important while cutting a piece of fabric. If you want to change this option you should click on this field and on the following menu select one of the available options:

<table>
<thead>
<tr>
<th>None</th>
<th>In this case there will be no lock stitches at the start or end of the selected objects.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fix</td>
<td>In this case the lock stitches will be placed at the beginning of the selected objects.</td>
</tr>
<tr>
<td>Lock</td>
<td>In this case these stitches will be placed at the end of the selected objects.</td>
</tr>
</tbody>
</table>
Fix&Lock

In this case these stitches will be placed at both the beginning and the end of the selected objects.

**Offset**

With this numeric field you can specify the distance between punched curve and the position of the stitches in millimeters.

**Figure 8.4**

Offset

Without offset  
With offset
Introduction

In this chapter we will analyze the adjustments that can be done in the options of Wings’ modular® software, in order to fit our preferences. The adjustments that can be done are separated in the following sections that will be described thoroughly in this chapter.

- Display properties
- Printing preferences
- General features.
- 3D properties
- Program levels
- Design tools color scheme
- Optimizer

Tools ➔ Options

There are several adjustments that can be made in Wings’ modular®. Most of them are in the "Options" dialog box which can be opened from the menu "Tools ➔ Options". In this dialog box you can adjust several properties that are located in each menu tab. The available tabs and the properties that affect will be described each one separately. The available categories (Tabs) are:

- Display
- General
- 3D properties
- Printing
- Colors
- Key
- Workspace

Display

In the display tab you can adjust options that are correlated with the display mode of the program.
Monitor width: In this area you can define the actual width of your monitor. This is important if you want to view your digitized designs in their actual size when 100% zoom selection is clicked. In order to find your monitor’s width you can measure the visible area with a ruler. The result of your measurement must be entered in the text field “Visible area” at the right metric format. Another way to define your monitor’s width is by knowing the size of your monitor in inches, and simply clicking on the respective “monitor preset” size button. The program will automatically set your monitor’s width. In order to activate your changes you have to click “Ok” at the “Options” dialog box. By pressing “Auto detect” Wings’ modular automatically detects the actual size of your screen.

The next time you will select to view your embroidery design in 100% zoom, the size of your design will be the actual one.

Viewing options:

Enable Automatic panning: With this option checked you can set if the pan option will be enabled or not. In case that this field is enabled, with “Ctrl + right click” you can change the view port of the screen, a Hand like handle appears, click on any point of the design area and drag the design.
area towards the direction you like. Just like that you change the viewable part of the design area. Right click once again to release the "Pan" handle.

**Show design during move, rotate etc. operations:** When this tool is active you can view the designs while they transformed (moved, rotated, slanted, etc). This option needs the software to be restarted in order to take effect.

**Show translucent selection rectangle:** When this option is checked every time you are creating a selection rectangle area with the mouse, a translucent rectangle is drawn. You can select the color of this translucent rectangle using Colors tab. You can find more information about the color selection later on this chapter in the section about Colors tab. If you disable this option, only the outline of the rectangle will be visible. Wings’ modular® must be restarted in order the option change to take effect.

**Show dimension tool tip:** When this option is checked the dimension tool tip appears next to cursor while digitizing or while making rectangle selections with mouse.

**Zoom- all border area:** This field specifies the width of the border (counted in pixels) of the selected area. The same parameter is enabling in Zoom all function. Therefore you can easily select even the objects that are in the edge of the screen.

**Up to cursor pts:** This numeric value adjusts the number stitches before and after the current stitch that will be marked with an arrow showing the direction of stitches (stitch editing mode). By adjusting this value you can increase-decrease this value in order to fit your viewing preference.

**Maximum visible palette icons:** Using this option we can adjust the number of visible palette colors (Needle carriers). This option is very useful in cases that your embroidery machine supports more than 20 colors and you want to create and embroider design with more than 20 colors up to 99. The default value is 20.

- **Language:** From this drop down menu you can specify the language of the software. Wings’ modular® must be restarted in order the option change to take effect

- **Outline quality:** Using this track bar select a level of outline quality. The best outline quality is "Precise" but requires more system resources and you can lower quality in order to have less accurate but faster results.

**Printing**

This tab shows the general parameters of the printing function.
You have the ability to adjust the following options.

- **Printout fonts**: These two fields specify the fonts that will be used in the printouts. You can select any font from the already installed fonts in the computer. The True Type fonts can be used for Dot-matrix, Laser and inkjet printers. The Vector fonts can be used for plotters.

- **Size of text**: This field specifies the size of the letters that the printouts will have counted in Pts.

- **Printout parameters**:
  
  * **Design bitmap DPI**: This field specifies the DPI that will be used in the printouts. Design bitmap DPI should be around half the printer's DPI. Bigger number generates finer lines with less accurate colors and uses more memory. For example, on a printer with 360 dpi, you can put it from 120 to 180 dpi. There is no need to set this number above 254 dpi.
**Company name:** This field specifies the contents of the company name field on the printout. In this field you can write the name of your company.

**Auto-fit design when displaying print preview:** This field specifies the way that every design will be displayed in print preview. If the Auto-fit option is enabled the program will use as many as possible pages in order to show the design in actual size (scale 100%). If the Auto-fit option is disabled and the design is bigger than the default page size of your printer, the program will show the design shrunk, in order to fit in one page. On the right bottom corner of the printout, you can view the percentage of the shrunk.

### General

This tab shows other parameters, beyond the categories mentioned above.

- **3.5” embroidery floppy disk is:** The following radio-button control specifies which floppy disk drive is 3.5” and can accept floppy disks (A:, B: or None). This control is very important in case that you would like to read or write a design on a disk.

- **Other options:** In this field set you can specify the following:

  **Ask start of block when digitizing:** When this option is enabled Wings’ modular® always prompts you to define the starting point of the block that you are currently digitizing.
**Count stitches assuming 4mm max:** This checkbox specifies the way that the stitches of the current design will be counted. When it is Checked, all the stitches will be counted in such a way that the maximum length will be 4 mm. For example, a 9mm stitch counts as 3 stitches (2X4 mm and 1X1 mm). If this parameter is a 9 mm stitch counts as 1 stitch (1X9 mm).

**Loaded designs are always maximized:** This checkbox specifies the way that every design will appear when it is loaded. If this parameter is enabled all the designs will be loaded maximized, if not all the designs will be loaded cascaded.

**Icon browser selection method without using CTRL key:** This checkbox specifies the way of multi selection in "Browser" window. If this option is disabled, in order to select more than one designs in "Browser" you have to keep pressed the Control (CTRL) button of the keyboard. If this option is enabled, in order to select more than one designs in Browser, just click on the design you want.

**Show object shadows:** This checkbox specifies if the "Show filled outlines" option will be enabled or disabled every time that Wings' modular® starts. This option shows the outline of the design that you are digitizing behind the stitches. If you disable it no outline will appear behind the digitized objects.

- **Default 3D preview fabric:**

  **Change fabric:** This option specifies the default fabric that that Wings' modular® will use to preview the design on. When 3D preview from View menu is activated you can have a realistic preview of the design on a fabric. If you haven’t already set one fabric for your design the default will be used. By pressing "Change fabric" button the Fabric window will appear. Select a Fabric from one of available categories. When you change the fabric from this option, it will become automatically the default fabric that will be used from the software every time that the software will start.

- **Undo levels:** This field specifies how many times you can roll back an action in the design. You can increase or decrease it using the arrows next to the field or by entering directly the value in the field. Too high "undo level" value means more memory usage and the opposite.

  **Auto backup:** In the same location there is another field where you can specify the auto backup occurrence. You can set the "Auto backup"
mechanism to occur after every change you are making on the design or more. The only thing you have to do is to change the "Auto backup" value.

- **Measurement system**

  You can change the "Measurement" system of the program from "Metric" (mm) to "U.S." (inches) and vice versa. Wings’ modular® has metric as the default measurement system, but in this part of General tab of Wings’ modular® options you can change it into US(Inches). This is important for those who want to view the sizes in their local measurement system.

### 3D properties

In the "3D properties" tab you can adjust the 3D preview of your design. You can define "3D acceleration Driver", 3D graphics parameters and 3D graphics quality.

The options of this tab are very technical. The best way to adjust your 3D graphics is from the three preset buttons in the "Quality functions" section. You can choose between three 3D quality options: "Fast", "Quality" and "Safe".

- If you click the "Fast" button, your 3D quality will be set automatically to minimum. This means that you lose 3D quality but gain in program’s speed.

- If you click the "Quality" button, your 3D quality will be set automatically to maximum. This means that you gain in 3D quality but lose in program’s speed.

- If you click the "Safe" button, your 3D quality will be set automatically in the most reliable way. This means that you lose 3D quality but gain in program’s speed and reduce compatibility problems with your graphics card.
Make your selection and click "Ok" to confirm your changes. The changes will be applied the next time that the program will start. By default Wings' modular starts with Fast option enabled. If you select any preset that causes Wings' modular not to work properly you must set graphic properties to a lower level.

**Key**

In this tab you can enable or disable levels in Wings' modular®.
- **Requested level / options:** In this field-set you can view all the modes/levels that are available in Wings' modular®. You can enable or disable each mode/level you have bought by selecting the one you have form the "Program level" jump menu. Also you can "Enable all" or "Disable all" options by clicking the respective button.

  If you change the level without updating the software, the new level will not take effect.

- **Update to new level:** In the lower section of the key tab are located the functions that can be used to change the levels of Wings' modular®.

  **Old parts:** In this field is located the current serial code of the program.

  **New parts:** In this field must be entered the code that will activate a new level of Wings' modular®. This code is provided from your supplier when you purchase a different level of the software.

  **Key form:** The "KeyForm" button is creating a web based report with the current state of the program. When you will need to change the level of the software you will be asked to send a "KeyForm" to your supplier.
**Update:** This button works together with the "New parts" field. If you buy a new level, your supplier will give you a new update code to activate it. The code must be placed in the "New parts" field and the "Update" button must be clicked afterwards. The level will be activated when you restart Wings’ modular®.

**Note:** keep in mind that when you update a level the respective level in the "Requested level / options" must be checked in order the new level to work.

**Colors (Design tools color scheme)**

The design area of Wings’ modular® is the heart of the application. All embroidery miracles take place here. Inside this area, there are various visual assistance tools, guidelines, grids, highlight rectangles, selections outlines. All these tools use a color to help you recognize the object you want to focus on and make more accurate editing.

These tools exist to help you focus on your task. For many users it is very useful to be able to modify the colors that these marks use, because they can recognize them easier. In order to be able to personalize these visual assistance marks and make them match your personal preferences we have created a color customization window.

Generally you can adjust many options of the application by selecting from the "Tools" menu, "Options" submenu item. From "Options" dialog select "Colors" tab. In this tab you can customize the color schemes of editing tools.
On the left side of the tab there is a list "Display items", containing the items that is possible to change their color scheme. By selecting each item on the list you can see on the right side of the dialog the colors that are currently set for the selected tool. As you have noticed there are 2 colors selected. The one is for dark background and the other for light. Wings’ modular automatically enables, according to the selected background, the color that is selected for the tool based on the luminosity of the background. Let’s take a closer look at the tools that can be customized and the available ways to select and customize their color.

**SELECTED OUTLINE (OBJECT EDITING MODE)**

When selecting an object (Object editor), in order to be easier to recognize the selected object it gets a light green outline. When the background is light the color is dark green and when the background is dark the color is light green. You can select another color for the outline of the selected object by selecting from "Display items" the "Selected outline" option and then use "Color" drop down menu to select a color for dark and light backgrounds.
In node editing mode the selected object has a magenta outline which also connects the nodes of the shape. You can change the color of this outline by selecting "Node editor selected outline" item from "Display items" and then the already selected colors for the item will appear on the right side. Click on the arrow on the right side of the selected color in order to select a new color from the color tool.

When an object is selected a highlight rectangle appears around it. This rectangle has some controls that can be used to transform the object. You can change the color of this Transformation rectangle in order to match your personal preferences. Select "Transformation" rectangle from "Display items". Now on the right side of the dialog the colors of the "Transformation rectangle" for dark and light backgrounds have appeared. Selected the arrow that is located on the right side of each color in order to select another color.
**TOGGLE GRID (DARK-LIGHT)**

With this option from the "View" menu or by using 'G' shortcut key from the keyboard, you can display grid lines on the working area to allow accurate positioning of the design. Select "Grid" item from "Display items", the used colors for the grid will appear on the right part of the dialog. Use the small arrow next to each color in order to change the color.

**GUIDELINES**

Professional designers use guidelines in order to have more accurate results. In Wings' modular software, there are 3 types of guidelines. All the guidelines can be seen with a colored dotted line and in any activity the cursor snaps on them.

Guidelines can have different status: **Normal**, **Locked** and **Temporary**.

**Normal guidelines** are all the guidelines we can import into the design area. These guidelines can be moved and changed any time.
Locked guidelines any guideline can be locked in order to avoid moving it by mistake.

Temporary guidelines are produced by the software automatically during various designing tasks, for example when moving Design Start-End.

Every type of guideline uses a different color. You can change the colors of guidelines by selecting the respective status from "Display items" and then changing the color from "Color" drop down menus.

**SELECTION RECTANGLE (OBJECT EDITING)**

When using your mouse to make a selection a highlight rectangle appears highlighting the selected area. This highlight rectangle is by default white for dark backgrounds and black for light backgrounds. You can change these colors by selecting "Selection rect" item from "Display items" and then use "Color" drop down menu to select a color.
When adding an envelope, a grid is automatically created on top of the object. When using node editing mode this grid also reveals the nodes of the grid. By editing these nodes you can create various artistic effects. You can adjust the color of the grid lines (Node editing mode) by selecting "Patch grid" from "Display items" list and then selecting any color you like from available colors that you will find under the "Color" drop down menu. This color will be applied immediately on all envelope grids.
CROSSHAIR (DARK-LIGHT)

Using this option in "View" menu, a cross follows the mouse when it is on the design and helps you align and position design items. You can also initiate the crosshair display by pressing the letter "C" from the keyboard while you are working with the design. By adjusting Crosshair color you select a color that this Cross will have. You can adjust the color that this cross will have on dark or in light background-fabric color.

You can change the color of the Crosshair by selecting "Crosshair" from "Display items" list and then selecting any color you like from the available colors that you will find under the "Color" drop down menu. The selected colors will be applied immediately on the Crosshair tool.

SELECTING COLORS (COLOR SELECTOR TOOL)

In this section we will present in more detail the usage of color selector tool that is included in "Color" tab of "Tools → Options" and acts as a selector for the colors that the user desires. You can select colors for any item include in display items. Click on the arrow that is next to the already used color. A color selection dialog appears. On the top area of this dialog you can select to have the default color, in case you have already changed it. You can also select one of the colors that are ready to be selected with one click. You can also press Custom color in order to choose or create one color that is not included among these Basic colors.
Custom color selection window consists of 2 tabs. The standard tab contains a wider range of readymade colors. There is also on the left bottom corner a preview area where you can see your old color in comparison with the new. You can also select a color using color picker tool to select any color that is used on any place on your screen.

**Custom color** tab, gives you the ability to select any color from the rainbow color container by a single click. Use the arrow next horizontal line in order to light up the color or make it heavier. You can also type the exact code number of the color you want on the Red – Green – Blue / Hue – Sat – Lum fields and produce the color you want. Color pick tool, also exists in custom color tab. Finally you can view the new color in comparison to the older at the bottom right corner of the window. When you have selected a color just press "Ok" button.
OUTLINE WIDTH

Sometimes when designing from scratch very complex designs the width of the lines of the design may not very helpful. By using the respective arrows we increase or decrease the width of the outlines. This way we can adjust the design lines to match our personal preferences. Using the first control we can adjust the outline width of the selected object, using the second one the outline width in node editing mode and using the last one we can adjust the width of the lines while digitizing.

Workspace

In this tab we can select which workspace components will remain visible when we press Space key that is used in order to hide workspace components.
Figure 9.16
Options tab

Options dialog box showing the Options tab with checkboxes for Toolbars and Rollups. The Toolbars section includes checkboxes for 'Standard', 'Special functions', 'Modes', 'Cross stitch', and 'Status bar'. The Rollups section includes checkboxes for 'Properties', 'Transform', 'Image map', 'Sequence manager', and 'Font editor'.
Chapter 10 - Editing embroidery designs

Introduction

In this chapter we will analyze the way that you can edit embroidery designs with any stitch type that Wings’ modular® supports. In addition we will discuss how you can make artistic designs using the transformation tools of Wings’ modular®.

Create Artistic Designs with transformation tools

Using the transformation tools of Wings’ modular® you can create Artistic design easily. In this section we will show how easily you can create the wreath of an embroidery design. The result of the design will look like the following figure 6.1.

In order to create this artistic embroidery design, we used the flower in the middle and one butterfly. The initial state of the design was look like the following figure 6.2.

In order to create the Artistic design you have to follow the steps:
1. Select the butterfly design, and pause your mouse over the corners of highlight rectangle in order the rotation handles to appear.

2. Move the rotation center of the design and place it at the middle of the flower design.

3. Now, drag the upper right rotation handle and rotate it from left to right until the butterfly is placed next to the previous one. While rotating the butterfly and before releasing the mouse click, you have to press the right mouse button to duplicate it. A rotated copy of the design appears next to the original butterfly design.

   Another way to rotate the design is from the "Tranform" toolbar. Use "Rotation" option to set the exact angle you want the design to be rotated and apply the rotation to a duplicate of the butterfly design.

4. To avoid doing the same transformation again and again, you can activate the "Repeat last transformation" option from the "Edit" menu or press the "R" key from the keyboard. This option will do the job for you and will repeat the rotation and duplication of the design in perfect symmetry.

5. When you finish applying the "Repeat last transformation" option you will end up with an Artistic design that took less than a minute to create.

---

**Artistic Mirroring designs**
Another way to create artistic embroidery designs is by using mirroring in combination with the other transformation tools. We will analyze an example that will show how easily you can create a design using simple shapes and the tools of Wings’ modular®.

Initially you will have to create or import an existing embroidery design like the one shown in the figure below.

Move the rotation center of the design outside of the design on the vertical axis. After that you will have to place your mouse over a corner of the highlight rectangle in order to activate the rotation handles. Grab the low right rotation handle and rotate the design anticlockwise while right clicking with the mouse in order to create a rotated copy of the design.

Select both designs by holding the "Shift" or the "Ctrl" key and by dragging the low middle handler of the "selection rectangle" upwards you will start creating the horizontal mirror of the design. If you hold the "Ctrl" key also while dragging you will activate the snapping tool that will snap at every 25% of mirroring enlargement. This tool will help you to create an accurate size mirror of the design. Before releasing the mouse right click once for a mirrored copy to be created.
If you find the above procedure difficult there is another way to do the same thing using the "Scale" tools of Transform rollup. Select the design, click on the "Mirror Y" button and then the "Apply to Duplicate" button. On the workspace a copy of the mirrored design will appear over the source design. Now the only thing that you have to do is to move the duplicated design and place it above the source design.

After that you have to select again the entire design and follow a similar procedure to create a vertical mirror of the design. This time you have to drag the middle right selection handler and drag it to the left. Again, hold the "Ctrl" key to help you create an accurate size mirror of the design and before release the mouse click, right click once for a copy of the mirrored design to be created.

You can do the same thing using the "Scale" tools of transform rollup. As you can see we have created an artistic frame by using a simple design. To finish with the embroidery design we will add an embroidery design in the middle as shown in the figure below.

You can use your imagination and create any design you want.
Appendix A: Glossary

In the Glossary you can find explanation of the terminology that is used in the manual.

Cancel

By pressing the Cancel button, you can discard the changes you have made on the current dialog.

Field types

In Wings’ modular® Object properties rollup there are two types of fields:

- Numeric fields
  
  These types of fields are accepting only numbers. To change a numeric parameter you have to click on it and type by the keyboard the number that this parameter will be. Another way to change the value of a numeric field is to use the arrows on the right side. Also the value of this field can be changed by using the scrolling wheel of the mouse.

- Logical fields
  
  The logical fields accept two values, Yes or No. This way you can specify if the parameter will be true or false. To change the value of this type of field you have to click on it and on the following menu select the value that you wish.

Mouse Terminology

The typical mouse features two buttons on top that register clicks and a trackball underneath that registers movement. Here is some mouse terminology that will be used in this manual.

- To move your mouse is to move it without pressing any buttons.
- To click is to press and immediately release the left mouse button without moving the mouse. For example, you click a tool icon to select a tool.
- To right-click is to press and release the right mouse button. This is frequently used to access special commands not visible on the menu.
- To double-click is to press and release the left mouse button twice in rapid succession without moving the mouse.
- To click-and-drag is to press the left mouse button, hold it down, move the mouse to a new position, and release the button. This is used to move a block, a stitch, or a node.
By pressing the OK button, you can apply the changes you have made on the current dialog.

**Scroll bar**

This scroll bar appears in many places in the program and helps you to change parameters. For example, when you want to change the density of a punching object, you have to specify how much the density will be. Near the scroll bar or on top of it, appears a display box indicating the value you specify in text.

1. Click to increase one scale unit.
2. Click to increase ten scale units.
3. Drag to move to the point you want.
4. Click to decrease ten scale units.
5. Click to decrease one scale unit.

**Stitch data Objects**

Stitch data objects are the parts of a design that don’t have any outline information. That means that for these objects the only known information is the movements of the frame.

*For example:* The objects of a design which was loaded from a machine disk, have only stitch data information.

In Wings’ modular® software it is possible to have Stitch data and Punching data objects in the same design.

Additionally, there are functions that are not active in both types of objects or there are functioning differently.

**Track – bar**

This track bar appears in many places in the program and helps you to change parameters. For example, when you want to change the stitch count of a design, you have to specify the percentage of increase or decrease in the
number of stitches. Near the scroll bar appears a display box indicating the value you specify in text.

1. Click to increase ten scale units.
2. Drag to move to the point you want.
3. Click to decrease ten scale units.

Also you can change the value of the track bar by pressing the Left & Right arrows of the keyboard.

**Punching data objects**

Punching data objects are the parts of a design that has outline information. That means that for these objects the known data is the area and the stitch type that will be used, in order to be filled with stitches.

*For example:* The objects of a design which were created with Wings’ modular® software, have only punching data information.

**Important notice:** In any transform of a punching object, the program recalculates the objects. This way the punching objects keep the same high quality.

In Wings’ modular® software it is possible to have Stitch data and Punching data objects in the same design.

More over there are functions that are not active in both types of objects or there are functioning differently.

**What is a section**

A section is a part of an object. In order to create an object you have to punch its sections. The program automatically recognizes the closest or the connecting points of the sections in order to create the object and make the branches. The exit and entries point between the sections cannot be changed. In this case you have to break the selected object to its sections.

A simple example of section you can see below.
In the given example with red and blue line can be seen the two sections. The colors were selected in order to explain with the best way the meaning of the sections and the reason why they are needed.

In reality all the sections of an object has the same color, belong to the same stitch type and there is not any special function between them.

**What is a node**

There are two kinds of nodes. The curve nodes which are indicated with • characters and the curve break nodes which are shown with the ■ characters. During punching all nodes that you are adding are curve nodes. If you want to add a curve break you should hold the "Shift" key from the keyboard while clicking on the point that you want. If you have placed a curve node, you can convert it to a curve break node using the node editor, which can be viewed by clicking the right mouse button over the node you wish to convert.

A node is the point indicated with the arrow in the drawing on the left.

A curve can be controlled by the tangent, which is indicated with the arrows in the drawing on the left.

**What is a direction**

The direction always indicates the way that the stitches will be sewn. The most important information is that you don't have to add nodes on satin or Zig-Zag to show the direction. The direction indicator is separate from the nodes.
This allows one part of a design to have directions in one orientation and another part with a different direction.
# Appendix B: Hot keys – Quick reference card

## General

### Main functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New design(1)</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Open design(1)</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Save design(1)</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save character into font(1)</td>
<td>Ctrl+F12</td>
</tr>
<tr>
<td>Print design(1)</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Close design (1)</td>
<td>Ctrl+F4</td>
</tr>
<tr>
<td>Close program(1)</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Help(1)</td>
<td>F1</td>
</tr>
<tr>
<td>Show Help on</td>
<td>Shift+F1</td>
</tr>
<tr>
<td>Undo changes(1)</td>
<td>Alt+Backspace / Ctrl+Z</td>
</tr>
<tr>
<td>Redo changes(1)</td>
<td>Ctrl+Shift+Z</td>
</tr>
</tbody>
</table>

### Backdrops

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide backdrop</td>
<td>Alt+1</td>
</tr>
<tr>
<td>Show Backdrop</td>
<td>Alt+2</td>
</tr>
<tr>
<td>Faded Backdrop</td>
<td>Alt+3</td>
</tr>
<tr>
<td>Backdrop on-top</td>
<td>Alt+4</td>
</tr>
</tbody>
</table>

### Viewing tools

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crosshair</td>
<td>C</td>
</tr>
<tr>
<td>Grid(1)</td>
<td>G</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Z</td>
</tr>
<tr>
<td>Zoom previous</td>
<td>Shift+Z</td>
</tr>
<tr>
<td>Zoom all(1)</td>
<td>A</td>
</tr>
<tr>
<td>Show/Hide rollups-toolbars</td>
<td>Space</td>
</tr>
<tr>
<td>Measure(1)</td>
<td>Shift+Right Click</td>
</tr>
<tr>
<td>3D Preview</td>
<td>P</td>
</tr>
<tr>
<td>Design info</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Lasso selection tool</td>
<td>L</td>
</tr>
</tbody>
</table>

### Other

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Presets(2)(3)</td>
<td>E / Num *</td>
</tr>
</tbody>
</table>

### Switch to

<table>
<thead>
<tr>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object editor</td>
<td>B</td>
</tr>
<tr>
<td>Stitch editor</td>
<td>M</td>
</tr>
<tr>
<td>Node editor</td>
<td>N</td>
</tr>
<tr>
<td>Toggle between open windows(Forward)</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Toggle between open windows(Backward)</td>
<td>Ctrl+shift+Tab</td>
</tr>
</tbody>
</table>

(1) These shortcuts do not work during digitizing
(2) Not active in stitch editor
(3) Not active in Node editor
(4) Active while auto-digitizing
## Appendix B: Hot keys – Quick reference card

### Object Editor

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rearrange</td>
<td></td>
</tr>
<tr>
<td>To end</td>
<td>End</td>
</tr>
<tr>
<td>To front</td>
<td>Home</td>
</tr>
<tr>
<td>1 step backward</td>
<td>Page Down</td>
</tr>
<tr>
<td>1 step forward</td>
<td>Page UP</td>
</tr>
<tr>
<td>Selection</td>
<td></td>
</tr>
<tr>
<td>Select next object</td>
<td>Tab</td>
</tr>
<tr>
<td>Select previous object</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl+Shift+I</td>
</tr>
<tr>
<td>Select all</td>
<td>Ctrl+A / Num +</td>
</tr>
<tr>
<td>Deselect all</td>
<td>Ctrl+Shift+A</td>
</tr>
<tr>
<td>Hide object(s)</td>
<td>H</td>
</tr>
<tr>
<td>Show object(s)</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Transform</td>
<td></td>
</tr>
<tr>
<td>Move object(s) 1/10 mm left</td>
<td>←</td>
</tr>
<tr>
<td>Move object(s) 1/10 mm right</td>
<td>→</td>
</tr>
<tr>
<td>Move object(s) 1/10 mm up</td>
<td>↑</td>
</tr>
<tr>
<td>Move object(s) 1/10 mm down</td>
<td>↓</td>
</tr>
<tr>
<td>Move object(s) 1 mm left</td>
<td>Ctrl+ ←</td>
</tr>
<tr>
<td>Move object(s) 1 mm right</td>
<td>Ctrl+ →</td>
</tr>
<tr>
<td>Move object(s) 1 mm up</td>
<td>Ctrl+ ↑</td>
</tr>
<tr>
<td>Move object(s) 1 mm down</td>
<td>Ctrl+ ↓</td>
</tr>
<tr>
<td>Delete object(s)</td>
<td>Del</td>
</tr>
<tr>
<td>2-point copy</td>
<td>K</td>
</tr>
<tr>
<td>Join objects</td>
<td>Ctrl + J</td>
</tr>
<tr>
<td>Break apart</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Repeat last change (Object only)</td>
<td>R</td>
</tr>
<tr>
<td>Add new objects as clones</td>
<td>Ctrl + Shift + C</td>
</tr>
<tr>
<td>Add new objects to the end</td>
<td>Ctrl + Shift + E</td>
</tr>
<tr>
<td>Copy object(s)</td>
<td>Ctrl+C / Ctrl + Ins</td>
</tr>
<tr>
<td>Cut object(s)</td>
<td>Ctrl+X / Shift + Del</td>
</tr>
<tr>
<td>Paste object(s)</td>
<td>Ctrl+V / Shift + Ins</td>
</tr>
<tr>
<td>Other</td>
<td></td>
</tr>
<tr>
<td>Duplicate design</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Duplicate design while click and drag</td>
<td>D</td>
</tr>
<tr>
<td>Input text</td>
<td>T</td>
</tr>
<tr>
<td>Input symbol from Library</td>
<td>I</td>
</tr>
<tr>
<td>Copy attributes from</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Show as continuous design</td>
<td>Ctrl+P</td>
</tr>
</tbody>
</table>

### Stitch Editor

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic stitch editing</td>
<td></td>
</tr>
<tr>
<td>Insert Stitch</td>
<td>Ins</td>
</tr>
<tr>
<td>Insert stitch at start</td>
<td>Numeric keyboard +</td>
</tr>
<tr>
<td>Delete stitch</td>
<td>Del</td>
</tr>
</tbody>
</table>
### Appendix B: Hot keys – Quick reference card

#### Selection

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go to the first stitch of the next object</td>
<td>Tab</td>
</tr>
<tr>
<td>Go to the first stitch of previous object</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Go to the first stitch of the current object</td>
<td>↓</td>
</tr>
<tr>
<td>Go to the next object</td>
<td>↑</td>
</tr>
<tr>
<td>Go to next stitch</td>
<td>→</td>
</tr>
<tr>
<td>Go to previous stitch</td>
<td>←</td>
</tr>
</tbody>
</table>

#### Node Editor

**Basic node editing**

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move node(s) 1/10 mm left</td>
<td>←</td>
</tr>
<tr>
<td>Move node(s) 1/10 mm right</td>
<td>→</td>
</tr>
<tr>
<td>Move node(s) 1/10 mm up</td>
<td>↑</td>
</tr>
<tr>
<td>Move node(s) 1/10 mm down</td>
<td>↓</td>
</tr>
<tr>
<td>Move node(s) 1mm left</td>
<td>Ctrl+ ←</td>
</tr>
<tr>
<td>Move node(s) 1mm right</td>
<td>Ctrl+ →</td>
</tr>
<tr>
<td>Move node(s) 1mm up</td>
<td>Ctrl+ ↑</td>
</tr>
<tr>
<td>Move node(s) 1mm down</td>
<td>Ctrl+ ↓</td>
</tr>
<tr>
<td>Insert node</td>
<td>Ins</td>
</tr>
<tr>
<td>Delete node(s)</td>
<td>Del</td>
</tr>
<tr>
<td>Join nodes</td>
<td>Ctrl+J</td>
</tr>
</tbody>
</table>

#### Selection

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next node</td>
<td>Tab</td>
</tr>
<tr>
<td>Previous node</td>
<td>Shift+Tab</td>
</tr>
</tbody>
</table>

#### Digitizing

**Select Special function-Needle colors**

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Needle color carrier [1] to [10]</td>
<td>1, 2, 3... 9, 0</td>
</tr>
<tr>
<td>Select Thread trim special function</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Select Stop special function</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Select Needle up special function</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Select Frame in/out special function</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Select Sequin special function</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Select Double sequin special function</td>
<td>Ctrl+Shift+5</td>
</tr>
<tr>
<td>Add a Borer special function</td>
<td>Ctrl+6</td>
</tr>
<tr>
<td>Add an appliqué special function</td>
<td>Ctrl+7</td>
</tr>
<tr>
<td>Select Low speed special function</td>
<td>Ctrl+8</td>
</tr>
<tr>
<td>Advance Borer depth ()</td>
<td>Ctrl+9</td>
</tr>
<tr>
<td>Unselect All Special Functions</td>
<td>Ctrl+0</td>
</tr>
<tr>
<td>Insert object split special function</td>
<td>Ctrl+`</td>
</tr>
<tr>
<td>Move start point</td>
<td>Ctrl+[</td>
</tr>
<tr>
<td>Move end point</td>
<td>Ctrl+]</td>
</tr>
<tr>
<td>Move Start and End point at the same time</td>
<td>X</td>
</tr>
<tr>
<td>Select Chain stitch type</td>
<td>Ctrl + &quot;,,&quot;</td>
</tr>
<tr>
<td>Select Loop stitch type</td>
<td>Ctrl + &quot;,+&quot;</td>
</tr>
</tbody>
</table>

**Start digitizing**

<table>
<thead>
<tr>
<th>Mode</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manual</td>
<td>F2</td>
</tr>
<tr>
<td>Running</td>
<td>F3</td>
</tr>
</tbody>
</table>
### Hot keys – Quick reference card

<table>
<thead>
<tr>
<th>Command</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Satin</td>
<td>F4</td>
</tr>
<tr>
<td>Step</td>
<td>F5</td>
</tr>
<tr>
<td>Zig-Zag</td>
<td>F6</td>
</tr>
<tr>
<td>Satin Serial</td>
<td>F7</td>
</tr>
<tr>
<td>Piping</td>
<td>F8</td>
</tr>
<tr>
<td>Photostitch</td>
<td>F9</td>
</tr>
<tr>
<td>Cross Stitch</td>
<td>F10</td>
</tr>
<tr>
<td>Chenille</td>
<td>F11</td>
</tr>
<tr>
<td>Auto digitize satin</td>
<td>Shift+F4</td>
</tr>
<tr>
<td>Auto digitize zig-zag</td>
<td>Shift+F6</td>
</tr>
<tr>
<td>Auto digitize piping</td>
<td>Shift+F8</td>
</tr>
</tbody>
</table>

### Corrections

<table>
<thead>
<tr>
<th>Action</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete last digitized node</td>
<td>Backspace</td>
</tr>
<tr>
<td>Hide objects</td>
<td>H</td>
</tr>
<tr>
<td>Show objects</td>
<td>Ctrl+H</td>
</tr>
</tbody>
</table>

### Insert options

<table>
<thead>
<tr>
<th>Type</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>T</td>
</tr>
<tr>
<td>Text in vector, form and block fill</td>
<td>T</td>
</tr>
<tr>
<td>Shapes</td>
<td>S</td>
</tr>
</tbody>
</table>

### Cross stitch

<table>
<thead>
<tr>
<th>Action</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Cross</td>
<td>Q</td>
</tr>
<tr>
<td>Remove Cross</td>
<td>W</td>
</tr>
<tr>
<td>Add Tacking</td>
<td>E</td>
</tr>
<tr>
<td>Remove Tacking</td>
<td>R</td>
</tr>
</tbody>
</table>

### Viewings tools

<table>
<thead>
<tr>
<th>Action</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Z</td>
</tr>
<tr>
<td>Zoom back</td>
<td>Shift + Z</td>
</tr>
</tbody>
</table>

### Auto-digitizing

<table>
<thead>
<tr>
<th>Action</th>
<th>Key(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Divide and Add direction while auto-digitizing</td>
<td>D</td>
</tr>
</tbody>
</table>
### Variable Pitch Table (100%)

<table>
<thead>
<tr>
<th>Satin Density (in mm)</th>
<th>0.35</th>
<th>0.40</th>
<th>0.45</th>
<th>0.50</th>
<th>0.55</th>
<th>0.60</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.25</td>
<td>0.70</td>
<td>0.80</td>
<td>0.90</td>
<td>1.00</td>
<td>1.10</td>
<td>1.20</td>
</tr>
<tr>
<td>0.50</td>
<td>0.60</td>
<td>0.68</td>
<td>0.77</td>
<td>0.85</td>
<td>0.94</td>
<td>1.02</td>
</tr>
<tr>
<td>0.75</td>
<td>0.53</td>
<td>0.60</td>
<td>0.68</td>
<td>0.75</td>
<td>0.83</td>
<td>0.90</td>
</tr>
<tr>
<td>1.00</td>
<td>0.46</td>
<td>0.52</td>
<td>0.59</td>
<td>0.65</td>
<td>0.72</td>
<td>0.78</td>
</tr>
<tr>
<td>1.50</td>
<td>0.40</td>
<td>0.46</td>
<td>0.52</td>
<td>0.58</td>
<td>0.63</td>
<td>0.69</td>
</tr>
<tr>
<td>2.00</td>
<td>0.37</td>
<td>0.42</td>
<td>0.47</td>
<td>0.53</td>
<td>0.58</td>
<td>0.63</td>
</tr>
<tr>
<td>2.50</td>
<td>0.35</td>
<td>0.40</td>
<td>0.45</td>
<td>0.50</td>
<td>0.55</td>
<td>0.60</td>
</tr>
<tr>
<td>3.00</td>
<td>0.35</td>
<td>0.40</td>
<td>0.45</td>
<td>0.50</td>
<td>0.55</td>
<td>0.60</td>
</tr>
<tr>
<td>3.50</td>
<td>0.35</td>
<td>0.40</td>
<td>0.45</td>
<td>0.50</td>
<td>0.55</td>
<td>0.60</td>
</tr>
<tr>
<td>4.00</td>
<td>0.35</td>
<td>0.40</td>
<td>0.45</td>
<td>0.50</td>
<td>0.55</td>
<td>0.60</td>
</tr>
<tr>
<td>4.50</td>
<td>0.34</td>
<td>0.38</td>
<td>0.43</td>
<td>0.48</td>
<td>0.53</td>
<td>0.58</td>
</tr>
<tr>
<td>5.00</td>
<td>0.33</td>
<td>0.37</td>
<td>0.42</td>
<td>0.47</td>
<td>0.51</td>
<td>0.56</td>
</tr>
<tr>
<td>5.50</td>
<td>0.32</td>
<td>0.36</td>
<td>0.41</td>
<td>0.45</td>
<td>0.50</td>
<td>0.54</td>
</tr>
<tr>
<td>6.00</td>
<td>0.30</td>
<td>0.34</td>
<td>0.38</td>
<td>0.43</td>
<td>0.47</td>
<td>0.51</td>
</tr>
<tr>
<td>6.50</td>
<td>0.28</td>
<td>0.32</td>
<td>0.36</td>
<td>0.41</td>
<td>0.45</td>
<td>0.49</td>
</tr>
<tr>
<td>7.00</td>
<td>0.27</td>
<td>0.31</td>
<td>0.35</td>
<td>0.39</td>
<td>0.43</td>
<td>0.47</td>
</tr>
<tr>
<td>7.50</td>
<td>0.27</td>
<td>0.31</td>
<td>0.35</td>
<td>0.39</td>
<td>0.43</td>
<td>0.47</td>
</tr>
<tr>
<td>8.00</td>
<td>0.27</td>
<td>0.31</td>
<td>0.35</td>
<td>0.39</td>
<td>0.43</td>
<td>0.47</td>
</tr>
</tbody>
</table>

*eg. A satin bar, with 1mm width and 0.4 density will become 0.52 density when using 100% variable pitch*
Index

2
2-point copy, 124

3
3D properties, 173

A
Active designs, 60
  Close designs, 63
  Format floppy, 62
  Print, 60
  Right click menu, 63
  Save, 62
  Write to floppy, 62
Add direction, 161
Add new object to end, 131
Add stitches, 152
All directions movement, 151
All small stitches, 154
Apply Venere cutting system, 163
Array, 131
  Circular, 134
  rectangular, 132
Artistic Designs, 186
  with Mirroring, 187
Auto-backup, 42
AutoCAD format, 49
Auto-density Apply, 127
Auto-density Reset, 128

B
Backdrop, 29
  background, 29
  preview 3D, 29
Backdrop properties, 102
  Auto-snap in digitize, 103
  Backdrop is visible, 103
  Delete, 104
  Lightness values, 103
Backdrops, 102
  Above embroidery, 104
  Backdrop properties, 102
  Below embroidery, 104
  Hide, 104
  Washed out, 104
Bitmap graphics, 30
Bitmap/Vector backdrop, 102
Break apart, 122

C
Cancel, 190
Change fabric, 105
Change satin width, 128
Change Stitch-count, 127
Change the tangents of a node, 158
Change view port, 71
Circle guidelines, 84
Clear transform, 122
Close, 53
Close all, 53
Color Management, 96
  Color tables, 97
  Current palette, 98
  Delete color, 102
  Edit Color, 102
  New Color..., 100
  Preview, 99
Color tables, 97
context menus, 20
Copy, 123
Copy object from one design to another, 126
Crosshair, 88
Current palette, 98
  Load a palette, 99
  Reset to default, 99
  Save a palette, 99
  Set as default, 99
Curve node, 160
  Curve-break node, 160
  Cut, 123

D
Delete a node, 159
Delete stitches, 152
Density adjustment
  Auto-density Apply, 127
  Auto-density Reset, 128
  Change Stitch-count, 127
Density adjustment, 127
Design
  Move Start and End, 143
  Return to design start, 143
Design, 143
  Move design end, 143
  Move design start, 143
Design info, 89
  Count exact number of stitches, 93
  Count time needed to embroider, 94
General, 89
Histogram, 95
Machine type, 94
Stitches, 92
Summary, 90
Yarn, 91
Design Start/End point, 143
Design tools color scheme, 176
  color selector tool, 182
crosshair, 182
Patch grid, 181
Selected outline, 177
Selected outline(node edit), 178
Selection rectangle, 180
Toggle grid, 179
Transformation handle, 178
Diagonal Guidelines, 83
direction, 156, 193
direction, 129
Index

Display
  Language, 169
  Monitor width, 168
  Outline quality, 169
  Viewing options, 168
Display, 167
Divide, 137
DPI, 50
Duplicate design, 126

E
Edit punching nodes
  Change the tangents of a node, 158
  Delete a node, 159
  Insert a node, 159
  Move node(s), 157
  Select Node(s), 157
Edit punching nodes, 157
Edit step pattern
  Preset steps, 142
Edit step pattern, 141
e-mail, 52
embroidery design
  using transformation tools, 186
embroidery image, 49
Embroidery process simulation, 73
  Move through object/stitches, 74
  Slow redraw, 74
Exit, 53
Export design, 52
  About, 52
  Add driver, 52
  Configure, 52
  Remove driver, 52
  Select Driver, 52
Export to 8-channel tape, 49
  Cut is...jumpstitches. See
  Maximum stitch length, 49
Export to DXF format, 49
  Fast, 173
Favorites, 33
  Add, 33
  Open, 33
Field types, 190
Filter
  In Punching data objects, 130
  In Stitch data objects, 129
Filter, 129
First Object, 74
Fit curve, 161
Format Floppy, 43
  format properties, 43
G
General
  3D preview fabric, 172
  floppy disk, 171
  Measurement system, 173
  Other options, 171
  Requested level / options, 175
  Undo levels, 172
  Update level, 175
General, 171
Glossary, 190
Grid, 87
Group, 122, 123
Guidelines, 81
  Circular, 84
  Diagonal, 83
  Horizontal, 82
  Options, 85
  Vertical, 83
H
Hide, 78
Horizontal Guidelines, 82
Hot keys
  General, 195
  Node Editor, 197
  Object Editor, 196
  Stitch Editor, 196
  Variable Pitch Table, 199
Hot keys, 195
I
Icon browser, 33
  Delete, 37
  load, 34
  Load design in Browser, 35
  Move, 37
  Open, 34
  Print selected designs, 36
  Properties, 36
  Search function, 37
  Selection in Browser, 35
  Size of Icons, 36
Icon Toolbars, 18
  Modes toolbar, 19
  Special functions toolbar, 19
  Standard toolbar, 19
Image map, 71
  zoom all, 70
  zoom-out, 70
image resolution, 50
Import 8-channel tape, 46
  Convert Stop to color changes, 46
  Cut is...jumpstitches, 46
  Delete all Slow/Fast commands, 46
  Format, 46
  Read double stops, 47
  Split objects, 46
  ZSK code Version, 47
Include fabric, 51
Insert a node, 159
Invert selection, 65
K
Key, 174
L
Last Object, 74
Last tape imported, 47
  Convert Stops to Color changes, 48
  Cut is...jumpstitches, 48
Delete all Slow/Fast commands, 48
Format, 47
Read double stops, 48
Split objects, 48
ZSK code Version, 48
light source, 77
Limits of the design, 28
load a design, 31
 Logical fields, 190
 Look in, 31

M
 measurement system, 173
 Mirror objects, 115
 Modify Satin width
 Change satin width, 128
 Direction, 129
 Modify Satin width, 128
 Mouse Terminology, 190
 Move design end, 143
 Move design start, 143
 Move design Start & End, 144
 Move node(s), 157
 Move objects, 111
 Move outline, 154
 Move stitches
 All directions movement, 151
 Snap movements, 150
 Move stitches, 150
 Moving through Objects/Stitches, 74

N
 New Color..., 100
 Color map method, 101
 Hue- Luminance - Saturation method, 100
 Red - Green - Blue method, 100
 new design, 28
 New design, 28
 new folder, 32
 Next object, 74
 Next Stitch, 74
 node, 156, 193
 Node editor, 156
 nodes editor menu
 Add direction, 161
 Curve node, 160
 Curve-break node, 160
 Fit curve, 161
 To lines, 161
 nodes editor menu, 159
 Numeric fields, 190

O
 Object editor menu
 Break apart, 122
 Object editor menu, 121
 Ok, 191
 One step backward, 120, 122
 One step forward, 120, 122
 Open a design, 31
 parameters, 33
 Preview Icon, 32
 View menu, 32
 Operations, 107
 Redo, 107
 Undo, 107
 Options
 Display, 167
 General, 171
 Key, 174
 Printing, 169
 Options, 167
 Options
 3D properties, 173
 Options
 Design tools color scheme, 176
 Order, 121
 One step backward, 122
 One step forward, 122
 To back, 121
 To front, 121

P
 Pan, 70
 Paste, 123
 Preset steps, 142
 Presets
 Add Preset, 144
 Presets, 144
 Preview 3D, 76
 Previous object, 74
 Previous stitch, 74
 Print, 54
 Print items, 55
 Printer Setup, 55
 Print items, 55
 3D-Preview, 59
 Binder space, 58
 Color changes, 56
 Company name, 57
 Design date, 59
 Fabric, 59
 Header, 56
 Information, 57
 Orientation, 57
 Sequence icons, 57
 Start point, 58
 Stitch count, 58
 Tiled printout, 59
 Printing
 Printout fonts, 170
 Printout parameters, 170
 Size of text, 170
 Printing, 54, 169
 Punching data objects, 192
 punching nodes, 157
 Punching nodes editor menu, 159

Q
 Quality, 173
 Quick reference card, 195
 Quit, 53

R
 Recent Files, 40
 Rectangle selection, 147
 Redo, 107
 Remove small
 All small stitches, 154
 Small stitches from (mm), 154
 Remove small, 153
 Remove small To (mm), 154
 Re-order, 116
Group, 123
One step backward, 120, 122
One step forward, 120, 122
Sequence manager, 116
To back, 119
To Front, 120
Ungroup, 123
Repeat last transform - R, 116
Replace stitches, 152
Reset object properties, 145
Return to design start, 143
Reverse
  In Punching data objects, 131
  In Stitch data objects, 131
Reverse, 131
Roll up windows, 21
  Image map, 21
  Sequence viewer/manager, 21
Rotate objects, 114
Ruler, 81
Safe, 173
Save, 42
Save as, 40
  .ngs, 40
  file formats, 40
Scale objects, 113
Scroll bar, 191
Search function, 37
  Customer, 38
  Design name, 37
  Designer, 38
  File date, 38
  Keyword, 37
  Limit search, 38
Search, 38
Search results, 38
Size, 38
Start from folder, 38
Stitches, 38
section, 192
Select all, 65
Select by color, 65
Select by special function, 65, 67
Select Node(s), 157
Select none, 65
Selection with mouse, 64
  selections, 64
  Invert Selection, 65
  Select all, 65
  Select by color, 65
  Select by special function, 65
  Select by stitch type, 67
  Select none, 65
Selections in stitch editor
  Rectangle selection, 147
  Single click selections, 149
  Selections in stitch editor, 146
  Send through e-mail, 52
  Sequence manager, 116
  Sequin options, 140
  Serial connection, 51
  Export design, 52
set light source, 77
  Settings, 49
  Show Filled Outlines, 79
  Show hidden objects, 78
  Show Stitch Marks, 79
  Show Up to Cursor, 79
  Single click selections, 149
  Slant objects, 115
  Slow redraw, 74
  Small stitches from (mm), 154
  Snap movements, 150
  Special functions toolbar
    Sequin options, 140
Special functions toolbar, 139
Split objects, 126
Start/End point
  Move design end, 143
  Move design start, 143
  Return to design start, 143
Start/End point, 143
Stitch data Objects, 191
Stitch editor, 146
Straighten Bitmap, 104
Template, 29
To (mm), 154
To back, 119, 121
To Front, 120, 121
To lines, 161
Toggle Grid, 87
Tools, 162
Track – bar, 191
Transform, 107
  Alignment, 110
  Move, 108
  Rotate, 108
  Scale, 109
Transform rollup, 107
Transform with mouse
  Mirror objects, 115
  Rotate objects, 114
  Slant objects, 115
Transform with mouse, 111
  Move objects, 111
Scale objects, 113
Undo, 107
Ungroup, 122, 123
Up one level, 32
Vector file formats, 30
Vector graphics, 30
Venere cutting printout, 164
Venere cutting system, 162
Vertical Guidelines, 83
View direction of stitches, 146
View your designs, 69
What is a direction, 156, 193
What is a node, 156, 193
What is a section, 192
Window, 54
  All iconic, 54
  Cascade, 54
  Tile horizontal, 54
  Tile vertical, 54
Working with files, 17
Workspace, 17
  Auto hide, 26
  Customize, 22
| Dock tool windows, 24                  | Maximum stitch length, 44                   | Zoom preset, 73                           |
| Move tool windows, 23                  | Supported file formats, 45                   | Zoom tools, 69                            |
| Write Floppy, 44                       | Templates, 44                                | Pan, 70                                   |
| Cut is … jumpstitches, 44               |                                             | Zoom all, 70                              |
| Design stitches, 45                     |                                             | Zoom back, 70                             |
| File name, 44                           |                                             | Zoom in, 69                               |
| Free stitches, 45                       | Z                                             | Zoom Out by 25%, 71                       |
| Machine-Code, 44                        | Zoom All, 70                                 | Zoom using keyboard, 73                   |
|                                          | Zoom Back, 70                                |                                           |
|                                          | Zoom In, 69                                  |                                           |
|                                          | Zoom Out, by 25%, 71                         |                                           |

Z

Zoom All, 70
Zoom Back, 70
Zoom In, 69
Zoom Out, by 25%, 71